Bad IPDM? - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

Reply
 
Thread Tools Display Modes
#1 Old 11-10-2012, 12:15 PM
kev2809
SHIFT_Lurker
 
Join Date: Jul 2012
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kev2809 is on a distinguished road
Bad IPDM?

hey guys, new here! i bought my wife a 2004 armada back in august this year...love the truck! it has 82k miles on it. recently, a few days ago actually, the truck just cut off on her while she was driving. i was at work, so i called my buddy and he towed it back it my house..thinking its just the alternator or maybe even the battery.

well i ran cables to it for a few minutes with my truck, and tried cranking it and it wouldnt turn on. it sounded normal then after a few seconds of cranking it just started clicking, like the battery was dead. over the last month, i would turn the key once and nothing, then turn it again and it would crank normal, but i didnt think anything of it. so now it just wont turn on. i read on here and on titantalk.com about swapping over the relays from the fog lights, but it still wouldnt crank.

any ideas?
kev2809 is offline  
Sponsored Links
Advertisement
 
#2 Old 11-10-2012, 04:09 PM
rsoto80
SHIFT_Hardcore
 
rsoto80's Avatar
 
Join Date: Oct 2010
Posts: 282
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
rsoto80 is on a distinguished road
Sounds like the ECM relay. There is a recall for it.

If that doesn't work then it could be the fuel pump .



04 Nissan Armada all stock

06 Dodge Charger R/T
13.8@101mph
rsoto80 is offline  
#3 Old 11-10-2012, 06:24 PM
kev2809
SHIFT_Lurker
 
Join Date: Jul 2012
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kev2809 is on a distinguished road
is the fuel pump a common problem? is it supposed to hum when you turn the key? i know on my chevys that when u turn the key but not turn the truck on, you can hear the fuel pump kick on and hum....

i did the ecm relay swap with the fog lamp relay and still nothing. i called the stealership to get a list of recalls and they never called back, but i looked up online and it only had 3 recalls for a 2004 armada, and none of them were this problem.
kev2809 is offline  
#4 Old 11-11-2012, 02:11 PM
kev2809
SHIFT_Lurker
 
Join Date: Jul 2012
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kev2809 is on a distinguished road
i found a reasonable price for the ipdm..

http://www.nissanpartszone.com/parts...4b6-zc00a.html

thinking of ordering it tomorrow and giving it a shot.
kev2809 is offline  
#5 Old 11-11-2012, 04:28 PM
blackArmada_Dxb
SHIFT_Hardcore
 
blackArmada_Dxb's Avatar
 
Join Date: Jul 2012
Location: Dubai, U.A.E
Posts: 1,612
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
blackArmada_Dxb is on a distinguished road
Does the starter kick in?
blackArmada_Dxb is offline  
#6 Old 11-12-2012, 10:29 AM
kev2809
SHIFT_Lurker
 
Join Date: Jul 2012
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kev2809 is on a distinguished road
i believe so....it sounds exactly like its gonna turn on but doesnt...then the battery starts clicking after a few seconds of cranking
kev2809 is offline  
#7 Old 11-12-2012, 11:13 AM
rsoto80
SHIFT_Hardcore
 
rsoto80's Avatar
 
Join Date: Oct 2010
Posts: 282
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
rsoto80 is on a distinguished road
Its not uncommon for the fuel pumps to go out on these trucks. If the pump is humming when you turn the key then its priming like it should but that doesn't mean it is pumping efficiently while driving.

It sounds like you have another issue though. Are you sure you swapped the right relay out with the ecm and fog light.? All the relays look the same so its easy to get confused. I had a similar problem with my 04 but when I put a new ecm relay it fixed it.



04 Nissan Armada all stock

06 Dodge Charger R/T
13.8@101mph
rsoto80 is offline  
#8 Old 11-12-2012, 12:14 PM
kev2809
SHIFT_Lurker
 
Join Date: Jul 2012
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kev2809 is on a distinguished road
i dont hear a thing coming from the pump when i turn the key..is it a distinctive hum?

im pretty sure i got them right...i swapped the second and the fourth (last) relay on the bottom of the ipdm board and still get the same result. this morning it sounded like it even turns on but right back off at the same time, then try it again and it just cranks like it wants to start but doesnt. if i never seen this ipdm horror story, i wouldve automatically assumed fuel pump.
kev2809 is offline  
#9 Old 11-12-2012, 02:58 PM
blackArmada_Dxb
SHIFT_Hardcore
 
blackArmada_Dxb's Avatar
 
Join Date: Jul 2012
Location: Dubai, U.A.E
Posts: 1,612
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
blackArmada_Dxb is on a distinguished road
Quote:
Originally Posted by rsoto80 View Post
Its not uncommon for the fuel pumps to go out on these trucks. If the pump is humming when you turn the key then its priming like it should but that doesn't mean it is pumping efficiently while driving.

It sounds like you have another issue though. Are you sure you swapped the right relay out with the ecm and fog light.? All the relays look the same so its easy to get confused. I had a similar problem with my 04 but when I put a new ecm relay it fixed it.
I agree with rsoto80. I had the same symptoms like you did and it turned out to be a bad fuel pump.
blackArmada_Dxb is offline  
#10 Old 11-12-2012, 04:47 PM
kev2809
SHIFT_Lurker
 
Join Date: Jul 2012
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kev2809 is on a distinguished road
hoping this is the fix...just picked up a fuel pump from autozone, ill post up when im done...

*sighs*
kev2809 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off