anybody replace their starter? - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
Thread Tools Display Modes
post #1 of 9 Old 11-18-2012, 07:39 PM Thread Starter
rsoto80
SHIFT_Hardcore
 
rsoto80's Avatar
 
Join Date: Oct 2010
Posts: 292
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
rsoto80 is on a distinguished road
anybody replace their starter?

My armada seems to be clicking alot more lately when starting. Before it would click every now and then. I really dont feel like taking the intake manifold off just to replace starter. Why the hell did nissan design it this way...



04 Nissan Armada all stock

06 Dodge Charger R/T
13.8@101mph
rsoto80 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 11-18-2012, 07:59 PM
ntrddragn
SHIFT_Hardcore
 
ntrddragn's Avatar
 
Join Date: Jul 2007
Location: San Diego
Posts: 3,009
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 63 Post(s)
ntrddragn is on a distinguished road
Did you check your battery? The battery connection? Just because it's clicking and you have lights and everything works doesn't mean it the starter. It's cheaper and easier to start with that.

Sent from my Galaxy Nexus using AutoGuide.Com Free App



'04 LE
ntrddragn is offline  
post #3 of 9 Old 11-18-2012, 09:05 PM Thread Starter
rsoto80
SHIFT_Hardcore
 
rsoto80's Avatar
 
Join Date: Oct 2010
Posts: 292
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
rsoto80 is on a distinguished road
Its a fresh battery...replaced about a month ago. I changed the starter relay and it still does it.



04 Nissan Armada all stock

06 Dodge Charger R/T
13.8@101mph
rsoto80 is offline  
post #4 of 9 Old 11-18-2012, 09:25 PM
ntrddragn
SHIFT_Hardcore
 
ntrddragn's Avatar
 
Join Date: Jul 2007
Location: San Diego
Posts: 3,009
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 63 Post(s)
ntrddragn is on a distinguished road
Quote:
Originally Posted by rsoto80 View Post
Its a fresh battery...replaced about a month ago. I changed the starter relay and it still does it.
Its funny my brother just called me regarding the exact same thing. Hid car tick tick when he tries and I told him get a new battery and he did. He called and said it starts but then it just tick tick again and won't turn over. Told him to make sure that it proper connection and check the terminal. He texted me back and said it was the terminals.


Edit: he too thought it was is starter. I'm just saying it might be worth to check it out.

Sent from my Galaxy Nexus using AutoGuide.Com Free App



'04 LE

Last edited by ntrddragn; 11-18-2012 at 09:33 PM.
ntrddragn is offline  
post #5 of 9 Old 11-19-2012, 01:06 AM
9balllrook
SHIFT_Hardcore
 
9balllrook's Avatar
 
Join Date: Apr 2008
Location: Ellicott City, Md
Posts: 3,435
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
9balllrook is on a distinguished road
When my starter crapped out it just died! I went to leave work and it wouldn't start, everything lit up but no sound at all. Terrible sight to see it on the back of a tow truck, but the perfect time to add the 07 intake manifold.

Jerry's 06 SE off road
07+ Intake, Injen CAI, JBA long tubes, Gibson Cat Back, UpRev tuned, 08 caliper kit w/ Frozen/Slotted Rotors, Goodridge Stainless Steel Brake Lines, Stillen 2-row/aluminum Radiator, PML pan, TransGo shift kit, 2" PRG lift, Bilstein 5100s, 20" Fuel Pump w/295/60/20 Terra Graps, 4ga. Grounding Kit, LEDs & HIDs, Kenwood DNX-9960 Alpine PDX amps, Kef separates,
(2) underseat subs w/Kenwood 10' slims, Twin Stinger Batteries, remote start & protection by Python

9balllrook is offline  
post #6 of 9 Old 11-19-2012, 01:32 AM
gt-leo
SHIFT_Hardcore
 
Join Date: Jul 2009
Posts: 280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
gt-leo is on a distinguished road
Mine did!!!

I have an 04. Mine died around late 2009. It would click then start. Got worse after a couple months until one day my family and I went out for lunch and got stranded. It clicked away for about 45 minutes. I tried to reach the starter to get a stick to hit it some but the location is retarded and couldnt reach it.

I removed the starter had it rebuilt. A shop rebuilt it in 2 hours. It wasn't the starter motor that broke though. It was the solenoid that pushes the gearing out that was broken. If you already checked the connection and battery is good. It's time to remove the intake manifold. And I agree with you it's a stupid design. Don't wait like I did and get stranded. Be careful not to drop anything down the intake holes.
gt-leo is offline  
post #7 of 9 Old 11-19-2012, 08:11 AM Thread Starter
rsoto80
SHIFT_Hardcore
 
rsoto80's Avatar
 
Join Date: Oct 2010
Posts: 292
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
rsoto80 is on a distinguished road
My battery terminals are clean and tightened down.

I might just pay my brother to replace it.



04 Nissan Armada all stock

06 Dodge Charger R/T
13.8@101mph
rsoto80 is offline  
post #8 of 9 Old 11-19-2012, 08:15 AM Thread Starter
rsoto80
SHIFT_Hardcore
 
rsoto80's Avatar
 
Join Date: Oct 2010
Posts: 292
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
rsoto80 is on a distinguished road
Quote:
Originally Posted by gt-leo View Post
I have an 04. Mine died around late 2009. It would click then start. Got worse after a couple months until one day my family and I went out for lunch and got stranded. It clicked away for about 45 minutes. I tried to reach the starter to get a stick to hit it some but the location is retarded and couldnt reach it.

I removed the starter had it rebuilt. A shop rebuilt it in 2 hours. It wasn't the starter motor that broke though. It was the solenoid that pushes the gearing out that was broken. If you already checked the connection and battery is good. It's time to remove the intake manifold. And I agree with you it's a stupid design. Don't wait like I did and get stranded. Be careful not to drop anything down the intake holes.
Did you drain your coolant first?



04 Nissan Armada all stock

06 Dodge Charger R/T
13.8@101mph
rsoto80 is offline  
post #9 of 9 Old 11-19-2012, 01:42 PM
gt-leo
SHIFT_Hardcore
 
Join Date: Jul 2009
Posts: 280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
gt-leo is on a distinguished road
Nope

No need to drain anything. The plastic intake is just an air tunnel. Nothing else running through it besides air. Was kind of a pain in the butt to remove one of the starter bolts though. I went and got a 2 feet 3/8" extension to reach the bolt and spun it from the bottom of the trans. With a swivel too. Good luck!
gt-leo is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off