need some suggestions on mada strut being stuck - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
Thread Tools Display Modes
post #1 of 10 Old 11-27-2012, 07:54 PM Thread Starter
Cash2005
SHIFT_Newbie
 
Cash2005's Avatar
 
Join Date: Jan 2011
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Cash2005 is on a distinguished road
need some suggestions on mada strut being stuck

Hi,

Ive got my 2005 mada up on jacks atm. I am following this thread on removal and installation. http://www.clubarmada.com/forums/showthread.php?t=17919
I have the 3 bolts off and the lower nut and bolt and have tried to lever it out with a 2x4 but it aint budging on the lower part of the strut where the big nut and bolt connects to the lower arm assembly. I can see the 3 bolts on the top moving down when I apply leverage but it only goes so far.

Any suggestions on what I may be doing wrong?

Thanks

edit. I have only one side jacked up. I just read something about a swaybar and both side need to be raised. But odd thing is, I tried hammering the lower strut to realign the holes in case I have to put it back together and it wont even budge even a 1/32"

Last edited by Cash2005; 11-27-2012 at 08:00 PM. Reason: add info
Cash2005 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 11-27-2012, 08:00 PM
ntrddragn
SHIFT_Hardcore
 
ntrddragn's Avatar
 
Join Date: Jul 2007
Location: San Diego
Posts: 3,023
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 67 Post(s)
ntrddragn is on a distinguished road
I just pushed down in the lower arm and have someone else tap it out.

Sent from my Galaxy Nexus using AutoGuide.Com Free App



'04 LE
ntrddragn is offline  
post #3 of 10 Old 11-27-2012, 09:36 PM
Kooshtaka
SHIFT_Hardcore
 
Kooshtaka's Avatar
 
Join Date: May 2009
Location: Juneau, AK
Posts: 2,603
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 60 Post(s)
Kooshtaka is on a distinguished road
What I did was stand on the 2x4 while my friend simply removed the coil over... no banging necessary... did you unhook all the abs wires? completely remove top nuts and bottom bolt?

'05 Mada LE Slate
Mods Done: UpRev, Bilstein 5100s in front, PRG 2" rear spaces, R1 Premium Drilled & Slotted Rotors, PosiQuite pads, Volant GenII CAI, 8K HID Lows, LEDs by ArmaDen, 3k HID Fogs, and Delete middle row console.
Mods in progress: JBA LT, PRT 300-cell hi-flo cat'd b-pipes, Borla xlr-1 muffler w/custom tubing, LED Engine Bay LEDs, Custom Suspension Lift by PRG, Custom PRG front & rear shocks, Custom PRG Rear springs.
Mods in contemplation: GoodHood or custom hood, Steel front and rear bumpers, upgraded front springs, Custom roof rack and cargo basket, Additional lighting.
Kooshtaka is online now  
post #4 of 10 Old 11-27-2012, 10:47 PM
ntrddragn
SHIFT_Hardcore
 
ntrddragn's Avatar
 
Join Date: Jul 2007
Location: San Diego
Posts: 3,023
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 67 Post(s)
ntrddragn is on a distinguished road
Quote:
Originally Posted by Kooshtaka View Post
What I did was stand on the 2x4 while my friend simply removed the coil over... no banging necessary... did you unhook all the abs wires? completely remove top nuts and bottom bolt?
I like to bang things. Its a man thing. LOL

Sent from my Galaxy Nexus using AutoGuide.Com Free App



'04 LE
ntrddragn is offline  
post #5 of 10 Old 11-28-2012, 02:42 AM Thread Starter
Cash2005
SHIFT_Newbie
 
Cash2005's Avatar
 
Join Date: Jan 2011
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Cash2005 is on a distinguished road
Hi, thanks guys.

I had to put it all back together so I could drive somewhere.
But I think ive got it figured out now. Its alot easier when my wife was here to help me leverage the 2x4 and then I could move the lower strut end.

Quote:
did you unhook all the abs wires? completely remove top nuts and bottom bolt?
I did not touch any wires or hoses.

Quote:
I like to bang things. Its a man thing. LOL
I like my hammers too
Cash2005 is offline  
post #6 of 10 Old 11-28-2012, 03:29 AM
Kooshtaka
SHIFT_Hardcore
 
Kooshtaka's Avatar
 
Join Date: May 2009
Location: Juneau, AK
Posts: 2,603
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 60 Post(s)
Kooshtaka is on a distinguished road
Quote:
Originally Posted by ntrddragn View Post
I like to bang things. Its a man thing. LOL

Sent from my Galaxy Nexus using AutoGuide.Com Free App
lol that's what she said

Sent from my SAMSUNG-SGH-I727 using AutoGuide.Com Free App

'05 Mada LE Slate
Mods Done: UpRev, Bilstein 5100s in front, PRG 2" rear spaces, R1 Premium Drilled & Slotted Rotors, PosiQuite pads, Volant GenII CAI, 8K HID Lows, LEDs by ArmaDen, 3k HID Fogs, and Delete middle row console.
Mods in progress: JBA LT, PRT 300-cell hi-flo cat'd b-pipes, Borla xlr-1 muffler w/custom tubing, LED Engine Bay LEDs, Custom Suspension Lift by PRG, Custom PRG front & rear shocks, Custom PRG Rear springs.
Mods in contemplation: GoodHood or custom hood, Steel front and rear bumpers, upgraded front springs, Custom roof rack and cargo basket, Additional lighting.
Kooshtaka is online now  
post #7 of 10 Old 11-28-2012, 12:12 PM
Pops
SHIFT_Moderator
 
Pops's Avatar
 
Join Date: Jan 2007
Location: Okc
Posts: 12,920
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 23 Post(s)
Pops is on a distinguished road
Garage
Here: http://www.clubarmada.com/forums/showthread.php?t=8988

You need to disconnect the sway bar on at least one side or you'll never get that LCA low enough to remove the shock.

- Bob
2005 Armada LE 4x4
Pops is offline  
post #8 of 10 Old 11-28-2012, 12:43 PM
drewcs
SHIFT_Hardcore
 
drewcs's Avatar
 
Join Date: Feb 2010
Location: British Columbia, Canada
Posts: 535
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
drewcs is on a distinguished road
I agree with Pops. Piece of cake once you disconnect the sway bar.

'06 LE, Airaid MXP CAI w/dry filter - BullyDog GT w/regular tune - 20" Titan wheels w/Cooper ATP's - Int/Ext LED conversion - 5000K HID low beams - Bilstein HD - Amsoil Synthetic everywhere - Power Stop drilled/slotted rotors w/ceramics pads
drewcs is offline  
post #9 of 10 Old 11-28-2012, 01:04 PM
Kooshtaka
SHIFT_Hardcore
 
Kooshtaka's Avatar
 
Join Date: May 2009
Location: Juneau, AK
Posts: 2,603
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 60 Post(s)
Kooshtaka is on a distinguished road
It worked fine for me using the a long bit of 2x4 and using that to lever the lower control arm down... didn't disconnect the sway bar. getting the 5100s in at the highest setting was a bit fun though. haha.

'05 Mada LE Slate
Mods Done: UpRev, Bilstein 5100s in front, PRG 2" rear spaces, R1 Premium Drilled & Slotted Rotors, PosiQuite pads, Volant GenII CAI, 8K HID Lows, LEDs by ArmaDen, 3k HID Fogs, and Delete middle row console.
Mods in progress: JBA LT, PRT 300-cell hi-flo cat'd b-pipes, Borla xlr-1 muffler w/custom tubing, LED Engine Bay LEDs, Custom Suspension Lift by PRG, Custom PRG front & rear shocks, Custom PRG Rear springs.
Mods in contemplation: GoodHood or custom hood, Steel front and rear bumpers, upgraded front springs, Custom roof rack and cargo basket, Additional lighting.
Kooshtaka is online now  
post #10 of 10 Old 11-28-2012, 06:27 PM
RocketPower
SHIFT_Lurker
 
Join Date: Sep 2010
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
RocketPower is on a distinguished road
I did it without taking off the sway bar, and you don't need a 2x4. What we did was to jack up the front two wheels so there is no tension on the sway bar. To get the extra clearance to get the strut out, just open the hood (so there is something to hold on to), and then have a friend stand on the rotor and push it down. It doesn't require a whole lot of extra clearance to get it off. The same applies when putting the new strut in. As always the first side takes much longer than the other. Have fun.
RocketPower is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off