Bad ABS on Armada!!!!! - Page 24 - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

Reply
 
Thread Tools Display Modes
post #231 of 309 Old 06-14-2012, 01:56 AM
numbay
SHIFT_Newbie
 
Join Date: Apr 2010
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
numbay is on a distinguished road
I had the brake booster replaced about a year/10K miles ago. So far so good, and wanted to see if I should keep it or not.
numbay is offline  
Sponsored Links
Advertisement
 
post #232 of 309 Old 08-21-2012, 04:31 PM
Sluggo
SHIFT_Lurker
 
Join Date: May 2008
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Sluggo is on a distinguished road
This is the second time this has happened to me with my 06.

In March 2011 my 4x4/brake/VDC lights we on and lost most of my braking braking power along with the massive clanging from the front end coming off a highway off ramp. Scared the crap out of me at the time as you dont expect to put your foot to the floor and keep going.
Dealer replaced the front left Hub and wheel speed sensor and it corrected the issue.... or so I thought

This Tuesday, I started up my truck and started to pull out of my driveway and the same clanging and loss of brake power happened although only my brake light was on this time.

Its been fine ever since so is a diagnostic going to pick up what the problem is?
Sluggo is offline  
post #233 of 309 Old 08-21-2012, 04:40 PM
BigBlack08
SHIFT_Lurker
 
Join Date: Jun 2011
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BigBlack08 is on a distinguished road
This is the same thing that happened to me about a week ago - happened twice. When you turn the truck off it resets the computer and it doesn't happen again for awhile. It will however definitely happen again. Nissan knows about the ABS issues and has not done a recall. I was at the dealership I go to today and they told me to hold on because Nissan will more than likely be doing a recall. GOOD LUCK. I had a case pending with Nissan Consumer Affairs and it was denied, I spoke with them again today and they suggested I call the Better Business Bureau. Nissan has a FB page and I have started posting my issues on there. May sound like it won't help but if enough people start to post the issue on a social networking site (as was done to Bank of America) then maybe just maybe we will start to get Nissan moving in the direction it should - taking care of their faulty ABS systems. Good luck and I pray that no one else is in a accident due to the faulty system on these Armadas.

By the way my actuator was replaced in June of 2011 and a few months prior to that I was told that their computer could not read my sensors. At that time the truck was under warranty. It no longer is under warranty at this time. However, this is not a wear and tear issue - this is a Nissan malfunction that should be handled.

Last edited by BigBlack08; 08-21-2012 at 04:44 PM.
BigBlack08 is offline  
post #234 of 309 Old 08-24-2012, 10:05 PM
Tad Wicks
SHIFT_Lurker
 
Join Date: Sep 2011
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Tad Wicks is on a distinguished road
Quote:
Originally Posted by Tad Wicks View Post
Update, We just had booster failure #4, They replaced the booster and Delta sensor. I am done with it, I no longer trust the car or the brakes. Does anybody have any experience with the Lemon Law, this is just getting ridiculous, at least 10 different trips to the dealers for brake light warnings including 4 boosters, I am fed up. Tad


To Big Black 08, with 4 booster failures and driving on #5, I too filed a claim to replace or buy back my lemon, not only was the answer "no" but more or less "F**** NO" and the horse you rode in on also. I did consult a Lemon Law attorney, they told me they had done many Armadas for all the reasons below, but they have to ascertain a value, so you can spend many hours compiling info for the attorney so that they can maybe get blue book value so my question is why??? the attorney will make money and I will get mid book, that is where I am at now. My biggest fear is that some poor soul will be hurt, maimed or killed before there will be any action, and if that happens, the powers that be at Nissan should be held criminally liable. There is more than enough info to warrant a recall and why the government has not stepped in is beyond me, OH I forgot, the government is there only to hammer the little guy not to help him. still fed up;Tad

Last edited by Tad Wicks; 08-24-2012 at 10:08 PM.
Tad Wicks is offline  
post #235 of 309 Old 11-06-2012, 10:16 PM
Pdxrealtor
SHIFT_Lurker
 
Join Date: Nov 2012
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Pdxrealtor is on a distinguished road
Is there a place to go and read about specifics? Years effected, faulty parts, etc..??
Pdxrealtor is offline  
post #236 of 309 Old 12-04-2012, 12:57 PM
petep
SHIFT_Lurker
 
Join Date: Dec 2012
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
petep is on a distinguished road
bought my armada new in 2007. Had this problem first in 2009 or so...but it was intermittant (I know now because the sensor resets when the car is turned off).

West Palm Beach Nissan said they could not replicate it and had never heard of it...

It's occured two to three times since...so after it happened last weekend, I did a search.

Low and behold, lots of posts about the armada booster/delta s sensor...even you tube videos documenting the problem.

Took it into Pompano Nissan...at first said they never heard of the problem...I suggested do a simple search...they asked me about the sound...I suggested they go to you tube...

sure enough, they did their diagnostics...guess what - the booster and delta S - quoted $671. Said there is little they can do - out of warranty, 100k miles...I asked to speak with the service manager....and they also suggested I call Nissan North America...I did call the latter and have a case number...they said they'd call back tomorrow...Just doesn;t seem right that some dealerships acknowledge the problem up from and repair for free or at a significant discount...and other act like they have never heard of the issue...

We will see...

These companies/dealers are fools if they think that people can't do a quick search to determine if there is a widespread problem. Be so much better if they would just be up front about it....
petep is offline  
post #237 of 309 Old 12-05-2012, 11:43 AM
numbay
SHIFT_Newbie
 
Join Date: Apr 2010
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
numbay is on a distinguished road
Please make sure you also add your case to the open Class Action Lawsuit. contact Jodi: Jodi@justice4you.com to add your case to the file.




Quote:
Originally Posted by petep View Post
bought my armada new in 2007. Had this problem first in 2009 or so...but it was intermittant (I know now because the sensor resets when the car is turned off).

West Palm Beach Nissan said they could not replicate it and had never heard of it...

It's occured two to three times since...so after it happened last weekend, I did a search.

Low and behold, lots of posts about the armada booster/delta s sensor...even you tube videos documenting the problem.

Took it into Pompano Nissan...at first said they never heard of the problem...I suggested do a simple search...they asked me about the sound...I suggested they go to you tube...

sure enough, they did their diagnostics...guess what - the booster and delta S - quoted $671. Said there is little they can do - out of warranty, 100k miles...I asked to speak with the service manager....and they also suggested I call Nissan North America...I did call the latter and have a case number...they said they'd call back tomorrow...Just doesn;t seem right that some dealerships acknowledge the problem up from and repair for free or at a significant discount...and other act like they have never heard of the issue...

We will see...

These companies/dealers are fools if they think that people can't do a quick search to determine if there is a widespread problem. Be so much better if they would just be up front about it....
numbay is offline  
post #238 of 309 Old 12-11-2012, 12:40 PM
petep
SHIFT_Lurker
 
Join Date: Dec 2012
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
petep is on a distinguished road
Well Nissan North America is not a very responsive organization. I called them first on Tuesday 11/4. I spoke with a woman named Ella, very cordial, who assigned me a case number and said I'd have to speak with a regional specialist. She said I'd get a call back no later than the next morning.

No call back, so I phoned ella again. She said she'd send an email and leave the specialist another message...still no call back by the next day...called ella again.

she said she'd elevate to a supervisor...

I did get the name and extension finally of the regional specialist I was assigned to....I've left her many messages...she did finally call me back last Friday...I explained the situation, that it seems others have had this...the dealer initially said they've never heard of it....then after the diagnosis they acknowldeged yes, some years had this problem but not my 2007....

She asked if I could prove that I've had this problem in the past...if its documented with a dealer...I said no, I can't prove it...I can only say that I've had the problem occur at various times over the past 3 years...and its pretty clear that others on the internet have the same issue...

she said nissan does not rely on the internet because people can post anything, only on their dealers diagnostics...I said fine, I just need a resolution one way or the other....I did point out she is free to go to youtube, or any number of sites and she will see the same problem repreatedly...she again said they don't rely on the internet...

she said I'd hear back monday....she left me a message at 10:45am to call her back...I've called back 3x no response...

I told her I simply need an answer so I can get my car worked on....
petep is offline  
post #239 of 309 Old 12-11-2012, 01:36 PM
ntrddragn
SHIFT_Hardcore
 
ntrddragn's Avatar
 
Join Date: Jul 2007
Location: San Diego
Posts: 3,009
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 63 Post(s)
ntrddragn is on a distinguished road
Quote:
Originally Posted by petep View Post
Well Nissan North America is not a very responsive organization. I called them first on Tuesday 11/4. I spoke with a woman named Ella, very cordial, who assigned me a case number and said I'd have to speak with a regional specialist. She said I'd get a call back no later than the next morning.

No call back, so I phoned ella again. She said she'd send an email and leave the specialist another message...still no call back by the next day...called ella again.

she said she'd elevate to a supervisor...

I did get the name and extension finally of the regional specialist I was assigned to....I've left her many messages...she did finally call me back last Friday...I explained the situation, that it seems others have had this...the dealer initially said they've never heard of it....then after the diagnosis they acknowldeged yes, some years had this problem but not my 2007....

She asked if I could prove that I've had this problem in the past...if its documented with a dealer...I said no, I can't prove it...I can only say that I've had the problem occur at various times over the past 3 years...and its pretty clear that others on the internet have the same issue...

she said nissan does not rely on the internet because people can post anything, only on their dealers diagnostics...I said fine, I just need a resolution one way or the other....I did point out she is free to go to youtube, or any number of sites and she will see the same problem repreatedly...she again said they don't rely on the internet...

she said I'd hear back monday....she left me a message at 10:45am to call her back...I've called back 3x no response...

I told her I simply need an answer so I can get my car worked on....
Didn't you tell her the internet doesn't lie? LOL. Even state farm insurance commercial said so.

All joking aside..Hope you get your issue resolve.

tap tap with my galaxy nexus.



'04 LE
ntrddragn is online now  
post #240 of 309 Old 12-13-2012, 01:27 PM
petep
SHIFT_Lurker
 
Join Date: Dec 2012
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
petep is on a distinguished road
well, finally heard back from megan at nissan consumer affairs a few minutes ago. 800-343-6913 ext. 457218.

I should note I called yesterday and tried another person. He said he could see a decision has been reached in my case, but I would have to speak with megan to receive it. I explained this coming tuesday will be two weeks, with no answer, and a rental car I'm paying for...He said he can see on his computer that a decision was reached monday (today is thursday)...I asked why they couldn't just leave me a message or email me....again, he said I'd have to speak with her live....(which we already know is a problem)....

I also spoke with the service person (Jose) at pompano nissan yesterday, to let him know I'm not abandoning my vehicle, that I can't seem to get megan to return a call. He said he knows her by name, as she is the regional specialist, and sometimes they must make 30 calls before they can get her. Ridiculous.

So, the net is...they are not going to do anything for me...because I can't document that I had this problem before now....I politely said thanks. I'll be signing onto this class action suit on this issue I've been reading about.

Also note, when I did speak with her last Friday, I offered that if they pay half - roughly 350, that I'd cover the other half and move on...I just want my car back.

Heck of a company....funny thing was, I don't have a small car and was seriously considering buying a 350z in a couple months....not now....

for some reason companies cannot understand the long term value of a customer....and just how the internet and word of mouth affects future sales...
petep is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off