2011 Armada Platinum Rear Liftgate issues - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
Thread Tools Display Modes
post #1 of 5 Old 01-04-2013, 01:32 PM Thread Starter
Katcon
SHIFT_Lurker
 
Join Date: Jan 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Katcon is on a distinguished road
2011 Armada Platinum Rear Liftgate issues

I have searched the forums but can't find a problem identical to mine. When I try to open the rear powered liftgate it beeps like normal and you can hear it try and open but it just unlatches and stalls out. I have tried using both the outside handle, remote switch and inside console button but all do the same thing. I have verified the rear window is closed all the way as well since others had that issue. Could it be the motor? Lift struts/shocks? I also get the beeping noise after washing it that several on here have reported so could water have gotten into the motor and shorted it out? It sounds like the motor tries to open the gate but then stops. HELP!
Katcon is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-04-2013, 04:58 PM Thread Starter
Katcon
SHIFT_Lurker
 
Join Date: Jan 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Katcon is on a distinguished road
Anybody? Does it sound like the motor is shot? I hate to take it to the dealer and pay some ungodly amount if I can fix it on my own.
Katcon is offline  
post #3 of 5 Old 01-04-2013, 05:12 PM
2011Platty
SHIFT_Lurker
 
Join Date: Sep 2011
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2011Platty is on a distinguished road
I would think your warranty would cover any repairs.
2011Platty is offline  
post #4 of 5 Old 01-04-2013, 09:21 PM
JDFSU
SHIFT_Hardcore
 
JDFSU's Avatar
 
Join Date: Sep 2008
Location: Lake Mary Florida
Posts: 463
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
JDFSU is on a distinguished road
Check the glass. I know if the glass is unlatched the power liftgate motor will not work. Could be a bad sensor there as well. Should be warranty unless you are past mileage.

Sent from my DROID RAZR using AutoGuide.com App

07 Granite Armada (Sold)
11 Armada Platinum Silver Lightning (sadly traded)
13 Infiniti JX35 AWD
13 VW Touareg TDI
JDFSU is offline  
post #5 of 5 Old 01-07-2013, 11:10 AM Thread Starter
Katcon
SHIFT_Lurker
 
Join Date: Jan 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Katcon is on a distinguished road
Quote:
Originally Posted by JDFSU View Post
Check the glass. I know if the glass is unlatched the power liftgate motor will not work. Could be a bad sensor there as well. Should be warranty unless you are past mileage.

Sent from my DROID RAZR using AutoGuide.com App

I did double check the rear glass and it's seems to be closed. When you lift up on the rear handle it beeps like normal, you can hear the motor start to work and then it stops and doesn't lift the gate at all. It's like the motor isn't strong enough or stalls out. It is just out of warranty or I would take it to the dealer.
Katcon is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off