Air Suspension - On while Driving? - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
Thread Tools Display Modes
post #1 of 4 Old 05-04-2017, 02:31 PM Thread Starter
Alex32817
SHIFT_Lurker
 
Join Date: Feb 2014
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Alex32817 is on a distinguished road
Garage
Air Suspension - On while Driving?

I know it might be hard to find this out, but does anyone knows if the AIR SUSPENSION that comes with the BIG TOWING PACKAGE is capable of turning itself on while the vehicle is in motion? What I mean is, when the car turns on, the pump quickly turns on at 30 seconds; on the dot. It lifts the vechicle to 16½" (at the towing mount). I am hearing my pump turn on just about every time I stop at a red light to lift. I am guessing my system has a leak. But while I am driving along the expressway with tow in place, the truck first lifts the boat, but while I drive, the chains will hit the ground, as I am loosing air. Unless I pull to the side, I am not noticing the vehicle will turn on the pump; thus my question. Does anyone know if the pump/relay turns on while the vehicle is in motion to compensate for air loss?

I have already replaced the compressor dryer, as it was leaking on one of the 2 valves. I have also replaced my left strut, as it was leaking at the other connection, but I am STILL leaking.

I turn the vehicle on at my place of work, waited 30 seconds, pump turns on, lifts car to 16½" measured at the tow mount (original), and within 15 minutes, the vehicle is at 15 5/8" with nothing to tow, just sitting at the flat parking space. So I am loosing that much air that quick. It is driving me crazy along with the mechanic working on it, as I might need to replace the other (right) strut, lines, or compressor at this point, as there is NOTHING else.

Anyone?

Thanks in advance!
Armada 2009 SE - FlexFuel, Big Tow Package
Alex32817 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-04-2017, 04:37 PM
scr38
SHIFT_Administrator
 
scr38's Avatar
 
Join Date: Oct 2004
Location: Lake Jackson, Texas
Posts: 5,191
Mentioned: 3 Post(s)
Tagged: 1 Thread(s)
Quoted: 89 Post(s)
scr38 will become famous soon enough
The system does work while in motion. Your system has a leak, that is why it comes on and lifts, then shuts off. Mix up some soap with water and brush on at all air line connections to find the leak.

2004 Armada SE, Throttle body coolant bypass, Grounding kit, modified Volant CAI with Amsoil dry element, custom engine cover, trailer brake controller, Michelin M/S2s, custom lower grill, Silver Star headlights, Bilstein HD shocks, Power Stop Drilled/Slotted Rotors, ceramic pads, Goodridge SS brake lines, interior and back-up LEDs, PLM transmission pan, trans radiator cooler by-passed, all Amsoil synthetic lubricants, Nismo headers, custom 3" SS exhaust system with high flow metallic core cats, UpRev tuner version, 318 rear wheel HP.
scr38 is offline  
post #3 of 4 Old 05-12-2017, 11:54 AM
anthracite
SHIFT_Lurker
 
Join Date: Nov 2011
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
anthracite is on a distinguished road
Yeup, you just need to find your leak.

Steve K.
anthracite is offline  
 
post #4 of 4 Old 05-18-2017, 12:01 PM Thread Starter
Alex32817
SHIFT_Lurker
 
Join Date: Feb 2014
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Alex32817 is on a distinguished road
Garage
Found several leaks. The left strut was leaking at the fitting. Leak on the back side of the compressor, on the sensor that activates the compressor. So, had to replace the strut and the compressor. Works like a charm.
Alex32817 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off