Spark Plugs Replaced - Page 3 - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

Reply
 
Thread Tools Display Modes
post #21 of 22 Old 11-11-2011, 10:48 AM
BlakSpyda
SHIFT_Moderator
 
BlakSpyda's Avatar
 
Join Date: Feb 2006
Location: MD
Posts: 13,206
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
BlakSpyda is on a distinguished road
Welcome 2fs2ns!



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BlakSpyda is offline  
Sponsored Links
Advertisement
 
post #22 of 22 Old 01-07-2012, 09:41 AM
Driftwood
SHIFT_Lurker
 
Driftwood's Avatar
 
Join Date: Sep 2007
Location: 'Gon
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Driftwood is on a distinguished road
My 2004 LE has 109,000 miles on it now. Thinking of doing the plug replacement myself. I am considering using Platinum 2 Bosch plugs. Has anyone used them?
Also, I've noticed a intermittent vibration while at idle. Almost like engine stumble. It comes and goes every 30 seconds. Is this a system of dirty fuel injectors?
http://www.boschautoparts.com/sparkp...Platinum2.aspx


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2004 Nissan Pathfinder Armada LE

Last edited by Driftwood; 01-07-2012 at 01:48 PM.
Driftwood is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off