[SOLVED] Auto Leveling Suspension Sag - Sticky please? - Page 2 - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

Reply
 
Thread Tools Display Modes
post #11 of 11 Old 09-08-2016, 06:21 PM
cramblda
SHIFT_Lurker
 
Join Date: Mar 2014
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
cramblda is on a distinguished road
Which O-Ring

I took the factory o-ring to Seal Source (an O-Ring and Seal specialty shop) in Portland, OR. They couldn't match the factory o-ring exactly, but they gave me their closest match which had a slightly smaller inside diameter and was just slightly thicker in the cross section.

They said the o-ring size was 4 x 8 mm. ( I think it's a 4mm ID, 8mm OD, and 2mm Cross Section )

I replaced all four o-rings. One at each shock, and the two on the air pump. The two in the shocks were pretty hard to get the white tube back in the fitting, I assume due to the tighter inside diameter/cross section. When I pushed the fitting into the shock, I could feel the o-ring springing the fitting back out a bit. I did use some of the TFE paste on the white tube that inserts into the fitting / o-ring. I tried both with and without TFE, didn't make the fit any easier without, so I decided to stick with a little TFE paste for extra seal. I eventually was able to get the tubes to slide in on the shocks. The Air Pump fittings seemed to fit fairly easy, even with the new o-rings.

The air seems to be holding, haven't checked with a trailer on yet.

David
cramblda is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off