4WD Light Turns On/Stays On - Page 3 - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

Reply
 
Thread Tools Display Modes
post #21 of 25 Old 04-26-2015, 08:50 PM
bsljacques
SHIFT_Hardcore
 
bsljacques's Avatar
 
Join Date: Jul 2009
Location: Fayetteville, AR
Posts: 353
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
bsljacques is on a distinguished road
I must of just gotten some water in that area and it cause it to do that. IT's all back to normal now. Just need to be more cautious with washing the engine compartment.

But I did see my front pinion seal is leaking again....just had that fixed back in 2012....Oh well see what the dealer will charge to fix it...or maybe I will just do it myself this time.

--------------------------------------------------------------------------------------------------------------------------
2006 Nissan Armada LE 4x4 Navi (wife's mall crawler...better known as = Silver Bullet) OEM SiriusXM Sat Radio install, M&D DVD install, HID conversion, Frozen Rotors upgrade with wildwood areo6 calipers (front) and Bilsteins HD's, Goodridge SS brake lines, JBA LT headers with Cajun B-pipes and UpRev and AirRaid MXP Intake System, .....Level 10 Converter and VB upgrade next!!!
bsljacques is offline  
Sponsored Links
Advertisement
 
post #22 of 25 Old 04-28-2015, 11:10 PM
thalia
SHIFT_Newbie
 
Join Date: Apr 2012
Location: West Jordan Utah
Posts: 98
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
thalia is on a distinguished road
Garage
I have this same issue Thanks for the heads up now I have to find it all I see behind my battery is a big black box I assume the relays are in there? Really dirty engine. I hope it is the same in my O8.
thalia is offline  
post #23 of 25 Old 04-28-2015, 11:39 PM
thalia
SHIFT_Newbie
 
Join Date: Apr 2012
Location: West Jordan Utah
Posts: 98
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
thalia is on a distinguished road
Garage
Wait a minute I pull the box off this is what I find I do not see anything labeled 4WD transfer case maybe you guys can help me out? Here are the pics? Anybody? Thanks in advance!
Attached Thumbnails
Click image for larger version

Name:	armada fuse box.jpg
Views:	1323
Size:	128.9 KB
ID:	27737   Click image for larger version

Name:	armada fuse box2.jpg
Views:	1303
Size:	111.9 KB
ID:	27745   Click image for larger version

Name:	armada fuse box3.jpg
Views:	1295
Size:	123.1 KB
ID:	27753   Click image for larger version

Name:	armada fuse box4.jpg
Views:	1297
Size:	171.2 KB
ID:	27761  
thalia is offline  
 
post #24 of 25 Old 04-29-2015, 10:40 AM
AnandQX56
SHIFT_Lurker
 
Join Date: Jan 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AnandQX56 is on a distinguished road
The relays are actually not located in that box. They are actually on the fender side of the battery. To the left of the battery if you are standing in front of the car looking in. You will have to remove the battery in order to access them.
AnandQX56 is offline  
post #25 of 25 Old 05-01-2015, 10:51 PM
thalia
SHIFT_Newbie
 
Join Date: Apr 2012
Location: West Jordan Utah
Posts: 98
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
thalia is on a distinguished road
Garage
Thanks I will look at it this weekend!
thalia is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off