Heater not working - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
Thread Tools Display Modes
#1 Old 12-30-2008, 12:48 AM
888
SHIFT_Lurker
 
Join Date: Dec 2008
Location: Bakersfield
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
888 is on a distinguished road
Heater not working

Hi there! I am a new member of this site which I heard from my friend that has an Armada as well. Really happy to be a part of your family/group and looking forward in meeting members and looking forward in learning more about our SUV.

I have a problem with the heating of my '07 Armada. The heater just quit on me. It is really hard to use the vehicle right now co'z it's really cold here in Bakersfield. And using the SUV in the morning and going home from work is really something. I am wondering if any of you guys have any idea of what's wrong with my heater. And yes, I did all that I am suppose to do to run the heater. It was working fine last week and all of a sudden it stops working. She already have 70k miles. Yeah....yeah, I know, she already has a lot of miles. What can I do, I drive 150 miles a day. I am also wondering if the dealership will still fix the problem under warranty... Any input from you guys will be deeply appreciated. Thanks in advance!

ops! mods, I think I might have put this in the wrong section. Pls feel free to move it to the right section. Thanks!
888 is offline  
Sponsored Links
Advertisement
 
#2 Old 12-31-2008, 12:16 AM
andy
SHIFT_Hardcore
 
andy's Avatar
 
Join Date: Nov 2004
Location: Los Angeles
Posts: 1,223
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
andy is on a distinguished road
Just make sure your coolant if all the way to full. If your coolant is even a little below full, heater stops working. Just look at the white plastic overflow thing, that's where you will top it off. Prestone has a 50/50 premixed container now. Just pour it in.
andy is offline  
#3 Old 12-31-2008, 12:28 AM
888
SHIFT_Lurker
 
Join Date: Dec 2008
Location: Bakersfield
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
888 is on a distinguished road
Thanks for that tip! I will try that tom.
888 is offline  
#4 Old 12-31-2008, 02:55 AM
DBL047
SHIFT_Enthusiast
 
DBL047's Avatar
 
Join Date: Jun 2007
Location: Happy Valley, OR
Posts: 195
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
DBL047 is on a distinguished road
Send a message via AIM to DBL047 Send a message via Skype™ to DBL047
Welcome to the club and that is good advice... you definitely need to make sure you have good coolant and make sure its full or the heating will not work. But is it totally not working or intermittent?
DBL047 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off