Couple of issues - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
Thread Tools Display Modes
post #1 of 7 Old 11-10-2012, 08:49 PM Thread Starter
Pdxrealtor
SHIFT_Lurker
 
Join Date: Nov 2012
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Pdxrealtor is on a distinguished road
Couple of issues

So I drove the Armada that I've had my eye on for a second time today. Got to drive it for about 45 minutes and really get a good look at things.


A couple of things aren't right and I was wondering if anyone knows anything about them.

1) The back windows, both of them, roll down just fine but roll up very slow. They get to a point where you wonder if they're going to even finish rolling up.

2) Randomly there will be a loud clicking that comes from the gauge cluster area. Nothing is can be felt, and it can't be repeated at will.

3) The 4wd drive light on the cluster is always on. I ran it through the 4hi and low settings and could feel it changing modes. Drove it in both modes and it was activated. The seller says the light is on because the battery was dead, which it was. Any truth to that? I've never seen a light come on and stay on due to a dead battery.

It's a 2010 platinum.

Thanks guys!

Last edited by Pdxrealtor; 11-10-2012 at 08:52 PM.
Pdxrealtor is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 11-10-2012, 10:58 PM
hiperbeast
SHIFT_Newbie
 
Join Date: Feb 2012
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
hiperbeast is on a distinguished road
i have an 06 le and my rear windows do the exact same thing. no big deal, they work fine, but it is a little weird.
hiperbeast is offline  
post #3 of 7 Old 11-11-2012, 01:03 AM
Pops
SHIFT_Moderator
 
Pops's Avatar
 
Join Date: Jan 2007
Location: Okc
Posts: 12,920
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 23 Post(s)
Pops is on a distinguished road
Garage
Is there a reason those fools can't put in a new battery to sell the car?? Those few that have had electrical glitches ended up with a whole lotta problems. I would want it all to be proven to be good before signing off on it.

- Bob
2005 Armada LE 4x4
Pops is offline  
post #4 of 7 Old 11-11-2012, 09:00 PM
marctronixx
SHIFT_Hardcore
 
Join Date: Aug 2006
Posts: 3,361
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 37 Post(s)
marctronixx is on a distinguished road
yeah car fax the sucka?

get eh scan tool and see if you get an error form the 4WD system.

the clicking in the dash sounds like the vent baffle motor. those motors are connected to a plastic gear thats attached to the door to direct aif flow. sometimes the door can get stuck in a position and the click could be the motor jumping the teeth on the plastic gear.

run the HVAC with the fan on the highest speed (does not have to be on A/C) and cycle through the air flow settings (floor, dash, top/defog), giving a few seconds in each cycle. see if you hear any clicks or not. thos has happened in other parts of the HVAC system also.
marctronixx is offline  
post #5 of 7 Old 11-12-2012, 02:03 AM
Snizzle
SHIFT_Hardcore
 
Snizzle's Avatar
 
Join Date: Apr 2009
Location: Seattle Wa
Posts: 251
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Snizzle is on a distinguished road
Try test driving a different Armada and see if you notice a difference.

Snizzle is offline  
post #6 of 7 Old 11-12-2012, 02:30 PM Thread Starter
Pdxrealtor
SHIFT_Lurker
 
Join Date: Nov 2012
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Pdxrealtor is on a distinguished road
All great suggestions and info, will do. The rear windows being so slow isn't right, but good to know they keep working.

A little history. The truck is a theft recovery with clean title. I've yet to check carfax since I haven't sold the hummer. The price right now is 27k w 35k on the clock. If the carfax shows theft recovery which I'm thinking it will, I might forego the purchase anyways. Unless I can get it for less. I figure at 27 k I'm at about 8k discount and I'd need a bit more to feel good about the resale.

I've yet to have it checked out at a shop. The under side looks brand new, the panels are straight, doesn't appear to have had body work done. Seller says the only thing they did was turn the rotors.

I've talked to the Nissan dealer the truck was bought at and it was serviced regularly, most recalls have been completed and some warranty work was done.

It's a big if right now. There's a big piece of hood liner that's gone right above the engine. Could have been from heat for all I know. I need more time for investigative work. It's a risk buying a theft recovery.

Thanks again all. Ill keep you posted.
Pdxrealtor is offline  
post #7 of 7 Old 11-12-2012, 03:34 PM
Pops
SHIFT_Moderator
 
Pops's Avatar
 
Join Date: Jan 2007
Location: Okc
Posts: 12,920
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 23 Post(s)
Pops is on a distinguished road
Garage
Quote:
Originally Posted by Pdxrealtor View Post
.... There's a big piece of hood liner that's gone right above the engine. Could have been from heat for all I know. ...
Mine fell off too, the plastic clips all broke and eventually fell out so I just took it out and put it in a box to mess with later if I decide to put it back on.

- Bob
2005 Armada LE 4x4
Pops is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off