Center Console Airbag Light PLEASE HELP - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
Thread Tools Display Modes
#1 Old 01-06-2013, 07:32 PM
Jayjohn24
SHIFT_Lurker
 
Join Date: Nov 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Jayjohn24 is on a distinguished road
Center Console Airbag Light PLEASE HELP

I recently had a new stereo installed in my Armada. It was a large touch screen which required a double DIN install kit. So we had to take the factory radio, climate control panel and any harnesses that hooked to the center console off to put the double DIN install kit in. When we finished the install the light on the gauge cluster was flashing. I followed the procedure on an older thread and got that light to stop blinking. However, the yellow light in the center of the dash which indicates when someone is sitting in the seat only comes on when the truck is starting up. Once the truck finishes it's starting sequence, the light goes out regardless of whether someone is in the passenger seat or not! How do I get this light to function properly? Has anyone had the same issue before?
Jayjohn24 is offline  
Sponsored Links
Advertisement
 
#2 Old 01-07-2013, 08:48 PM
Olds67
SHIFT_Newbie
 
Olds67's Avatar
 
Join Date: Sep 2012
Location: Southwest Michigan
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Olds67 is on a distinguished road
I have an 07 LE and my light functions the same way. If someone is not in the seat it will turn on for a few when I start it and shut off after a few seconds. If I place something not too heavy on the seat like a bag, it will do the same thing.

Sent from my EVO using AutoGuide.Com Free App
Olds67 is offline  
#3 Old 01-07-2013, 10:12 PM
Olds67
SHIFT_Newbie
 
Olds67's Avatar
 
Join Date: Sep 2012
Location: Southwest Michigan
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Olds67 is on a distinguished road
I read through the safety section of my owners manual and it stated the front passenger airbag off light will not illuminate if unoccupied. So it seems to me it goes by weight and how the occupant is sitting in the seat. Hope this helps.

Sent from my EVO using AutoGuide.Com Free App
Olds67 is offline  
#4 Old 01-08-2013, 08:31 PM
Jayjohn24
SHIFT_Lurker
 
Join Date: Nov 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Jayjohn24 is on a distinguished road
Gotcha. However, it doesn't go on when someone is sitting there either. Any info on what could be the problem? Wondering if it's because I unplugged it?
Jayjohn24 is offline  
#5 Old 01-08-2013, 11:09 PM
Olds67
SHIFT_Newbie
 
Olds67's Avatar
 
Join Date: Sep 2012
Location: Southwest Michigan
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Olds67 is on a distinguished road
I think it is functioning correctly. Did it do something different before the install? It should not turn on unless the occupant is under a certain weight limit or not sitting in the seat correctly. I am not sure what the weight threshold is but if you place something less than 50 pounds on the seat I would assume the light would stay on. I'm by no means an expert at the airbag systems in our armadas, just trying to explain how I have noticed the light working in mine. I have done a great deal of after market electronic installs from stereos, remote starters, chips and so on for my brother's company. I learned the hard way but before any install disconect the battery and wait 15 minutes. Only reconnect once everything is put back in place. This will mitigate any issues regarding the ECU.


Sent from my EVO using AutoGuide.Com Free App
Olds67 is offline  
#6 Old 01-09-2013, 03:29 AM
marctronixx
SHIFT_Hardcore
 
Join Date: Aug 2006
Posts: 3,343
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 34 Post(s)
marctronixx is on a distinguished road
the person has to be at least 70 pounds i think for the system to detect someone. just saying this for record.

its possible something has been disconnected along the way. if you have a code scanner , connect it to the OBD port and see if you get any DTCs. Autozone or similar will have a obd scanner and you can see if you have a code there.
marctronixx is offline  
#7 Old 01-09-2013, 08:31 PM
Olds67
SHIFT_Newbie
 
Olds67's Avatar
 
Join Date: Sep 2012
Location: Southwest Michigan
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Olds67 is on a distinguished road
I had my 6 year olds sit it the front seat (while the I was parked) to see how the light functioned. I began with him out of the seat and started the truck, the light turned on for a few seconds and then shut off as usual. I then had my son sit in the seat and the light turned on and stayed on. I had him stand up and the light turned off. I had him do this a few times and the light turned on when he sat down every time and stayed on and shut off when he got out of the seat. When I sit in the seat the light does not turn on.

If you can run a similar test, that should let you know if you have an issue or not.

Sent from my EVO using AutoGuide.Com Free App
Olds67 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off