Noise in steering wheel - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
Thread Tools Display Modes
post #1 of 4 Old 02-26-2013, 06:50 PM Thread Starter
Pres56
SHIFT_Newbie
 
Join Date: Aug 2011
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Pres56 is on a distinguished road
Noise in steering wheel

So after getting the cruise control fixed which required a clock spring behind air bag to steering wheel column I am now having this like clicking sound which I just noticed today with heat off and radio off I had to have complete silent to hear which is part of reason why I may have only heard now. With radio up and heat on cant really notice but once both off u can really here it.Anyone else ever heard this when turning the wheel.


Sorry I had the wrong video link it is now correct
FYI you have to have flash enabled browser to view/hear.

http://static.photobucket.com/player...226_163815.mp4

Last edited by Pres56; 02-26-2013 at 08:45 PM.
Pres56 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 02-27-2013, 08:59 PM
lazzo70
SHIFT_Lurker
 
Join Date: Nov 2011
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
lazzo70 is on a distinguished road
I have the same noise in my 2011, its so annoying. I took it in to the the dealership and they said they adjusted the "column finisher," whatever that means. But guess what? They didnt fix a god damn thing cause as soon as i got back in the truck and turned the steering wheel...clicking... clicking left...clicking right... so what did they actually do except bill nissan for an hour on something they didnt fix. So now I have to go back and lose the truck for another day. I personally think its the spiral cable getting hung up on something behind the steering wheel, but what do i know..
lazzo70 is offline  
post #3 of 4 Old 03-01-2013, 02:21 PM Thread Starter
Pres56
SHIFT_Newbie
 
Join Date: Aug 2011
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Pres56 is on a distinguished road
Took it back to dealer one of the clips to the clock spring wire was loose. Now clipped and good to go you might want to check this out
Pres56 is offline  
post #4 of 4 Old 04-12-2013, 05:23 PM
lazzo70
SHIFT_Lurker
 
Join Date: Nov 2011
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
lazzo70 is on a distinguished road
Thanks for the info. I was finally able to bring the truck in and they replaced the spiral cable and clock spring. The noise is gone and the steering wheel actually feels nice and tight like when it was new.
lazzo70 is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off