BCI Malfunction - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 01-26-2017, 12:51 AM Thread Starter
SHIFT_Newbie
 
Join Date: Dec 2016
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
 
BCI Malfunction

Today while I was driving suddenly the BCI malfunction light came ON. I had to turn the engine off and fire it up again to make it go away. Anyone have this come up? Not sure why it popped up. Backup camera and sonar is functional.
elmatador is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 04-24-2017, 09:40 PM
SHIFT_Lurker
 
Join Date: Oct 2016
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
 
We have the same issue. Unfortunately, it comes on while driving and everything on the cluster goes crazy. Have to pull over and turn engine off and wait a couple minutes, then crank back up
wharper76 is offline  
post #3 of 11 (permalink) Old 04-25-2017, 10:23 AM Thread Starter
SHIFT_Newbie
 
Join Date: Dec 2016
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
 
So far I have had this occur once. Hopefully its not a recurring event.
elmatador is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 05-11-2017, 06:48 PM
SHIFT_Lurker
 
Join Date: Oct 2016
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
 
We took our Armada into the dealer for multiple issues, but their response to the BCI Malfunction issue was..."It's supposed to do that" HAHA. They said it happens when you change lanes or make a turn without using a turn signal...seriously????Told them that we can feel it coming on because the brakes start to automatically apply repeatedly and then every single light on the cluster comes on and the car stops. We then have to turn the car off, wait a minute, then crank back up and it's fine. They also said that we shouldn't turn the car off cause they can't read the history in the computer....not sure what they expect us to do!!!
wharper76 is offline  
post #5 of 11 (permalink) Old 05-11-2017, 07:46 PM
SHIFT_Moderator
 
Join Date: Aug 2006
Location: Los Angeles
Posts: 4,582
Mentioned: 7 Post(s)
Tagged: 3 Thread(s)
Quoted: 269 Post(s)
 
your dealer is misinformed. thats NOT how its supposed to work.

if you have any codes at the obd port, they should still be there after key off.
marctronixx is offline  
post #6 of 11 (permalink) Old 05-27-2017, 08:06 AM
SHIFT_Lurker
 
Join Date: Oct 2016
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
 
Can a code reader be plugged up the the Armada without erasing the code history? I would like to get a reader but the dealer mentioned that it will erase the history and therefore they would not be able to retrieve it to diagnose anything when it's brought in
wharper76 is offline  
post #7 of 11 (permalink) Old 05-28-2017, 04:20 AM
SHIFT_Moderator
 
Join Date: Aug 2006
Location: Los Angeles
Posts: 4,582
Mentioned: 7 Post(s)
Tagged: 3 Thread(s)
Quoted: 269 Post(s)
 
you can connect a scanner that will read the codes and give you an option to cancel the CEL lamp or not.
marctronixx is offline  
post #8 of 11 (permalink) Old 07-07-2017, 12:54 PM
SHIFT_Lurker
 
Join Date: Jun 2017
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
 
Exclamation

Quote:
Originally Posted by elmatador View Post
Today while I was driving suddenly the BCI malfunction light came ON. I had to turn the engine off and fire it up again to make it go away. Anyone have this come up? Not sure why it popped up. Backup camera and sonar is functional.
The same thing happened to me. It went away after restarting.

Photo:
http://imgur.com/aG0XFk3
Varuas is offline  
post #9 of 11 (permalink) Old 03-28-2019, 10:14 AM
SHIFT_Lurker
 
Join Date: Aug 2018
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
 
Garage
Sorry to revive an old thread - my 2018 is doing this and will reset with a key cycle... sitting at dealership now. Anybody have any resolutions to post?

Todd

2018 Armada Platinum Reserve
1999 Saleen Explorer XP8 SC
1989 Mustang 5.0 SC
todds89 is offline  
post #10 of 11 (permalink) Old 04-08-2019, 11:56 AM
SHIFT_Lurker
 
Join Date: Aug 2018
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
 
Garage
Quote:
Originally Posted by todds89 View Post
Sorry to revive an old thread - my 2018 is doing this and will reset with a key cycle... sitting at dealership now. Anybody have any resolutions to post?
So, I left out one detail that also started happening when the BCI Malfunction started - The truck would occasionally only go into ACC mode when we would try to start. The BCI issue was occurring at least once a day.

Apparently, they found that the brake switch was bad,so they replaced it. And, it's been over a week and about 1600 miles (road trip) and no more codes..
marctronixx likes this.

Todd

2018 Armada Platinum Reserve
1999 Saleen Explorer XP8 SC
1989 Mustang 5.0 SC
todds89 is offline  
Reply




Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome