Third brake light replacement - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 02-02-2019, 08:20 AM Thread Starter
SHIFT_Lurker
 
Join Date: Jan 2019
Location: E. TN.
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Third brake light replacement

Well the 3rd brake light has been out and it’s time for replacement. I think that will be my weekend project for the weekend. Maybe another thread here will pick up some discussion.

2005 with 183k+ miles. Replaced headers, radiator front shocks/ springs. Otherwise Factory!
leadsled qx56 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 02-02-2019, 11:58 AM
SHIFT_Enthusiast
 
Join Date: Feb 2018
Posts: 145
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
 
There are some videos on youtube that show the procedure. You have to remove some interior trim and the spoiler. The spoiler is held on by double sided tape.

Mine is out too so let me know if you are successful and what you did.

I've also read that the problem is that a solder joint breaks resulting in the light not working. Supposedly the solder joint is not difficult to repair. That's a lot cheaper than replacing the light. It's one assembly and isn't cheap. Shame that one can't just replace a bulb.
crazy4trains is offline  
post #3 of 9 (permalink) Old 02-02-2019, 02:35 PM Thread Starter
SHIFT_Lurker
 
Join Date: Jan 2019
Location: E. TN.
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Yes thanks I watched that video a week ago. It was largely accurate except for telling me to remove three forward nuts on the spoiler. I found them when the spoiler came loose and the spoiler connection mounts broke.

Here are some pics.

Luckily I had plenty of automotive double sticky back body tape. I should be fine.
Attached Thumbnails
Click image for larger version

Name:	E39FF021-1447-45F2-9C0D-FD6A37840663_1549135918027.jpg
Views:	39
Size:	126.9 KB
ID:	45253  

2005 with 183k+ miles. Replaced headers, radiator front shocks/ springs. Otherwise Factory!
leadsled qx56 is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 02-02-2019, 02:52 PM Thread Starter
SHIFT_Lurker
 
Join Date: Jan 2019
Location: E. TN.
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Here are some pictures along the way.
Attached Thumbnails
Click image for larger version

Name:	7BE2DC7F-1F02-4229-85FE-480A30D3B284_1549136210583.jpg
Views:	28
Size:	112.7 KB
ID:	45255   Click image for larger version

Name:	AE53AE44-E55B-4F0E-90CC-294172F0B7DB_1549136824822.jpg
Views:	28
Size:	163.3 KB
ID:	45257   Click image for larger version

Name:	FB2A0458-E99F-4F4D-BE5B-8512AA753CAC_1549136877691.jpg
Views:	28
Size:	157.2 KB
ID:	45259   Click image for larger version

Name:	0D378A7F-597F-40D3-96CC-ADA2D768459E_1549136994571.jpg
Views:	39
Size:	136.0 KB
ID:	45261   Click image for larger version

Name:	46219D39-8591-40E5-B453-71F479BC1FF2_1549137061449.jpg
Views:	28
Size:	41.3 KB
ID:	45263  


2005 with 183k+ miles. Replaced headers, radiator front shocks/ springs. Otherwise Factory!
leadsled qx56 is offline  
post #5 of 9 (permalink) Old 02-02-2019, 03:25 PM Thread Starter
SHIFT_Lurker
 
Join Date: Jan 2019
Location: E. TN.
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Tools required- 8mm and 11mm socket wrenches. Flat head screwdriver and panel pry device.

Apparently a second more forward plastic panel must come off as one of the above pics showed a bolt/ screw fastener that I never unbolted so it broke off the bottom mount as I tried to show.

2005 with 183k+ miles. Replaced headers, radiator front shocks/ springs. Otherwise Factory!
leadsled qx56 is offline  
post #6 of 9 (permalink) Old 02-02-2019, 06:36 PM
SHIFT_Enthusiast
 
Join Date: Feb 2018
Posts: 145
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
 
Where did you buy your replacement light and if you don't mind, what did you have to pay?
crazy4trains is offline  
post #7 of 9 (permalink) Old 02-03-2019, 01:15 AM Thread Starter
SHIFT_Lurker
 
Join Date: Jan 2019
Location: E. TN.
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
I got it from partsgeek. $90 tax and shipping.

2005 with 183k+ miles. Replaced headers, radiator front shocks/ springs. Otherwise Factory!
leadsled qx56 is offline  
post #8 of 9 (permalink) Old 02-24-2019, 12:13 AM
SHIFT_Lurker
 
Join Date: Jul 2018
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
oem replacement was ~$100 for me.... then i got in there to find out the wires going into the plug were the problem...
snorky18 is offline  
post #9 of 9 (permalink) Old 03-25-2019, 11:39 AM
SHIFT_Newbie
 
Join Date: Apr 2018
Posts: 29
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
 
I replaced mine with a chrome style LED from Amazon.
I was going to repair my OEM, but upon disasebly I ended up breaking the sides of the red lens.
They epoxy the crap out of it making it a challenge to disassemble without breaking.
Q-bert is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome