Coolant Question - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
LinkBack Thread Tools
Old 02-02-2019, 06:40 PM Thread Starter
SHIFT_Enthusiast
 
Join Date: Feb 2018
Posts: 145
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
 
Coolant Question

So I was stumbling around under the hood this afternoon and was looking at the coolant in the expansion tank. Stuck a paper towel in there to see what color the coolant was and it came out yellow/green. Everywhere I have looked indicates the 2011 Armada should have blue Asian spec coolant. Can anybody give any insight on what coolant the vehicle should have? I'm not necessarily worried about what's in there, but if I ever need to top off the coolant that makes that a little more complicated.
crazy4trains is offline  
Sponsored Links
Advertisement
 
Old 02-02-2019, 10:05 PM
SHIFT_Enthusiast
 
Join Date: Oct 2014
Posts: 205
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 31 Post(s)
 
I use Nissan OEM coolant and it is green.
Labeled L248SP
Part # 999MP AF000P

Edit to add I got an 06

Last edited by staplebox; 02-05-2019 at 09:00 PM.
staplebox is offline  
Old 02-03-2019, 08:08 PM Thread Starter
SHIFT_Enthusiast
 
Join Date: Feb 2018
Posts: 145
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
 
That's interesting. Peak shows that a blue coolant is recommended. Good to know that is probably wrong.

https://peakauto.com/products/antifr...ded-life-blue/
crazy4trains is offline  
Sponsored Links
Advertisement
 
Old 02-05-2019, 10:47 AM
Jon
SHIFT_Lurker
 
Join Date: Jun 2018
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
 
In all Nissan's 2010 and up use the blue coolant, 2009 and down use green.
Jon is offline  
Old 02-05-2019, 04:14 PM Thread Starter
SHIFT_Enthusiast
 
Join Date: Feb 2018
Posts: 145
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
 
Quote:
Originally Posted by Jon View Post
In all Nissan's 2010 and up use the blue coolant, 2009 and down use green.
The coolant in my 2011 is definitely green and not blue. I don't have any service records from the previous owner except for the basic and useless CarFax. I wonder if the cooling system was serviced previously and different coolant was installed.

Radiators and other components typically have manufacture dates on them. Does anybody know where/if the manufacture date is stamped on the radiator?
crazy4trains is offline  
Old 02-10-2019, 07:04 PM
SHIFT_Lurker
 
Join Date: Nov 2018
Location: Alaska
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Garage
My 2010 has green in it. That's what I found it in when I bought it 4 years ago and never had any problems with cooling.
jfsiv is offline  
Old 02-11-2019, 09:16 AM Thread Starter
SHIFT_Enthusiast
 
Join Date: Feb 2018
Posts: 145
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
 
Let me muddy the water further. Both the service manual and the owners manual state that the vehicle is filled at the factory with blue coolant. See attached.

This is not an issue for me now, but if I have a need to either replace or top-off the coolant i'm unsure of what to use.
Attached Thumbnails
Click image for larger version

Name:	Coolant Info.jpg
Views:	30
Size:	115.4 KB
ID:	45301   Click image for larger version

Name:	Owner Manual Coolant Info.jpg
Views:	29
Size:	104.4 KB
ID:	45303  
crazy4trains is offline  
Old 02-15-2019, 06:32 PM
Jon
SHIFT_Lurker
 
Join Date: Jun 2018
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
 
2011 uses blue
Attached Thumbnails
Click image for larger version

Name:	coolant.jpg
Views:	25
Size:	119.9 KB
ID:	45307  
Jon is offline  
Old 02-15-2019, 07:55 PM Thread Starter
SHIFT_Enthusiast
 
Join Date: Feb 2018
Posts: 145
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
 
Maybe Nissan used the green coolant in the 2011 models until their supply was exhausted then switched to the blue.
crazy4trains is offline  
 
Thread Tools



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome