Pathy loses cabin heat when ideling - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 02-02-2010, 09:21 AM Thread Starter
SHIFT_Newbie
 
Portman200's Avatar
 
Join Date: Nov 2009
Location: UP MI
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Pathy loses cabin heat when ideling

A buddy of mine has an 07' Pathfinder that is having cabin heating issues. We live in a very cold climate and the closest dealership is two hours away.
When his truck is warming up the engine comes up to temp fine but blows cold air through the vents. When he starts to move the air gets warmer and after ideling again for a while, at a stop light, the heat cools off again?

Any sugestions?

2005 Armada SE
Dimmpled/Slotted Rotors w/ High Pro Brakes
K&N
Family rig that pulls our 303 Keystone Zepplin #7k
Custom interior wear and tear from 3 boys!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Portman200 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-02-2010, 09:39 AM
SHIFT_Administrator
 
scr38's Avatar
 
Join Date: Oct 2004
Location: Crockett, Texas
Posts: 5,215
Mentioned: 4 Post(s)
Tagged: 2 Thread(s)
Quoted: 95 Post(s)
 
Sounds like the coolant level is low. At low RPM, such as at idle, there isn't enough coolant flow to go through the heater core. At higher RPM the pump moves enough coolant to flow through the heater core.
scr38 is offline  
post #3 of 6 (permalink) Old 02-02-2010, 10:49 AM Thread Starter
SHIFT_Newbie
 
Portman200's Avatar
 
Join Date: Nov 2009
Location: UP MI
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by scr38 View Post
Sounds like the coolant level is low. At low RPM, such as at idle, there isn't enough coolant flow to go through the heater core. At higher RPM the pump moves enough coolant to flow through the heater core.
The radiator was full and the over flow bottle looked like it could use some. There's about 2" of fluid in it. He's going to put some more in there and see what happenes.
Thanks!

2005 Armada SE
Dimmpled/Slotted Rotors w/ High Pro Brakes
K&N
Family rig that pulls our 303 Keystone Zepplin #7k
Custom interior wear and tear from 3 boys!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Portman200 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 02-02-2010, 01:28 PM
SHIFT_Hardcore
 
Dirty Cash's Avatar
 
Join Date: May 2009
Location: Cashville
Posts: 255
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Send a message via Yahoo to Dirty Cash
Portman...I see you're in the UP, I feel your pain dude. I was at K.I. Sawyer for about 1.5 years as my first assignment. I know how cold it gets.

-~ Dirty Cash ~-

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dirty Cash is offline  
post #5 of 6 (permalink) Old 02-02-2010, 08:14 PM Thread Starter
SHIFT_Newbie
 
Portman200's Avatar
 
Join Date: Nov 2009
Location: UP MI
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by Dirty Cash View Post
Portman...I see you're in the UP, I feel your pain dude. I was at K.I. Sawyer for about 1.5 years as my first assignment. I know how cold it gets.
We live in Dollar Bay/ Houghton. Wind chill has been in the negatives. Makes it hard on the vehicles.

2005 Armada SE
Dimmpled/Slotted Rotors w/ High Pro Brakes
K&N
Family rig that pulls our 303 Keystone Zepplin #7k
Custom interior wear and tear from 3 boys!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Portman200 is offline  
post #6 of 6 (permalink) Old 02-04-2010, 07:53 PM Thread Starter
SHIFT_Newbie
 
Portman200's Avatar
 
Join Date: Nov 2009
Location: UP MI
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by scr38 View Post
Sounds like the coolant level is low. At low RPM, such as at idle, there isn't enough coolant flow to go through the heater core. At higher RPM the pump moves enough coolant to flow through the heater core.
Well he filled the overflow bottle half way and problem solved! I would of never thought that the overflow bottle would make a difference.
Thanks for the head ache saving tip

2005 Armada SE
Dimmpled/Slotted Rotors w/ High Pro Brakes
K&N
Family rig that pulls our 303 Keystone Zepplin #7k
Custom interior wear and tear from 3 boys!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Portman200 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome