2nd battery installed - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 02-23-2012, 10:58 PM Thread Starter
SHIFT_Hardcore
 
GRILL's Avatar
 
Join Date: May 2009
Location: Anchorage, AK
Posts: 562
Mentioned: 0 Post(s)
Tagged: 2 Thread(s)
Quoted: 3 Post(s)
 
2nd battery installed

Hi guys,

I just finish the installed on a second battery, Stinger 920. Did some cutting n drilling but the end result was all worth it. Here are some pics.
Attached Thumbnails
Click image for larger version

Name:	ImageUploadedByAutoguide1330055858.064439.jpg
Views:	3788
Size:	187.9 KB
ID:	10605   Click image for larger version

Name:	ImageUploadedByAutoguide1330055879.487823.jpg
Views:	4825
Size:	152.0 KB
ID:	10606  

'07 Smoke Mada: 20" OEM 08' Armada Rims, Nitto Trails 305/55R20, 6" ProComp Lift, Radflo coilvers, PRG UCAs, Firestone AirBag Spring Helpers, 2* Timing Advance, Airaid TBS, Borla Dual Exhaust, Volant CAI, Bully Dog, two Tech12volt underseat box w/ Alpine SWR-T10, Stinger 925 in rear & Alpine PDX 1.1000, ArmaDen 6000k low's
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
GRILL is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 02-23-2012, 11:43 PM
SHIFT_Hardcore
 
AngelVivas's Avatar
 
Join Date: Dec 2011
Location: Sunny SoCal
Posts: 1,443
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
 
Garage
Looking good Grill. That would be a good write up possibly...


Angel Vivas, III
2006 Nissan Armada SE 4x2 Silver Lightning


UPRev Tuned (Cajun Style)
Gibson Cat-Back Exhaust
Cajun Catless B-Pipes
Volant Cold Air Intake
CSF 3328 Racing All-Aluminum Radiator
2" Front Leveling Kit (To Even Her Out)
Bilstein HD Front Struts
Interior LED Kit
6000 HID Kit
Nissan Black Grill Guard



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
AngelVivas is offline  
post #3 of 13 (permalink) Old 02-24-2012, 01:44 AM Thread Starter
SHIFT_Hardcore
 
GRILL's Avatar
 
Join Date: May 2009
Location: Anchorage, AK
Posts: 562
Mentioned: 0 Post(s)
Tagged: 2 Thread(s)
Quoted: 3 Post(s)
 
Quote:
Originally Posted by AngelVivas View Post
Looking good Grill. That would be a good write up possibly...

Thanks Angel. The hardest part was to cut the panel. The wires were already routed since i use to have a capacitor there.

'07 Smoke Mada: 20" OEM 08' Armada Rims, Nitto Trails 305/55R20, 6" ProComp Lift, Radflo coilvers, PRG UCAs, Firestone AirBag Spring Helpers, 2* Timing Advance, Airaid TBS, Borla Dual Exhaust, Volant CAI, Bully Dog, two Tech12volt underseat box w/ Alpine SWR-T10, Stinger 925 in rear & Alpine PDX 1.1000, ArmaDen 6000k low's
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
GRILL is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 02-24-2012, 11:16 AM
SHIFT_Hardcore
 
9balllrook's Avatar
 
Join Date: Apr 2008
Location: Ellicott City, Md
Posts: 3,453
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
 
Good choice using the Stinger, great batteries!!

Jerry's 06 SE off road
07+ Intake, Injen CAI, JBA long tubes, Gibson Cat Back, UpRev tuned, 08 caliper kit w/ Frozen/Slotted Rotors, Goodridge Stainless Steel Brake Lines, Stillen 2-row/aluminum Radiator, PML pan, TransGo shift kit, 2" PRG lift, Bilstein 5100s, 20" Fuel Pump w/295/60/20 Terra Graps, 4ga. Grounding Kit, LEDs & HIDs, Kenwood DNX-9960 Alpine PDX amps, Kef separates,
(2) underseat
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
subs w/Kenwood 10' slims, Twin Stinger Batteries, remote start & protection by Python


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
9balllrook is offline  
post #5 of 13 (permalink) Old 02-26-2012, 02:01 AM
SHIFT_Hardcore
 
Invanity's Avatar
 
Join Date: Feb 2011
Location: Ventura, CA
Posts: 1,289
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
 
Looks great!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

-Eli
04 Armada 20s with 35's Nitto RidgeGrapplers, Pinch Weld Mod, Titan 08+ 4x4 coils, Bilstein 5100s (middle setting), Rancho quicklift rear w/Raybestos 589-1150 coils, 22" Magnaflow exhaust, limo tint, Debadged, Billet grille, bull bar, rear brush guard, Armaden LED package, Torque Pro Vehicle monitoring via Nexus 7 indash tablet (CyanogenMod) ELM327 (OBDII-bluetooth), Viper Alarm, Die Hard Batt, Royal Purple Synthetics...lotsa plastidip
April 2012 Ride of the Month...
Thanks guys
Invanity is offline  
post #6 of 13 (permalink) Old 03-02-2012, 03:55 PM
SHIFT_Hardcore
 
dragon_27's Avatar
 
Join Date: Oct 2009
Location: Vancouver, BC
Posts: 469
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
 
one stinger battery still doesn't cut it? your system drains too much power, even with a capacitor?

2006 QX56 with all wheel drive and intelligent cruise control

22 inch incubus wheels, 305/45/22 nitto nt420s tires, e&g grille, s&b intake, magnaflow catback exhaust, solo performance resonated tip, bullydog tuner, 10 alpine shallow sub, tech12volt underseat box, 1000 watt alpine mono amp, tvandnav2go unit, harman kardon drive+play dock, tinted tail lights, magnum crossed drilled rotors, weathertech mats, 3m clear and bilstein hd - to do list: cajun b pipes, fm y pipe and blacking out chrome...

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dragon_27 is offline  
post #7 of 13 (permalink) Old 03-02-2012, 04:17 PM Thread Starter
SHIFT_Hardcore
 
GRILL's Avatar
 
Join Date: May 2009
Location: Anchorage, AK
Posts: 562
Mentioned: 0 Post(s)
Tagged: 2 Thread(s)
Quoted: 3 Post(s)
 
I have a yellow top up front. System is running smooth and sound is crisp. No dimming lights, battery gauge does not drop, no problems here and im running two amps.

'07 Smoke Mada: 20" OEM 08' Armada Rims, Nitto Trails 305/55R20, 6" ProComp Lift, Radflo coilvers, PRG UCAs, Firestone AirBag Spring Helpers, 2* Timing Advance, Airaid TBS, Borla Dual Exhaust, Volant CAI, Bully Dog, two Tech12volt underseat box w/ Alpine SWR-T10, Stinger 925 in rear & Alpine PDX 1.1000, ArmaDen 6000k low's
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
GRILL is offline  
post #8 of 13 (permalink) Old 03-02-2012, 04:51 PM
SHIFT_Hardcore
 
9balllrook's Avatar
 
Join Date: Apr 2008
Location: Ellicott City, Md
Posts: 3,453
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
 
Did you have problems before, even with a cap? I'm running a pair of PDX's- 4.125 and 1.600 without problems (though I put a second battery in when my stocker crapped out!). I don't believe I would've had any problems even if I didn't use a cap, just in case.

Jerry's 06 SE off road
07+ Intake, Injen CAI, JBA long tubes, Gibson Cat Back, UpRev tuned, 08 caliper kit w/ Frozen/Slotted Rotors, Goodridge Stainless Steel Brake Lines, Stillen 2-row/aluminum Radiator, PML pan, TransGo shift kit, 2" PRG lift, Bilstein 5100s, 20" Fuel Pump w/295/60/20 Terra Graps, 4ga. Grounding Kit, LEDs & HIDs, Kenwood DNX-9960 Alpine PDX amps, Kef separates,
(2) underseat
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
subs w/Kenwood 10' slims, Twin Stinger Batteries, remote start & protection by Python


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
9balllrook is offline  
post #9 of 13 (permalink) Old 03-03-2012, 02:14 AM Thread Starter
SHIFT_Hardcore
 
GRILL's Avatar
 
Join Date: May 2009
Location: Anchorage, AK
Posts: 562
Mentioned: 0 Post(s)
Tagged: 2 Thread(s)
Quoted: 3 Post(s)
 
Quote:
Originally Posted by 9balllrook View Post
Did you have problems before, even with a cap? I'm running a pair of PDX's- 4.125 and 1.600 without problems (though I put a second battery in when my stocker crapped out!). I don't believe I would've had any problems even if I didn't use a cap, just in case.
Had a glitch while running the system with a cap. I guess caps don't like the cold weather up here. I went thru 2 caps both digital 10 farad.

'07 Smoke Mada: 20" OEM 08' Armada Rims, Nitto Trails 305/55R20, 6" ProComp Lift, Radflo coilvers, PRG UCAs, Firestone AirBag Spring Helpers, 2* Timing Advance, Airaid TBS, Borla Dual Exhaust, Volant CAI, Bully Dog, two Tech12volt underseat box w/ Alpine SWR-T10, Stinger 925 in rear & Alpine PDX 1.1000, ArmaDen 6000k low's
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
GRILL is offline  
post #10 of 13 (permalink) Old 03-03-2012, 07:23 AM
SHIFT_Hardcore
 
Snizzle's Avatar
 
Join Date: Apr 2009
Location: Seattle Wa
Posts: 281
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
 
Nice.....Is that 4 gauge?

2004 Nissan Armada SE. JBA Long Tube Headers, Cajun Catted B-Pipes, Uprev, Spintech Pro Street Muffler, Airaide MXP Intake, Bio-Kustom 2" Spindles, 26" Lexani Hydras on 305/30R26 OHTSU Tires.
Snizzle is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome