Tow switch does not seem to work - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-05-2017, 05:07 PM Thread Starter
SHIFT_Newbie
 
Join Date: Mar 2016
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
 
Tow switch does not seem to work

I tow a 7000lb boat. I tow in 4th and also push the button for tow/haul. I do not notice the shift points being any different even though the light is on on the switch. What does this switch actually do and is there a way to test it? Thanks for any help.
niteridder64 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-05-2017, 05:34 PM
SHIFT_Moderator
 
Join Date: Aug 2006
Location: Los Angeles
Posts: 4,625
Mentioned: 8 Post(s)
Tagged: 3 Thread(s)
Quoted: 282 Post(s)
 
in my experience, it delays the shift points.

if you are not noticing anything, stop of at a autozone and have then scan your obd port for any trouble codes.

did you notice it used to work at some point or its never worked since you have used it?

when you are just driving sans trailer, engage the switch and see if you feel a difference too...

what year model is your car?
marctronixx is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome