2017 Owner with problems already - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 1Likes
  • 1 Post By JerryLedford
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 11-27-2017, 11:47 AM Thread Starter
SHIFT_Lurker
 
Join Date: Nov 2017
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
2017 Armada BCI Malfunction

Love our new Armada other than we only had for 1 week and 400 miles before taking to shop. Computer went crazy and has been in shop for almost 2 weeks now. Service dept called this morning to inform me ECM and ABS module were bad and they have ordered new ones. Part is supposed to be in Thursday so hopefully we will have our Armada back by weeks end with no further issues. I'm going to assume this is a rare problem as I haven't seen anyone else post about having this issue and will keep everyone updated. We are not regretting it but just look forward to actually having what we paid for.

Thanks for any feedback.

Last edited by JerryLedford; 04-03-2018 at 10:49 AM.
JerryLedford is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 11-28-2017, 10:22 AM
SHIFT_Hardcore
 
PetitFrereArmada's Avatar
 
Join Date: May 2013
Location: Pearland, TX
Posts: 2,461
Mentioned: 12 Post(s)
Tagged: 1 Thread(s)
Quoted: 226 Post(s)
 
It is a good thing you posted about your problem with your brand new Armada because some people only come to the forum to find solutions and never post their own problems.

When you post your problems and follow up with solutions, it helps out a lot of other members. That is the only way the forums are useful. Because people share their car troubles, ask for solutions and share the final solutions with others.

That is what makes a true and helpful post on the forum.

The 2017 Armada is new so far, so slowly but surely it is a fact that we will see others post all kinds of problems from brand new or as it ages with the years to come.

I hope they fix yours and you get back to enjoying your Armada.

My Build/Maintenance/Modification thread..., Aiming for 250K on odometer.
2012 Infiniti QX56
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
... KING OF THE ROAD
2008 Nissan Maxima SE
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
... CATCH ME IF YOU CAN


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
PetitFrereArmada is offline  
post #3 of 6 (permalink) Old 11-28-2017, 04:28 PM
SHIFT_Moderator
 
Join Date: Aug 2006
Location: Los Angeles
Posts: 4,618
Mentioned: 8 Post(s)
Tagged: 3 Thread(s)
Quoted: 280 Post(s)
 
The armada is a welll built vehicle with a long history of happy campers.

Issues occur on any mass produced item (phones, curtains, musical gear—anything mass produced).

As has been mentioned, people usually only post/seek out a forum to vent frustrations or to inquire about help. Rarely do people simply sign up to say “hey i like this [item] and wanted to make an account to say so”.

Welcome to the fourm and feel free to make yourself comfy...
marctronixx is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 12-04-2017, 09:59 AM Thread Starter
SHIFT_Lurker
 
Join Date: Nov 2017
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Same Issue

Ok, so we picked our Armada back up from the shop Thursday and the same thing happened over the weekend. BCI Malfunction comes on the message screen and all lights are on in the dash. It won't shift gears when this happens and the vehicle is "crippled". We have to pull over and shut it off, then when started back all lights go off except the check engine light. It is fine again for a while then does the same thing over again. We really love our Armada but beginning to wonder if we ended up with a lemon. The vehicle now has 800 miles on it and the shop has replaced the ECM and ABS Module. Taking back to dealership today and will keep you updated.
I'm beginning to wonder what our options are here.
JerryLedford is offline  
post #5 of 6 (permalink) Old 12-04-2017, 11:48 AM
SHIFT_Newbie
 
Join Date: Aug 2017
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
 
It sounds like they didn't diagnose the problem correctly. Two weeks is a long time to not fix it properly.

I had a relatively new vehicle that needed to have its engine replaced. It took two weeks, but it was fixed. It was covered by warranty, but they acted as if I got away with something by not having to pay for it.

document and date everything! who you talk to, when, what they say, ...
frank10 is offline  
post #6 of 6 (permalink) Old 04-03-2018, 10:27 AM Thread Starter
SHIFT_Lurker
 
Join Date: Nov 2017
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Follow Up on 2017 Aramada

Just wanted to let everyone know that my Armada turned out to be a lemon. 3 times in the shop for a total of 35 days for the BCI Malfunction. They replaced computer the first time, found bent prongs in wiring harness the second time and finally replaced the wiring harness the 3rd time but still has same issue. Nissan Consumer Affairs offered to buy back the vehicle so gonna take the money and run. I'm sure this is an isolated event and I know Nissan is a reliable brand overall. I will give props to the Consumer Affairs dept as they stepped up and gave me 3 options.
Platinumblack likes this.
JerryLedford is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome