Issues with 2017 Armada Platinum - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-04-2017, 10:09 AM Thread Starter
SHIFT_Lurker
 
Join Date: Nov 2017
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Issues with 2017 Armada Platinum

Love our new Armada except we purchased on 11/10 and only been able to drive it 1 week. After 6 days of having it the message screen read "BCI Malfunction" and all lights came on in the dash. The vehicle was crippled at that point by not shifting gears so we had to pull over and turn off. After restarting it all lights were off except the check engine light. We took back to dealership and they said the ECM and ABS Module needed replaced. After 13 days in the shop we picked it up Thursday hoping all would be good. Unfortunately it happened again over the weekend so we are headed back to the dealer today. We love the Armada but beginning to wonder if we got a lemon. Would love to have this thing fixed but now would be hesitant to trust it on long trips. Any other issues like this out there that could give me advice and peace of mind?
Another note, we only have 800 miles on this vehicle so far.

Thanks
JerryLedford is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-04-2017, 08:04 PM
SHIFT_Moderator
 
Join Date: Aug 2006
Location: Los Angeles
Posts: 4,591
Mentioned: 7 Post(s)
Tagged: 3 Thread(s)
Quoted: 273 Post(s)
 
its tough to nail anything down over the internet, so be aware of that.

the car is under warranty so at least there is no upfront cost to you about these issues.

doesn't sound like a lemon since it's the same trouble that keeps occuring. just sounds like the $tealer is not treating the issue directly and are instead milking the warranty work.

there are trouble codes that the car should be spitting out. have them give you a rundown of the codes. you are welcome to post them here so others can better get an idea of what could be going on.

unfortunately no one can give you any idea of what could go wrong. it's a massed produced car and things happen that are not normal.
marctronixx is offline  
post #3 of 3 (permalink) Old 12-05-2017, 12:05 PM
SHIFT_Hardcore
 
SGreenlyn's Avatar
 
Join Date: Apr 2015
Posts: 276
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 68 Post(s)
 
Quote:
Originally Posted by JerryLedford View Post
Love our new Armada except we purchased on 11/10 and only been able to drive it 1 week. After 6 days of having it the message screen read "BCI Malfunction" and all lights came on in the dash. The vehicle was crippled at that point by not shifting gears so we had to pull over and turn off. After restarting it all lights were off except the check engine light. We took back to dealership and they said the ECM and ABS Module needed replaced. After 13 days in the shop we picked it up Thursday hoping all would be good. Unfortunately it happened again over the weekend so we are headed back to the dealer today. We love the Armada but beginning to wonder if we got a lemon. Would love to have this thing fixed but now would be hesitant to trust it on long trips. Any other issues like this out there that could give me advice and peace of mind?
Another note, we only have 800 miles on this vehicle so far.

Thanks
Amazon has a number of $10 Bluetooth ODB2 port readers a phone app to connect with it is $0 to $5.

2005 Armada LE 207K miles,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, rear cats deleted and replaced with 2 x Vibrant 1792 resonators, Magnaflow 22", stock pipes, dual tips, home made K&N RU-3270 intake,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
with 6000K 75W HIDs,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, 36W LED projector fogs, LEDs all around,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, 400W rear amp + Bose 161s in back,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, 'Armada' emblem wrap for the hamburger,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
for interior exhaust fans and continuous battery charging.
SGreenlyn is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome