2nd Gen Armada brake pedal play - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-04-2018, 10:32 PM Thread Starter
SHIFT_Lurker
 
Join Date: Aug 2018
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
2nd Gen Armada brake pedal play

Well we bought a 2018 former rental Aramada SV 4WD with a whopping 36000 miles.

The only issue other than very soft paint and chips is that the brake pedal has about 3mm of play at the top of the travel. I can see the play is due to a sloppy fit between the yolk and the pin up above the pedal.

Does anyone else have similar play in their pedal? Do you know if it is any intentional design critical to braking (like unloading a sensor)? If the play is not required, has anyone determined if the play is removed by replacing the pin, the yolk, the insert tab or some combination of these?
ric200 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-05-2018, 09:36 AM
SHIFT_Moderator
 
Join Date: Aug 2006
Location: Los Angeles
Posts: 4,625
Mentioned: 8 Post(s)
Tagged: 3 Thread(s)
Quoted: 282 Post(s)
 
Curious, did you take it to a nissan shop to get it checked out prior tp purchase? Or your trusted mechanic?

The brake pedal should not have any “play” in the movement. No wiggle, no lag in the physical movement.

You should have your brake system checked out.
marctronixx is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome