knocking under the dash with vent air changes - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-30-2018, 11:40 AM Thread Starter
SHIFT_Lurker
 
Raygirardi's Avatar
 
Join Date: Nov 2018
Location: cold lake, alberta
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
knocking under the dash with vent air changes

I have a vent valve knocking for a minute when possibly trying to reach its new destination when switching vent air from floor to dash to front (like the motor is not strong enough to move it so it keeps trying to reach the position required). The knocking occurs as well after the vehicle is totally off. I'm scared to take apart my dash, as it looks complicated to see what the issue is. Knocking can last for 1 min to 2 min before it stops. Any changes to the venting which provides air to the front,,,,starts it again.
I've looked underneath the driver side dash and move some cowling out of the way, but no joy in finding the item in question making the noise. Has anyone taken apart the front dash area (radio and storage)?

Thanks

Ray Girardi
Black 09 Armada LX

Last edited by Raygirardi; 11-30-2018 at 11:47 AM.
Raygirardi is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-30-2018, 12:01 PM Thread Starter
SHIFT_Lurker
 
Raygirardi's Avatar
 
Join Date: Nov 2018
Location: cold lake, alberta
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
looks like the answers are here including how to remove and replace with lots of photos below in other posts.
No need to advise unless you have something new to add that other guys have not talked about. I guess I'll live with it for a while, due to the colder climate here in Alberta, we do use the defroster so switching climate zones venting is a daily activity.

thanks

Ray Girardi
Black 09 Armada LX
Raygirardi is offline  
post #3 of 4 (permalink) Old 11-30-2018, 12:28 PM
SHIFT_Newbie
 
Join Date: Jul 2018
Location: DeKalb IL
Posts: 40
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
 
Garage
I used the chap ebay replacements. I am talking in multiples as I replaced it twice and each worked for about a week or so. Since changing these out is a pain in the back, I decided to go with an OEM actuator for my 3rd attempt. Its been working now for several month.

The OEM is only a few bucks more online, so it might be worth the investment.
sswiss is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 11-30-2018, 08:30 PM
SHIFT_Enthusiast
 
Join Date: Oct 2014
Posts: 205
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 31 Post(s)
 
I'll just add there a couple YouTube videos on this that give a good look at the part and process. There is also one by a guy who just used 1 zip tie to keep the motor / cam from reaching the clicking point while still allowing the system to operate fully.

Armada's also share a lot of parts with the Nissan Titan - so we have a lot of the same problems and fixes - especially from the driver's seat forward. There is a Titantalk.com forum that is more active than this one and when chasing down problems I always check both sites.
staplebox is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome