Anyone Using Lubeguard Red - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-31-2012, 10:45 AM Thread Starter
SHIFT_Newbie
 
Join Date: Dec 2012
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Anyone Using Lubeguard Red

I have a slight shudder into 3rd gear once transmission gets warm. I bought the vehicle a few weeks ago and it has 72k miles on it. I did two drain and fill with Nissan S fluid. I'm going to do a third drain and fill this week sometime. I also did the front/rear diff and transfer case. I'm going to order the PML transmission pan next week too.
Someone mentioned to me to add the Lubeguard Red in the transmission. I'm not a big fan of additives - mainly because I don't know much about them. My question is - Is anyone using Lubeguard Red and has it helped transmission shifting,temp etc ?
Thanks and happy new year !
tomf is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-28-2013, 04:12 PM Thread Starter
SHIFT_Newbie
 
Join Date: Dec 2012
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
So, is anyone using lubeguard or any other friction modifier ??
tomf is offline  
post #3 of 3 (permalink) Old 02-28-2013, 05:30 PM
SHIFT_Administrator
 
scr38's Avatar
 
Join Date: Oct 2004
Location: Crockett, Texas
Posts: 5,215
Mentioned: 4 Post(s)
Tagged: 2 Thread(s)
Quoted: 95 Post(s)
 
I would NOT use that or any other additive!
scr38 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome