Just changed plugs - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 04-19-2013, 03:59 PM Thread Starter
SHIFT_Enthusiast
 
GottaMada's Avatar
 
Join Date: Nov 2006
Posts: 223
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Just changed plugs

So I just changed my first set of plugs. With CA guidance it wasn't difficult. The truck started afterword and there are no dummy lights on.
However, I know nothing about spark plugs. Based on the condition of the old plugs, do I have any cause for concern? I have 110k miles and I believe these were the original plugs.
Thanks.
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	194
Size:	138.2 KB
ID:	12045  
GottaMada is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 04-19-2013, 04:29 PM
SHIFT_Administrator
 
scr38's Avatar
 
Join Date: Oct 2004
Location: Crockett, Texas
Posts: 5,215
Mentioned: 4 Post(s)
Tagged: 2 Thread(s)
Quoted: 95 Post(s)
 
Your plugs look normal. No worries.
scr38 is offline  
post #3 of 9 (permalink) Old 04-19-2013, 05:08 PM Thread Starter
SHIFT_Enthusiast
 
GottaMada's Avatar
 
Join Date: Nov 2006
Posts: 223
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Thanks for the quick reply!
GottaMada is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 04-19-2013, 11:51 PM
SHIFT_Newbie
 
Nickoli415's Avatar
 
Join Date: Oct 2007
Location: California
Posts: 89
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
 
Changed out mines too last nite. Haven't changed the spark plugs since we bought the vehicle with 32k miles. Now the Mada is just shy of 101k miles.
Attached Thumbnails
Click image for larger version

Name:	IMG_0245.jpg
Views:	167
Size:	185.6 KB
ID:	12046  

2005 LE
Nickoli415 is offline  
post #5 of 9 (permalink) Old 04-20-2013, 09:19 PM
SHIFT_Hardcore
 
Invanity's Avatar
 
Join Date: Feb 2011
Location: Ventura, CA
Posts: 1,289
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
 
Looks ok but hard to tell from a picture, ideally you would want the same look on each plug on each bank for the overall engine. I would always do the good old smell test on them as well to make sure you aren't running rich (darker plugs and heavy gas smell) or lean

What plugs did you do with?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

-Eli
04 Armada 20s with 35's Nitto RidgeGrapplers, Pinch Weld Mod, Titan 08+ 4x4 coils, Bilstein 5100s (middle setting), Rancho quicklift rear w/Raybestos 589-1150 coils, 22" Magnaflow exhaust, limo tint, Debadged, Billet grille, bull bar, rear brush guard, Armaden LED package, Torque Pro Vehicle monitoring via Nexus 7 indash tablet (CyanogenMod) ELM327 (OBDII-bluetooth), Viper Alarm, Die Hard Batt, Royal Purple Synthetics...lotsa plastidip
April 2012 Ride of the Month...
Thanks guys
Invanity is offline  
post #6 of 9 (permalink) Old 04-20-2013, 11:40 PM
SHIFT_Administrator
 
scr38's Avatar
 
Join Date: Oct 2004
Location: Crockett, Texas
Posts: 5,215
Mentioned: 4 Post(s)
Tagged: 2 Thread(s)
Quoted: 95 Post(s)
 
Quote:
Originally Posted by Nickoli415 View Post
Changed out mines too last nite. Haven't changed the spark plugs since we bought the vehicle with 32k miles. Now the Mada is just shy of 101k miles.
Those plugs look great. A/F ratio good and no oil fouling.
scr38 is offline  
post #7 of 9 (permalink) Old 04-21-2013, 02:04 AM
SHIFT_Hardcore
 
Snizzle's Avatar
 
Join Date: Apr 2009
Location: Seattle Wa
Posts: 281
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
 
Good job guys.....How does it run? Can you tell the deference?

2004 Nissan Armada SE. JBA Long Tube Headers, Cajun Catted B-Pipes, Uprev, Spintech Pro Street Muffler, Airaide MXP Intake, Bio-Kustom 2" Spindles, 26" Lexani Hydras on 305/30R26 OHTSU Tires.
Snizzle is offline  
post #8 of 9 (permalink) Old 05-02-2013, 09:14 AM
SHIFT_Enthusiast
 
Ambush's Avatar
 
Join Date: Jan 2012
Location: Carolinas
Posts: 145
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
 
Inspiration! I ordered some Iridiums per the suggestion of Nissan Tech and HAVE NOT put them in my truck yet! That was 20k miles ago.
I am afraid I will prob not reach the back plugs
Oh well I will try it soon.

Thanks

--Ambush
Ambush is offline  
post #9 of 9 (permalink) Old 05-02-2013, 08:48 PM Thread Starter
SHIFT_Enthusiast
 
GottaMada's Avatar
 
Join Date: Nov 2006
Posts: 223
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Snizzle, sorry for the late reply. I only saw a notification of reply in my email today.
I used NGK platinum (PLFR5A-11).
For the amount of miles I have, I was kinda expecting to feel a difference, but I don't. My Mada has always seemed to run well (knock on wood). Gas mileage is about the same.

Ambush, it was really easy. Some people probably don't need as many as I used, but I used a 3" and 6" extensions as well as a magnetic, 6" swivel spark plug socket. That made a huge difference toward the back where there was stuff in the way. Good luck!
GottaMada is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome