Transmission Oil Filter? - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-05-2013, 07:03 PM Thread Starter
SHIFT_Enthusiast
 
Townending's Avatar
 
Join Date: Oct 2009
Location: Claremont, CA / Big Bear, CA
Posts: 234
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
 
Transmission Oil Filter?

I was under the impression that our cars did not have an oil filter, but instead we just had magnets. I went to autozone to buy a new oil pan gasket and they told me it could only be purchased in combination of the oil filter. I removed the oil pan and and I can see what I believe is the oil filter.

New Oil Filter:



Oil Filter in Transmission:


Is this an oil filter? or just some other part?

EDIT: Now that I have deeply looked at the pictures. The parts aren't even the same. The new "filter" has far less bolt holes and even a different placement of the filter intake/outlet hole.

Current Ride : 2013 Audi A4 / Moonlight Blue / APR Stage 2 E85 Tune

2004 Nissan Pathfinder Armada LE / 90,000 Miles / Green
2004 Nissan Xterra S / 50,000 Miles / Yellow - R.I.P.
2007 Nissan Xterra S / 60,000 Miles / White - R.I.P.
2009 Nissan Murano SL / 55,000 Miles / Brown

Last edited by Townending; 10-05-2013 at 07:05 PM.
Townending is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 10-05-2013, 07:26 PM Thread Starter
SHIFT_Enthusiast
 
Townending's Avatar
 
Join Date: Oct 2009
Location: Claremont, CA / Big Bear, CA
Posts: 234
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
 
I just found out that we also don't even have a gasket. What the hell did autozone sell me then? haha

Current Ride : 2013 Audi A4 / Moonlight Blue / APR Stage 2 E85 Tune

2004 Nissan Pathfinder Armada LE / 90,000 Miles / Green
2004 Nissan Xterra S / 50,000 Miles / Yellow - R.I.P.
2007 Nissan Xterra S / 60,000 Miles / White - R.I.P.
2009 Nissan Murano SL / 55,000 Miles / Brown
Townending is offline  
post #3 of 5 (permalink) Old 10-06-2013, 12:07 AM
SHIFT_Hardcore
 
blackArmada_Dxb's Avatar
 
Join Date: Jul 2012
Location: Dubai, U.A.E
Posts: 1,608
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by Townending View Post
I just found out that we also don't even have a gasket. What the hell did autozone sell me then? haha
LOL……hahaaaa…


Sent from AutoGuide.com Free App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Interior LED Package, 55W Morimoto 6000k HID Lows, 6000k LED Fogs, Rev Camera, Invisible Car Bra, Upper & lower grille combo, White Door Handles, VOLANT CAI with PowerCore filter, BD Triple Dog GT (Premium Tune + 2 deg)
Bilstein 5100s with maximum lift in the front, 1" Daystar rear lift, Red powdercoated NCP 2773546 NAPA front & 2773545 NAPA rear springs, Rancho 9000XL Rear shocks, F&R Powerstop slotted & drilled rotors with ceramic pads, Front and rear anti-sway bar delete
My Build Thread:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

blackArmada_Dxb is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 10-06-2013, 07:42 AM
SHIFT_Administrator
 
scr38's Avatar
 
Join Date: Oct 2004
Location: Crockett, Texas
Posts: 5,215
Mentioned: 4 Post(s)
Tagged: 2 Thread(s)
Quoted: 95 Post(s)
 
No filter - just a screen. And many if not most transmissions came with a gasket. The newer units may use silicon sealer instead of a gasket.
scr38 is offline  
post #5 of 5 (permalink) Old 10-06-2013, 07:18 PM Thread Starter
SHIFT_Enthusiast
 
Townending's Avatar
 
Join Date: Oct 2009
Location: Claremont, CA / Big Bear, CA
Posts: 234
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
 
I just put the pan back without adding a gasket or silicon sealer... How soon should I add either?

Current Ride : 2013 Audi A4 / Moonlight Blue / APR Stage 2 E85 Tune

2004 Nissan Pathfinder Armada LE / 90,000 Miles / Green
2004 Nissan Xterra S / 50,000 Miles / Yellow - R.I.P.
2007 Nissan Xterra S / 60,000 Miles / White - R.I.P.
2009 Nissan Murano SL / 55,000 Miles / Brown
Townending is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome