Oil Cooler Gasket Fail - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-02-2014, 01:04 PM Thread Starter
SHIFT_Newbie
 
Join Date: Feb 2007
Location: League City, Texas
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
 
Oil Cooler Gasket Fail

I noticed after I changed the oil, that it leaking oil. I checked the oil filter and it was tight. After searching the forum I decided to go after the oil cooler gasket. I installed the gasket and cranked the truck. Oil was going everywhere. I immediately shutdown the truck. I disassembled the oil cooler and found the gasket to be ok. I reassembled the oil cooler and cranked the truck. No leak this time. I didn't think that much oil had leaked but I will top it off and try it again. I did read that some people had an issue with low oil pressure after changing the oil cooler gasket. But didn't see an answer to the problem. I also read something about a pressure relief ball that had fallen out. I did see it the first time I had the cooler off. I looked around but didn't see it on the ground. Would this cause low oil pressure?
Of course it's Super Bowl Sunday, my only day off and it's raining and cold. What could be better!
chasliss is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome