b2 s1 is rich '06 - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-22-2014, 02:53 PM Thread Starter
SHIFT_Lurker
 
Join Date: Apr 2014
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
b2 s1 is rich '06

showing a average of .6 volts the rest are .25-.3 and im seeing a code p0430 for cat efficiency, I switched both upstream sensors and it still reads the same on bk2 s1, will this require replacing one or both cats on passenger side?
xrjoe is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-22-2014, 10:31 PM
SHIFT_Hardcore
 
nightowl's Avatar
 
Join Date: May 2013
Posts: 433
Mentioned: 0 Post(s)
Tagged: 2 Thread(s)
Quoted: 55 Post(s)
 
Quote:
Originally Posted by xrjoe View Post
showing a average of .6 volts the rest are .25-.3 and im seeing a code p0430 for cat efficiency, I switched both upstream sensors and it still reads the same on bk2 s1, will this require replacing one or both cats on passenger side?
Likely a failed cat or cracked manifold which is very common. Time for long tube headers, bpipes and Uprev. That is the best and cheapest fix that will last. Beware of the aftermarket and oem replacements as those will fail again. This happens usually in the 90-125k mile range.
nightowl is offline  
post #3 of 3 (permalink) Old 11-23-2014, 10:23 AM Thread Starter
SHIFT_Lurker
 
Join Date: Apr 2014
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
you think headers are acceptable in California? theres no aftermarket cat options according to local emissions guy, if so you got a ballpark idea of price? theres not a possibility fuel trim can be suspect im guessing.
xrjoe is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome