fuel pickup or guage problem - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 33 (permalink) Old 05-13-2016, 06:24 PM Thread Starter
SHIFT_Newbie
 
Join Date: Oct 2014
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
 
fuel pickup or guage problem

about 2 years ago I ran out of gas while the guage was under 1/4 tank.
Last week my car ran out of gas on 1/4 tank mark, I thought I was safe.
Today,,my car ran out of gas with the reading a little above 1/4 tank.
Now,,,I understand I'm an idiot for not filling up...but I'm out of work and trying to get by on every dollar I can save, plus I despise getting gas.

So,,I just put 20 gallons in and the guage reads 3/4 . (out of gas, plus 6 gallons to get it to gas station)
Could it be the fuel pick up tube is rotting and getting shorter??
To check the fuel pickup,,do I have to drop spare tire holder and tank or can I go from under seats to expose top of tank?
or could the guage be so off that 1/4 is actually empty? I'm not sure what size tank I have.
2004 pathfinder armada se 5.6 engine

2004 Pathfinder Armada SE 118K miles
bought used in 2012
ny04armada is offline  
Sponsored Links
Advertisement
 
post #2 of 33 (permalink) Old 05-13-2016, 09:50 PM
SHIFT_Hardcore
 
primoV8's Avatar
 
Join Date: Oct 2006
Location: NYC
Posts: 1,021
Mentioned: 9 Post(s)
Tagged: 2 Thread(s)
Quoted: 121 Post(s)
 
Garage
You'll need to replace the fuel pump assembly.

Check out this thread, no need to drop the tank going this route.
https://www.clubarmada.com/forums/showthread.php?t=45521

"I may think I have inalienable rights to be alive and happy but I don't - life is a blessing."

- Terrence McNally
primoV8 is offline  
post #3 of 33 (permalink) Old 05-13-2016, 11:38 PM Thread Starter
SHIFT_Newbie
 
Join Date: Oct 2014
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
 
Thanks,,it seems that it will start needing the tank to be kept full before it finally goes. My car is also at 120k miles like others this happened to. I needed this like a hole in the head.
ny04armada is offline  
Sponsored Links
Advertisement
 
post #4 of 33 (permalink) Old 05-14-2016, 03:26 PM
SHIFT_Hardcore
 
Believe_ET.2's Avatar
 
Join Date: Aug 2010
Location: Los Angeles, CA.
Posts: 431
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
 
Had to replace my fuel pump assembly too. I think it was a recall for my 08. It ran out of gas on me when the darn gas meter showed at least a quarter tank left.. After the dealer ship fixed it the same way primoV8 gave the example link to, no more problems with the gas meter....

Believe

-2008 LE w Tow Package
-4 piece Billet Grill
-Bug Deflector guard
-Sunroof wind deflector
-HID 6k lows (fogs soon)
-Air Box Mod with K&N Filter (thanks to this forum I was able to do it myself)
-screw on exhaust tip
-15% tint front windows
Believe_ET.2 is offline  
post #5 of 33 (permalink) Old 05-14-2016, 06:28 PM
SHIFT_Newbie
 
Iodonzs's Avatar
 
Join Date: Feb 2007
Location: Utah
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
 
Quote:
Originally Posted by ny04armada View Post
about 2 years ago I ran out of gas while the guage was under 1/4 tank.
Last week my car ran out of gas on 1/4 tank mark, I thought I was safe.
Today,,my car ran out of gas with the reading a little above 1/4 tank.
Now,,,I understand I'm an idiot for not filling up...but I'm out of work and trying to get by on every dollar I can save, plus I despise getting gas.

So,,I just put 20 gallons in and the guage reads 3/4 . (out of gas, plus 6 gallons to get it to gas station)
Could it be the fuel pick up tube is rotting and getting shorter??
To check the fuel pickup,,do I have to drop spare tire holder and tank or can I go from under seats to expose top of tank?
or could the guage be so off that 1/4 is actually empty? I'm not sure what size tank I have.
2004 pathfinder armada se 5.6 engine

We have never run out of fuel but our fuel gauge has never been accurate (owned it for 12k miles.)
I took it in to Nissan for one of our free oil changes and they said that their way a recall on the fuel sending unit. We had it replaced along with the recall on the ECM Relay and it works like a champ now. (We have a bigger fuel tank than I thought we did!)

Point is that it should be a free fix for you.

Mike.

If I had all the money I've spent on cars.... I'd spend it on cars!
Iodonzs is offline  
post #6 of 33 (permalink) Old 05-14-2016, 09:23 PM Thread Starter
SHIFT_Newbie
 
Join Date: Oct 2014
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
 
Really?? Even though im not the original owner?

Edit: i just searched and it seems to be 2005 - 2008. Mines an 04. I'll check some more.

Last edited by ny04armada; 05-14-2016 at 09:32 PM.
ny04armada is offline  
post #7 of 33 (permalink) Old 05-15-2016, 08:36 AM Thread Starter
SHIFT_Newbie
 
Join Date: Oct 2014
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
 
I checked autozone which show the pump at $300 yet on my google searches i see some under $150...im not sure why such a difference in prices.
Also, im trying to figure if the pump works then why isnt the pickup reaching the fuel? Can i repair that part myself? When looking at a picture of the pump there is a spring on a rod holding the float section. Does this bottom piece rise when full and lower when empty? Maybe its stuck and a good knocking on the top of tank can drop it? What do you think?
ny04armada is offline  
post #8 of 33 (permalink) Old 05-16-2016, 11:21 AM Thread Starter
SHIFT_Newbie
 
Join Date: Oct 2014
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
 
Well,,,,i ordered one from rockauto and with a discount code it came to $113. Im going to cut the carpet and change it out. Thanks to all who replied.
ny04armada is offline  
post #9 of 33 (permalink) Old 06-11-2016, 08:35 PM Thread Starter
SHIFT_Newbie
 
Join Date: Oct 2014
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
 
so the part came super quick,,about 2 days after i ordered it. Beat the crap out of the gas locking ring and changed the pump. All worked well. then a few days later I saw the gauge on E with the light (it never went there before) but I had about 3/4 tank. Then the next time I started the car the gauge was back to where it should be. So this has happened about 3 or 4 times. It seems to randomly happen then correct itself on the next start up. As long as the pump is pumping I'm happy. Now to go post my next problem.....

2004 Pathfinder Armada SE 118K miles
bought used in 2012
ny04armada is offline  
post #10 of 33 (permalink) Old 06-17-2016, 02:31 PM
SHIFT_Lurker
 
Join Date: Feb 2011
Location: Lockport, IL
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I have a 2004 Armada with 202K and I have had the same problem for over a year now. Did you also experience your truck hesitating when you pressed down on the accelerator? If so, did getting the new fuel pump fix that problem as well?
aqsartin is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome