changed out transmission hoses and clamps - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-02-2017, 07:11 PM Thread Starter
SHIFT_Newbie
 
Join Date: Feb 2017
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
changed out transmission hoses and clamps

after reading all the horror stories about how transmission hose / clamp failure on mostly Titan and some Armada.

I can only see 3 transmission rubber hoses. 2 long (probably 1 foot) and 1 short (~6" long with 90 degree bend). I replaced a total of 6 clamps. didn't replace the 1 short hose. it was so short, that my replacement hose will kink with the 90 degree bend.


btw, it is a 5/16" ID transmission fluid hose. this one is overkill, way too long. you need just 3'-4'
https://www.amazon.com/gp/product/B000CRFJ0M/

hose clamp is fuel injection type clamp.
https://www.amazon.com/gp/product/B0040CU0HM/

Last edited by bellwilliam; 03-04-2017 at 12:04 AM.
bellwilliam is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-03-2017, 09:28 AM
SHIFT_Administrator
 
scr38's Avatar
 
Join Date: Oct 2004
Location: Crockett, Texas
Posts: 5,215
Mentioned: 4 Post(s)
Tagged: 2 Thread(s)
Quoted: 95 Post(s)
 
I think the transmission cooler hoses are 5/16" ID.

2004 Armada SE, Throttle body coolant bypass, Grounding kit, modified Volant CAI with Amsoil dry element, custom engine cover, trailer brake controller, Michelin M/S2s, custom lower grill, Silver Star headlights, Bilstein HD shocks, Power Stop Drilled/Slotted Rotors, ceramic pads, Goodridge SS brake lines, interior and back-up LEDs, PLM transmission pan, trans radiator cooler by-passed, all Amsoil synthetic lubricants, Nismo headers, custom 3" SS exhaust system with high flow metallic core cats, UpRev tuner version, 318 rear wheel HP.
scr38 is offline  
post #3 of 3 (permalink) Old 03-04-2017, 12:05 AM Thread Starter
SHIFT_Newbie
 
Join Date: Feb 2017
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Thanks for correcting me. I've fixed my post.
bellwilliam is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome