05 Armada dies when shifting into gear - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 02-12-2019, 11:42 AM Thread Starter
SHIFT_Lurker
 
Join Date: Feb 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
05 Armada dies when shifting into gear

Thank u for adding me to this forum . I look forward in all tips and help as much as I can . I'm from text and just picked up and 05 armada. The main issue is that when I shift into gear the truck dies. What am I doing wrong and what do I need to check . She has about 165 k miles on her
justin richter is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 02-12-2019, 06:11 PM
SHIFT_Newbie
 
Join Date: Oct 2018
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Does it lurch or try to take off forward when you put it in gear like it's in direct drive? Does it do the same in reverse? Does it feel like it's trying to take off in 3rd gear in a manual?

04 Armada LE
fummins is offline  
post #3 of 10 (permalink) Old 02-12-2019, 06:16 PM
SHIFT_Newbie
 
Join Date: Oct 2018
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Did it just happen out of the blue or???

Oh and the rads are common to have the transmission cooler crack or break inside the rad and get coolant mixing with the tranny fluid destroying the transmission. Seems to be a problem that either has or will happen to these things.

04 Armada LE
fummins is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 02-12-2019, 06:50 PM
SHIFT_Hardcore
 
Campfamily's Avatar
 
Join Date: Oct 2004
Location: Southern California
Posts: 3,144
Mentioned: 7 Post(s)
Tagged: 2 Thread(s)
Quoted: 162 Post(s)
 
Quote:
Originally Posted by justin richter View Post
Thank u for adding me to this forum . I look forward in all tips and help as much as I can . I'm from text and just picked up and 05 armada. The main issue is that when I shift into gear the truck dies. What am I doing wrong and what do I need to check . She has about 165 k miles on her
If it's running this bad, it must be throwing codes. Get a code reader, hook it up to your OBDII port, and download the codes. A code reader is less than $30 on Amazon. When you have the codes, post them here and folks can provide you much better direction on what you need to do.

Keith


- 12 Armada Platinum 4WD, Tuscan Sun (red)
- 06 Armada LE 4WD, Red Brawn, QX56 Wheels (traded)
- 04 Armada LE 4WD, Smoke (lemon lawed)
- 18 Tesla Model 3, Long Range RWD
- 00 Maxima SE, Manual Trans (kids car)
- 65 Buick Skylark Gran Sport Convertible, 401 ci, 2nd owner, original condition, 71,000 miles (play car)
- Prowler Lynx 826M Travel Trailer, 26', 5000#'s

"How often we fail to realize our good fortune in living in a country where happiness is more than a lack of tragedy."
--Paul Sweeney, author
Campfamily is offline  
post #5 of 10 (permalink) Old 02-12-2019, 07:19 PM
SHIFT_Newbie
 
Join Date: Dec 2018
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
 
Quote:
Originally Posted by Campfamily View Post
If it's running this bad, it must be throwing codes. Get a code reader, hook it up to your OBDII port, and download the codes. A code reader is less than $30 on Amazon. When you have the codes, post them here and folks can provide you much better direction on what you need to do.

Keith
Keith, any app that you recommend in particular for the code reader?

I am on iOS, use the dash command app, and a generic wifi obd scanner off amazon. The expanded diagnostics (abs, trans, etc) in dash command did not work for me.

08 LE Non-nav, 4wd
dpatel791 is offline  
post #6 of 10 (permalink) Old 02-13-2019, 09:41 AM
SHIFT_Hardcore
 
Campfamily's Avatar
 
Join Date: Oct 2004
Location: Southern California
Posts: 3,144
Mentioned: 7 Post(s)
Tagged: 2 Thread(s)
Quoted: 162 Post(s)
 
Quote:
Originally Posted by dpatel791 View Post
Keith, any app that you recommend in particular for the code reader?

I am on iOS, use the dash command app, and a generic wifi obd scanner off amazon. The expanded diagnostics (abs, trans, etc) in dash command did not work for me.
I'm old school.....I have a traditional wired OBDII scanner that I bought off of Amazon a few years ago. Perhaps others on the forum can make recommendations.


- 12 Armada Platinum 4WD, Tuscan Sun (red)
- 06 Armada LE 4WD, Red Brawn, QX56 Wheels (traded)
- 04 Armada LE 4WD, Smoke (lemon lawed)
- 18 Tesla Model 3, Long Range RWD
- 00 Maxima SE, Manual Trans (kids car)
- 65 Buick Skylark Gran Sport Convertible, 401 ci, 2nd owner, original condition, 71,000 miles (play car)
- Prowler Lynx 826M Travel Trailer, 26', 5000#'s

"How often we fail to realize our good fortune in living in a country where happiness is more than a lack of tragedy."
--Paul Sweeney, author
Campfamily is offline  
post #7 of 10 (permalink) Old 02-13-2019, 11:26 AM
SHIFT_Newbie
 
Join Date: Oct 2014
Location: PA
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
 
I would definitely check your transmission fluid to make sure there are no leaks or contamination with antifreeze. If you don't see any issue, you should consider replacing the ECM relay. The ECM relay seems to go bad over time and cause various issues such as the one you are having. Its a $6 part and worth a shot. I put some info about it in the other most recent post about transmission issues. Good luck.
chromedomer is offline  
post #8 of 10 (permalink) Old 02-13-2019, 08:31 PM Thread Starter
SHIFT_Lurker
 
Join Date: Feb 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
I will order one scanner and let everyone know what codes . Lso will try and replace the ecm relay also... To others posts , when I shift just shift to reverse or any gear it just straight dies. No jerk or nothing just dies .
justin richter is offline  
post #9 of 10 (permalink) Old 02-14-2019, 09:42 AM
SHIFT_Newbie
 
Join Date: Oct 2018
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Well, it might not be the transmission like I thought. But who know's. I feel like I'm the only one who's felt a transmission or 6 fail like that. Mostly dodge diesels mind you.

If the engine just dies like you turn the key off or sputter? It's pretty hard to narrow it down without being there and seeing exactly what happens. Could be anything really, from low fuel pressure to bad a bad ground. I'd hate to say throw random parts at it like some shops do when they're clueless. I actually like to find out the problem first. It's kinda what I get paid to do.

I don't recommend cheap obd code readers, I'd at least get one that will show live data. I have an old cheap otc one that shows abs and airbag codes as well as some live data that's come in handy. At work I use an autel maxisys mini which is pretty. It's great for trouble shooting. You can activate the pos vent solenoid, air compressor, on demand and tons of other crap. It's decent but it's over $1000 so unless you use it every day not worth it for the home gamer.

04 Armada LE
fummins is offline  
post #10 of 10 (permalink) Old 02-14-2019, 11:42 AM
SHIFT_Newbie
 
Join Date: Oct 2014
Location: PA
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
 
I generally agree about not just changing parts to try to solve a problem. But if you have knowledge from other's experience about an issue and the part is super cheap and easy to install, then I lean toward trying those first. The knowledge on this forum has saved me tons over the years. The other part that some people have replaced with a general stalling issue is the cam position sensor. That is another cheap part. Obviously I don't recommend throwing lots of money and/or time at a problem without data.
chromedomer is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Nissan Pathfinder Armada Dies While Driving clrobinssr Problems 9 03-03-2017 07:27 AM
Replaced Fuel Pump, ECM Relay on 2004 Nissan Armada - Truck Still Dies While Driving clrobinssr Problems 2 03-03-2017 07:26 AM
2010 shifting into gear from park liquid1 Problems 2 08-09-2014 03:09 PM
Transmission won't go into gear drauden Problems 18 08-11-2012 12:50 PM
armada dies on warm restart , help jeepdad Problems 2 12-13-2007 09:58 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome