Cooler air even when A/C is off - Nissan Armada Forum: Armada & Infiniti QX56 Forums
User Tag List

 1Likes
  • 1 Post By andy
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 03-28-2019, 04:20 PM Thread Starter
SHIFT_Hardcore
 
andy's Avatar
 
Join Date: Nov 2004
Location: Los Angeles
Posts: 1,258
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
 
Cooler air even when A/C is off

When I turn off the A/C, the air coming out the vents is cooler than outside. Even after 10-20 mins later. When I press the A/C button and it lights up, the air is even colder.

Has anyone else noticed this? I'm wondering if the A/C stays on even when the light on A/C button is off.

2004 Armada LE Black - Sold but miss it!
2017 Armada SL Pearl White
andy is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-28-2019, 08:54 PM
SHIFT_Moderator
 
Join Date: Aug 2006
Location: Los Angeles
Posts: 4,583
Mentioned: 7 Post(s)
Tagged: 3 Thread(s)
Quoted: 270 Post(s)
 
if the AC led is off the system is off. depending on what time of day and location you may just feel cold air...

but i guess you didnt feel this in the valley!

on the center screen if you press info you will see if the AC is on or not.

you may lok to make sure the rear AC is off too.

plus if you dont hear the AC compressor clutch "clicking" when the compressor runs, then that is also a good indicator.
marctronixx is offline  
post #3 of 5 (permalink) Old 03-28-2019, 11:01 PM Thread Starter
SHIFT_Hardcore
 
andy's Avatar
 
Join Date: Nov 2004
Location: Los Angeles
Posts: 1,258
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
 
Quote:
Originally Posted by marctronixx View Post
if the AC led is off the system is off. depending on what time of day and location you may just feel cold air...

but i guess you didnt feel this in the valley!

on the center screen if you press info you will see if the AC is on or not.

you may lok to make sure the rear AC is off too.

plus if you dont hear the AC compressor clutch "clicking" when the compressor runs, then that is also a good indicator.
I guess I have a different kind of cold air intake. You're right, let's wait for the summer in the Valley and see if I still feel cold air.
marctronixx likes this.

2004 Armada LE Black - Sold but miss it!
2017 Armada SL Pearl White
andy is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-03-2019, 11:37 PM
SHIFT_Newbie
 
Join Date: Nov 2010
Location: Omaha, NE
Posts: 69
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
I have noticed the same thing. It says the AC is off. If I turn it "on" (where the led is lit) and then back off, it seems to go back to the outside temperature. But it seems like something I have to reset often.
imtfox is offline  
post #5 of 5 (permalink) Old 04-04-2019, 08:24 AM
SHIFT_Moderator
 
Join Date: Aug 2006
Location: Los Angeles
Posts: 4,583
Mentioned: 7 Post(s)
Tagged: 3 Thread(s)
Quoted: 270 Post(s)
 
Maybe you have something faulty? The AC does not run when its supposed to be OFF. You can easily tell by listening to the compressor CLICK on the compressor itself.

Just last night I was going UP an interstate here (405 north by the Getty for those in LA) and instantly just ina certain area I felt COLDer air than just seconds before. I had the VENT on (not AC). I immediately thought of this thread.

But yeah go into the info/status page and you will see AC OFF or some such. If you STILL feel cold air when you think you should not, you should perhaps have your system checked.
marctronixx is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Replace block to oil cooler line, cant get clip off. Luda Problems 2 07-17-2018 02:50 PM
Radio causing my battery to drain even when truck is off Noob_2009 General Discussions 0 03-06-2015 08:47 AM
Blower stays on even when you turn off??? raven69david Infiniti QX56 1 01-27-2015 08:31 PM
Wow!!! Not even 5500 miles and shes leaking... Madahajimoto Problems 13 03-29-2007 01:01 PM
Thank god I didn't get an Escalade!! (I love my Armada even more today) PumaFiveOh General Discussions 8 05-28-2005 06:40 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome