Nissan Armada & Infiniti QX56 Forums banner

Reaction score
0

Profile posts Latest activity Discussions Media Albums About

  • ArmaDen ·
    Sounds like a ballast issue if it was hanging loose and possibly got banged around. Send me your shipping information again to [email protected] and we'll get another out to you to warranty that one out. Thanks
    ArmaDen ·
    Another kit as in something failed on the original or another kit for another lighting location? Let me know and I'll get you taken care of. Have a great night. Jason
    SDArmada619 ·
    Hello friend, I put the the 5100's on my mada with the 2.5 lift and cant wait to upgrade from my stock 285's to a 325 or 35's if they can fit. I noticed that you are running 325's do the rub? did you do the pinch weld ??

    Truck looks great
    ArmaDen ·
    Hey, How's it going. The F250 project is completed. Doing some fine tuning with the aiming as I'm trying to get the cutoff as far out as possible without getting the cutoff line above hood level for oncoming vehicles. I'm so used to having some light scatter from the HIDs that having the light to black cutoff line on the road takes some getting used to. I haven't found a suitable tester pair of 08 Mada headlamps to start the Retro on that yet. I'm still deciding whether I'm going to use the plug in play version or the FX-R's I have sitting on my desk. The plug n plays have a great light output but the FX-Rs are just in a league of their own. I'm also trying to find a supplier that manufactures the headlamp housings without the component being put together so I can skip the PITA factor of baking them apart. That has to be the worst part of it. I'll keep everyone posted. Have a great weekend. Jason
  • Loading…
  • Loading…
  • Loading…
  • Loading…
  • Loading…
Top