Nissan Armada & Infiniti QX56 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Title says it all.

I'm burning a crap ton of oil and fear my engine is on it's way out.

I think it's the same but would like confirmation... Is the 1st gen Titan 5.6 litre engine the same as the 1st gen Armadas?

Also, this is a ridiculous idea but any thoughts on dropping a 2nd gen engine into a 1st gen?

Cheers
 

·
Premium Member
Joined
·
175 Posts

To answer your first question, yes, the Titan engine is the same VK56DE as in the Armada and Infinity QX56.

I honestly don't know the differences well enough to say you can swap a VK56VD for a DE. Sounds like an adventure you could pioneer and report back to us on though! ;)
 
  • Like
Reactions: OBXPatrol

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Thanks! I found one in Vancouver for $1400, only 93,000 km on it!! Seemed like a no brainer.

I talked to my buddy who is a mechanic and he said I would be better off just buying a new DE Titan.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
How much oil are you burning?
I'd say 2 litres per 1000-1200 km. Getting some nasty blue smoke on start up too. Thought it might be warn valves seals but I've noticed a knock every now and then.

I do a lot of overlanding and driving to remote locations for fishing. Last thing I need is for my engine to go.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
How many kilometers do you have on that engine?
120,000 miles (it's from Kalispell originally). There's basically no service history though on Carfax.

You should have seen the sludge that we drained from that thing. I don't think the previous owner changed the oil.. potentially ever.

Good thing I didn't pay too much at auction
 

·
Registered
Joined
·
10 Posts
That’s not many miles, have you tried to sea foam the engine? maybe it would free up a stuck ring. That’s the scary thing about used cars, you never know about previous maintenance.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
That’s not many miles, have you tried to sea foam the engine? maybe it would free up a stuck ring. That’s the scary thing about used cars, you never know about previous maintenance.
Yea man, sea foam in the oil and gas tank.

Tried lucas valve seal too.

I've done 4 oil changes in the past 6000km I've put on it to try to flush out the carbon build ups or soften the seals. No bueno, I feel more confident in just swapping it with something that I have history for.
 

·
Registered
Joined
·
10 Posts
That sucks, I’ve seen sea foam work but most of the time it doesn’t, worth a shot though. I have a Toyota Corolla that started burning oil at 130k it now has 230k and still chugging. No knock though. $1400 is not too bad if it gives you another 100k, then you get to tear down the old one to see what’s going on.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #11
That sucks, I’ve seen sea foam work but most of the time it doesn’t, worth a shot though. I have a Toyota Corolla that started burning oil at 130k it now has 230k and still chugging. No knock though. $1400 is not too bad if it gives you another 100k, then you get to tear down the old one to see what’s going on.
I'd take the risk if I didn't live in the middle of nowhere.

If my engine dies the armada is basically a write off cause it would cost more to ship it back south (2300km) than just replace. I'm tryna be proactive about this one.
 
1 - 12 of 12 Posts
Top