Nissan Armada & Infiniti QX56 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I have read and it looks like I need to go with Bilstein 4600 or 5100, but what size? Can I punch in online that it is for a 2011 Nissan Titan or something like that? Where do you guys get these too? Anywhere local, Oriley, Auto ZOne Advance Auto? OR do I have to order them?
Thanks in advance.
 

·
Premium Member
Joined
·
1,369 Posts
On this thread, I showed and explained which Bilstein 6100 I opted for. A semi-custom install, but an easy DIY if you've done suspension work before.

 
  • Like
Reactions: marctronixx

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
On this thread, I showed and explained which Bilstein 6100 I opted for. A semi-custom install, but an easy DIY if you've done suspension work before.

Thank you for your response. That’s is all the exact info I need. I have almost everything ordered, I went with rock auto for the little stuff too. The moog mount isn’t in stock though. Am I right in understanding your post said that if I pick a Nissan titan from that year span any of those mounts should work though? Like say Nissan Titan 2011? If I punch it in that way there are different branded mounts available. I’m hoping I can use one of those as well. If you see this and get a chance please let me know if I’m understanding your post correctly. Thanks again for your time and help.

Like the beck/arnley below?
50236
2EC8909A-D898-4DDF-9CD4-99BEB4428D6B.png
 

·
Premium Member
Joined
·
1,369 Posts
That’s correct. Only reason why I didn’t go with the Monroe strut mount(s) was because I wasn’t sure if a new spring seat was included. Otherwise, they’re all pretty much the same.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
That’s correct. Only reason why I didn’t go with the Monroe strut mount(s) was because I wasn’t sure if a new spring seat was included. Otherwise, they’re all pretty much the same.
That’s great! Thank you so much for all of your hard work figuring this stuff out. I love this truck. I have never driven anything like it before in my entire life. I’ve had it for a few years now, I hope to keep it for a very long time. Maybe long enough to figure out something cool like you have here and share it with the group I hope.
thanks again, be well,
 

·
Premium Member
Joined
·
1,369 Posts
I had a 04 LE armada before, daily driven in NYC for almost 11 years and sold it with 207K+ miles and still being daily driven in NJ. I learned a lot working on that 04, DIY'ing 99% of the work done from maintenance to mods. These newer Z62/Y62s are really no different with the exception of the external/cosmetic and interior changes. Even the chassis didn't change much so working on my Z62 isn't really that much of a difference. I did invest in a full range scan tool a couple years ago not only for this truck but also to learn about my wife's LR Discovery. The scan tool with the OE service manual has made diagnosing any issues I've had so much easier. In case you want to see what possible issues can happen with a GDI motor such as the VK56VD, here's another DIY I did:


Just in case, I also have Apple Carplay/Android via Grom Audio's VL2. :)
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
Just in case, I also have Apple Carplay/Android via Grom Audio's VL2. :)
Yeah, I like that interface. Does it take over permanently or just when you put it on a certain input? I mean do you loose all other functionality of that screen? I would guess not since it tells you about temperature and fan speeds and such, but I was just wondering how it worked. Once I do the suspension fixes and I can get my wife to ride in it without feeling seasick, I will look into doing this addition for sure.

Also nice post on the other thing too, I have seen most of that on mine already too as I have had to replace my starter. Good times...

Now today my key/entry systems are messing up on me though. Clicker buttons do nothing, doesn't recognize when I walk up and turn on the lights, button on door handle not working, and when I get in I have to touch it to the start button to let me start it, but still says "no key" while I drive. Love all the tech magic, hate maintaining it... I'll make another post for that issue.

Thanks again for your help though.
 

·
Premium Member
Joined
·
1,369 Posts
Don’t forget about a 4WD alignment from a reputable shop/tech that actually has the know-how in aligning a 4WD vehicle with IFS & IRS. These trucks go out of alignment more often than it should.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #9 · (Edited)
-Started a separate thread and deleted this reply. -
Don’t want to repost the same stuff everywhere.

Don’t forget about a 4WD alignment from a reputable shop/tech that actually has the know-how in aligning a 4WD vehicle with IFS & IRS. These trucks go out of alignment more often than it should.
I got the drivers side done last night. Doing passenger today. I’ll have it in for an alignment as soon as I’m done. Thanks again for all the help. I can’t wait to drive it and have it not be a wondering bounce-fest! :)

I got this finished up today. Amazing difference. Rides and drives like a totally different vehicle. The second side went on in half the time too. Well worth the effort for sure. Thanks again for the help primoV8!
 
1 - 9 of 9 Posts
Top