Nissan Armada & Infiniti QX56 Forums banner
21 - 34 of 34 Posts

·
Registered
Joined
·
8 Posts
I just bought one from crutchfield as well. Its getting here tomorrow. I was buying from amazon before so we’ll see if this one works. Ill post back once i install it. If it works then u definitely shouldnt buy from amazon
So I installed everything. At first the screen didn’t work. I found there were 2 harnesses left alone that the instructions didn’t state. I took them and tested each of them to the remaining connections from truck harness to see which fitted. The one that fitted I plugged into the interface and boom the screen came on. Also the directions are a little confusing. Make sure you’re using the right harness. 1 bundle that came with kit should be left over

So I installed everything. At first the screen didn’t work. I found there were 2 harnesses left alone that the instructions didn’t state. I took them and tested each of them to the remaining connections from truck harness to see which fitted. The one that fitted I plugged into the interface and boom the screen came on. Also the directions are a little confusing. Make sure you’re using the right harness. 1 bundle that came with kit should be left over
there are 2 wires that look like this but they have 2 different ends going to application but are the same for the interface.
 

Attachments

·
Registered
Joined
·
6 Posts
Factory screen still doesnt work with new one from crutchfield. I think they just made a product that doesnt work correctly
there are 2 wires that look like this but they have 2 different ends going to application but are the same for the interface.
im having a hard time understanding you. I believe you’re mentioning the display cable that’s separate from the interface harness and plugs into the side of the interface. I have that one plugged in. Is there anyway you could just send me a pic of all harnesses you connected. Thanks man and glad you got it working
 

·
Registered
Joined
·
8 Posts
Factory screen still doesnt work with new one from crutchfield. I think they just made a product that doesnt work correctly

im having a hard time understanding you. I believe you’re mentioning the display cable that’s separate from the interface harness and plugs into the side of the interface. I have that one plugged in. Is there anyway you could just send me a pic of all harnesses you connected. Thanks man and glad you got it working
I’ll be taking back apart tomorrow to put rca jacks in for subs. I’ll snap pics and get a video. I don’t know what package you have but I have Bose and nav so I used the harness that has the Nav label and threw the other one to the side that has “main” label. I didn’t use any of the rca that came with kit either.
 

·
Premium Member
Joined
·
12 Posts
Did you guys get this install figured out? Mine has been a mess from that start
I had a ton of issues the the Metra kit which seems to be common based on what different shops in my area have expressed... I now still sit with my factory headunit but run a decently high end SQ system leveraging both the Nissan HU and my mobile (phone/tablet) via lightning/USB digital out to a DSP. When i am using my phone as a source for streaming, i can choose to use either Nissan Nav or any Nav app on my device, the hands free is still done through the factory, all vehicle notifications still work, my HU still displays what songs are streaming from my mobile and i can control my mobile via the Factory touch screen :)
 

·
Premium Member
Joined
·
12 Posts
I always use the Scosche dash kits in my cars. Better quality and most are made in the US. I used this database to find that and some other wiring stuff: AutoHarnessHouse.com - Vehicle Audio Compatibility Database - The BEST source of vehicle audio data on the Web!
Scosche def makes great dash kits, but they do not have an option for this Vehicle with this particular head unit. Metra was the only one who decided to tackle it and the hardware software they used to mimic and integrate the steering wheel controls AC controls and to keep your factory display unfortunately is no Bueno
 

·
Registered
Joined
·
9 Posts
Basically everything that was factory works. There might be a few screens I’m missing but you can even turn off the factory camera and continue to use the rca jacks but I went above and beyond, taking my console out and running hdmi and usb dash kits so I dont need to use that. The bottom of the kit is from metra but it seems to work just the same as the factory one
 

·
Registered
Joined
·
180 Posts
Basically everything that was factory works. There might be a few screens I’m missing but you can even turn off the factory camera and continue to use the rca jacks but I went above and beyond, taking my console out and running hdmi and usb dash kits so I dont need to use that. The bottom of the kit is from metra but it seems to work just the same as the factory one
Thanks for sharing your success.
 

·
Premium Member
2012 Nissan Armada SL
Joined
·
436 Posts
I just wish Metra could have tried to make the buttons look less obviously aftermarket. It's specifically a kit for the 1st Gen Armada, couldn't they have tried to match the buttons to factory?
 
21 - 34 of 34 Posts
Top