Nissan Armada & Infiniti QX56 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My wife’s armada’s back hatch Just’s opens and closes repeatedly can’t get it to stop and stay closed help
 

·
Super Moderator
Joined
·
5,623 Posts
need some more info.

is this a new purchase? bought it used?

did it always behave this way? just started?

check the lock on the back to make sure there is nothing in the latch?

do you have children? could they have placed something inside the slit the hatch arm is in?

been to the car wash recently? water may have gotten into the mechanism and is causing the hatch to open.

have you done any troubleshooting steps or are you just going by what your wife has said to you?

your issue is not common, so this is why more info is needed.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
need some more info.

is this a new purchase? bought it used?

did it always behave this way? just started?

check the lock on the back to make sure there is nothing in the latch?

do you have children? could they have placed something inside the slit the hatch arm is in?

been to the car wash recently? water may have gotten into the mechanism and is causing the hatch to open.

have you done any troubleshooting steps or are you just going by what your wife has said to you?

your issue is not common, so this is why more info is needed.
We bought it slightly used had it 2 years. There are no foreign objects anywhere that would interfere with its operation. I have turned the power switch off by steering wheel and that doesn’t stop it. I have taken the battery out of key fob and that doesn’t stop it. It opens all the way stays open for a few minutes then closes back and locks. Then repeats. My wife does wash her car regularly.
 

·
Super Moderator
Joined
·
5,623 Posts
appreciate the follow up.

could be something corroded/shorted out in the hatch area thats causing this. some early model armadas would have the door open up during a car wash for example, due to water ingress.

if the fob was the issue, the doors and other such mischief would be happening too.

you may have to remove the back door finisher to have a look see at the mechanism.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Well took it to the dealer today and they kept all day it never opened one time there. I had taken battery out of the key fob suspecting it but it didn’t stop it. I had forgot about the spare fob. Soon as we pulled up at home and got out it started again. Went and found spare fob and removed battery and that fixed it. Guess the spare fob was shorting out or something
 

·
Registered
Joined
·
21 Posts
Owned our ‘08 QX56 since new. Two times I have had random hatch issues. Both times the problem disappeared after disconnecting the battery for 10 seconds. Give that a try.
 

·
Registered
2015 Armada SV 4X4
Joined
·
1 Posts
I have a 2015 Armada that I recently purchased with 91k miles. After my 1st carwash, I heard a beeping sound coming from the rear hatch. Being a new owner of the vehicle, I had no idea of what it meant. After pondering the issue, I decided to take off the plastic cover of the rear hatch and discovered water marks on the interior sides of the door above a multi pin electrical connection. I pulled the connection apart and observed wet pins and a light blue coloring on some of the pins where water has been leaking onto them causing corrosion. This is the main wiring connection to all of the electrical components in the rear of the vehicle. For me, it was the beep, beep of the indicator that the rear hatch was closing that was shorting across, but on your vehicle it could be the pins going to your hatch opener that are shorting out. My advice is to pull off the interior panel on the rear door/hatch and check for corrosion to the pins. For me, I cleaned the pins, siliconed the top of the connector to stop the water from getting to the pins of the connection and called it good. I suppose I should put new weather strip in to hopefully stop any further water intrusion, but I'm in Arizona and water isn't an issue here. I'm sure in other parts of the country, this could be a real pain in the ass. Good luck.
 
1 - 8 of 8 Posts
Top