Nissan Armada & Infiniti QX56 Forums banner
1 - 15 of 15 Posts

·
Premium Member
Joined
·
5 Posts
Discussion Starter · #1 ·
It's intermittent, but my push button sometimes won't work. I have to get out of the car and remote start it.

When I push it, the dash lights up and the infotainment system comes on. It just won't turn over.

This happened multiple times today, but later tonight the push button start worked several times. Seems random.

Any thoughts?
 

·
Premium Member
Joined
·
73 Posts
I am starting to run into this issue on my 2018 Armada. Had to keep trying until it finally started. I think I did notice the acc light come on. Curious if you got a resolution?
 

·
Registered
Joined
·
1 Posts
I still have a problem with it. I can start only with the remote. I brought to dealer and for diagnostic for this problem is $250

I still have a problem with it. I can start only with the remote. I brought to dealer and for diagnostic for this problem is $250
I opted out for the diagnostic. Ill wait what the group can recommend
 

·
Registered
Joined
·
1 Posts
I am having the same problem with my 2018 Armada SL. I find that I have to pump the brake to get it to start or get out and remote start it.
 

·
Registered
Joined
·
19 Posts
This is a known problem with the brake switch. If you have a brake controller it can also be that. Had mine in multiple times and had the brake switch replaced and even had a factory rep come out and it ended up being the brake controller. Yea, you should be able to plug in a brake controller into the harness when you have the tow package but apparently there are APPROVED controllers, who knew? Anyway either of those is most likely culprit.
 

·
Registered
Joined
·
1 Posts
This is a known problem with the brake switch. If you have a brake controller it can also be that. Had mine in multiple times and had the brake switch replaced and even had a factory rep come out and it ended up being the brake controller. Yea, you should be able to plug in a brake controller into the harness when you have the tow package but apparently there are APPROVED controllers, who knew? Anyway either of those is most likely culprit.
I have had this happen on my 2019 three times now. They replaced the brake switch each time. Once they replaced the battery as well. They have a regional technician looking at it today. Did the controller replacement work for you? They are telling me they are going to look at a relay switch as well.
 

·
Registered
Joined
·
19 Posts
Yes, disconnecting the controller worked. I ended up going with the curt echo controller so nothing plugged into the pigtail in the cab. I have a 2019 as well. Echo: A Wireless Brake Controller for Your Smartphone

Have had not starting problems since. Seems crazy weird to me that the controller was the problem but the curt unit works well and I just did not want to try another controller plugged into the pigtail since the first one created the starting problem.
 

·
Registered
Joined
·
12 Posts
I have had this happen on my 2019 three times now. They replaced the brake switch each time. Once they replaced the battery as well. They have a regional technician looking at it today. Did the controller replacement work for you? They are telling me they are going to look at a relay switch as well.
The problem is the brake sensor switch...if they keep putting the same faulty OEM Part back in there and it keeps happening, I believe that’s the definition of insanity, haha! Seriously buy you a $10 brake sensor switch off eBay, replace it and be done! I replaced mine well over a year ago and have not had a single problem since.
 

·
Registered
Joined
·
1 Posts
I still have a problem with it. I can start only with the remote. I brought to dealer and for diagnostic for this problem is $250


I opted out for the diagnostic. Ill wait what the group can recommend
I have a 2018 Armada. I've had the brake start sensor thingy replaced twice so far and mine just starting to act up again. 😡 So 3 times in 3 years. Not fun. It starts with get in, step on brake, push start button and nothing except the dash some of the things will light up each time I push the button it's something different lighting up. I have gotten out of the vehicle and done the remote start at times. I will be taking it in tomorrow for a new sensor again 😡
 

·
Registered
Joined
·
2 Posts
I have a 2018 Armada. I've had the brake start sensor thingy replaced twice so far and mine just starting to act up again. 😡 So 3 times in 3 years. Not fun. It starts with get in, step on brake, push start button and nothing except the dash some of the things will light up each time I push the button it's something different lighting up. I have gotten out of the vehicle and done the remote start at times. I will be taking it in tomorrow for a new sensor again 😡
Hi. Which sensor is it? the brake light switch or the cruise control switch? Having the same problem on my 2018 platinum, my wife thinks I'm not doing anything about it because the dealer wants me to tow it to them when it happens. nonsense.
 
1 - 15 of 15 Posts
Top