Nissan Armada & Infiniti QX56 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
The default screen on my MMSI system is the navigation screen. In my town of 50,000 in Alaska navigation is the last screen I need. This is my 3rd Armada and I have not had this issue before. I've been chasing it for 10 months and my dealer has been a prick about it. So I'm reaching out to others before I go to the top of the food chain and get help from Mr. Nissan.
Guaranteed this will be the last Armada when this lease is up.
It just has to be a firmware fix if I could just get somebody to help.
Thank you.
 

·
Super Moderator
Joined
·
5,819 Posts
happy to attempt to help, but I'm a bit ignorant on the later models... what is "MMSI"?
you have a "status" button yes? when you touch this button, does it change the screen to different pages (i.e. radio, gps, hvac, etc) at each push? if it does, and you leave the last screen to show the radio for example and turn off the car, will that radio screen still be shown at startup or does it default back to gps?

and do you have a fully loaded trim model?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
happy to attempt to help, but I'm a bit ignorant on the later models... what is "MMSI"?
you have a "status" button yes? when you touch this button, does it change the screen to different pages (i.e. radio, gps, hvac, etc) at each push? if it does, and you leave the last screen to show the radio for example and turn off the car, will that radio screen still be shown at startup or does it default back to gps?

and do you have a fully loaded trim model?
Good morning. Thank you for your response. Apoligies - the MMSI is the screen on the dash board system.
Yes - I have to punch “status” every time the ignition is turned off. On my two previous Armadas the screen performed as you described but not this 2019. My wonderful dealer has patted me on the head and finally told me that is way it’s supposed to work and there is no fix.
I can’t believe that is correct and am trying to get some help but not from Fairbanks Nissan.
I’ve tested a 2019 in Tucson and it behaves the same way. My dealer has a 2020 and he says it does the same thing.
I’m not buying it so want to press on and find somebody, inside Nissan or out, who can give a definitive answer.
And yes - it is the Platinum model.
Thank you again.
 

·
Super Moderator
Joined
·
5,819 Posts
ahh i hear you. yeah i think that is nissans decision to have it that way. it may be something that was overlooked in the firmware build.

at least there can be more frequent updates on the newer system so it may be worth your time to reach out directly to nissan corporate offices and submit request. ive looked over the nissan connect manual for that year and dont see any setting to choose a screen on startup.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Thanks for the quick response. I'm going to start up the food chain starting with the "zone manager". That will be an interesting request. I will be ignored at which time I will get a hold of Nissan Anchorage to see if they have a zone manager whose shoulder I can cry on.
I'll keep you in the loop.
And thanks again.
 

·
Registered
Joined
·
2 Posts
This has always been a HUGE complaint of mine and I just dont get it. My 2018 SV is the same way. There is no way to change the default screen and it drives me crazy. Good luck with your endeavor and hopefully you can come up with a solution.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
This has always been a HUGE complaint of mine and I just dont get it. My 2018 SV is the same way. There is no way to change the default screen and it drives me crazy. Good luck with your endeavor and hopefully you can come up with a solution.
Hello Scott: Nice to hear of someone with equal frustrations. Today I called Nissan Consumer Affairs (800-647-7261) and talked to a very nice gent named Carl. We spent 44 minutes doing research and creating notes to see if he could find a thread to help with a solution. No luck.
So he created a case number (38505434) and is going to turn this over to the next level of support that will be more technical. They will call back by COB tomorrow.
I told him of your 2018 issue so that was of interest to him as well.
I'll advise when I hear something. He expressed great surprise and empathy for my sitiaotion but then that's his job. But it is a baby step.
We had a good laugh when I told him another problem was that the car thermometer would not indicate colder than 22 degrees below zero. He wanted to know how I knew that and I told him because the high temperature in Fairbanks today is 42 below zero....... I told him that if I freeze to death, I want to know at what temperature.
I'll let you know what I find out.
Best regards.
Gary Wilken
Fairbanks Alaska
907.378.0707 m
 

·
Registered
Joined
·
1 Posts
Hi Gary,

Came across your post today and was curious what the eventual outcome with Nissan was with this issue? I too am curious why the decision to default to the Nav screen rather than the radio (or last screen displayed) was made and if anything could be done to change this.

Thanks!
 

·
Registered
Joined
·
1 Posts
Hey all, following this thread, as we recently bought a 2019 SL, and our previous Armada (2007 SE) didn't have the MMSI, so this is a new and irritating issue.
 
1 - 10 of 10 Posts
Top