Nissan Armada & Infiniti QX56 Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I've had problems with the Bluetooth not connecting (likely my phone) so I tried to see if there were other options. My dash control panel lists both USB and Ipod options. But when I look at the video online of the 2020 Armada, it shows a USB in one of the center console boxes under the lid. But I have no USB port there, just an empty box. I do have two USB ports under the front control panel, toward the passenger side. But when I plug my phone in there it seems to only give a (weak) power charge ... nothing comes up as either a USB or Ipod when my phone is plugged in there. I read somewhere that when you don't have a center USB, you can use the front USB to get music via USB or Ipod.

What I am doing wrong? Or has USB and Ipod been disabled (even though it shows up) because I don't have that center port?
 

·
Administrator
Joined
·
6,652 Posts
post up a photo of your center where the ports are, so other can see whats going on.

can you try another phone? can you use a different cable?

dont expect PD level charging out of the usb port. its going to be trickle charge at best.

did you buy the car new? if used, are there any electrical mods or aftermarket equipment installed on the car?
 

·
Registered
2020 Armada Platinum
Joined
·
15 Posts
I have the same problem with my android s10 connecting but my wife iphone connects instantly. So what I do is go to Settings / Bluetooth/ Turn on bluetooth/ Select audio device / Click phone name / Turn on phone bluetooth/ Click trucks name on phone/ Then click AUDIO on radio / CLICK BLUETOOTH/ Now you should be connected. This is my way give it a try. let me know if it works
 
1 - 3 of 3 Posts
Top