Nissan Armada & Infiniti QX56 Forums banner
1 - 20 of 22 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all,

I have had my 2021 Armada for just under 3 weeks now and have had nothing but problems with vehicles electronics systems.

First, every time I drive the vehicle I get an error code through the app that tells me to have the vehicle serviced.

The error messages will say either the Transmission Fluid Pressure Sensor needs to be serviced or that the Oil Pressure Sensor needs servicing.

I have taken the vehicle in for service and the vehicles computer doesn't even store the error codes that I am receiving.

The dealers have tried to tell me that there may be someone else who registered an incorrect VIN in their app and I am reviving their error messages. This makes no sense to me. All I know is that with all of these error codes (6 in 3 weeks), I find that I am really concerned about driving this vehicle because I am not sure if the vehicle is really having service required issues or is there some sort of glitch in the system.

I was driving yesterday, got another error code and took it to the dealer I purchased it from, they put it on the computer and it shows no error codes even though I have dash light warning and one in the app as well.

Second, the vehicles Bluetooth connection continues to disappear while I am driving and the vehicles Bluetooth signal is completely gone, it cannot connect to my phone and my phone does not recognize any Bluetooth signal from the Armada.

The only way I can get these to pair with each other is to forget the device on the Armada and my phone. Then I have to stop the vehicle, wait about 30 seconds and then I have to turn off and the restart the vehicle.

If I am able to pair the devices again, if will stay paired for about 2 or 3 uses of the vehicle and then disappear again. My phone is an iPhone 12 Pro.

I had this checked out by one dealer who said they reset the system and everything should be working fine, this is not the case and this issue continues to happen.

Third, I cannot get the Armadas wifi hot spot to activate and allow for use. I have registered the vehicles hot spot with AT&T and put it on my cell phone plan.

Every time I try to use the Hotspot, i pick the vehicles wifi spot and it immediately takes me to a AT&T my vehicle page for Nissan and adults me to register the vehicle. When I do so, it tells me that the vehicle is already registered and I cannot connect to the internet and the wifi Hotspot will drop the connection and disconnect.

To this day, I have not been able to connect to the internet one time.

So now comes the recap that I have been given by the Nissan dealership.

The Armada is supposedly not able to work with my IOS device because the operating system I am using on my devices (14.6) is not compatible with the vehicles electronic system. I was told if I was working off of operating system (14.5) the vehicle would be working just fine but right now there needs to be an update that will allow the vehicles electronic system.

Problem is, the dealership cannot tell me if the update needs to come from Apple or if it had to come from Nissan. All I know is that the vehicle is not working correctly and the continuing warning symbols are a huge concern for me.

So that is an overview of what I have been dealing with since taking ownership of the vehicle.

Does anyone have any issues similar to these? If so, could you possibly offer some words of hope.

Thanks in advance.
 

·
Registered
2021 Nissan Armada SL RWD
Joined
·
47 Posts
Hey - sorry for your troubles. 1st world problems, right? I just posted in another spot, Nissan released a s fort ware update last week (on Tuesday or Wednesday) for the infotainment system and I let it download and update while I was on the road, I have a ‘21 myself. I’m running 14.6 on my Xr and it seems to work just fine. You seem tech savvy so, take some pictures or videos of the error codes/messages, especially if the system isn’t storing the codes for the dealer to see. If I was having repeated issues, I’d camp out at the dealer, file a complaint with Nissan Corp. and make darn sure I was happy with the vehicle and the functionality.

Here is a pic of the update:

50386
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Here is a pic of the update:

View attachment 50386
Thank you so much for the information on the update. I will check my unit to see what version of its running.

I have screen shots of the 3 latest warning signals that I have received since yesterday. I am not looking for anything more than a properly functioning vehicle, right now I am so far away from having that.

Thank you so much for the information on the update. I will check my unit to see what version of its running.

I have screen shots of the 3 latest warning signals that I have received since yesterday. I am not looking for anything more than a properly functioning vehicle, right now I am so far away from having that.
I just checked and I have the same software version. 😟
 

·
Administrator
Joined
·
6,188 Posts
i did not read the OPs entire post, buti get a sense they are having issues that are potentially from the infotainment.

there have been some 2021 owners who are having issues as well with this new infotainment system.

my advice to anyone who are having any issues with this new model year , is to take the car back and have nissan fix it or buy the car back. these cars are too brand new for anyone to start troubleshooting them. these are bugs in the system, ands this happens to a new model vehicle with major refreshes.

its possible infiniti know about these but its up to you "beta testers" of this new system to reach out to nissan consumer affairs and complain about this.
 

·
Registered
Joined
·
1 Posts
I purchased a beautiful 21 Armada 2 months ago and my truck has been siting at the dealer because the center display on top of the new dash keeps cutting out. Nissan cant figure out what is causing this annoying problem. Has anyone experienced this problem. This is 7th Nissan vehicle we have owned and we never had any issues. We traded in our 2011 Armada platinum that we loved and cherished for the 2021. Please help, getting no where with Nissan....
 

·
Administrator
Joined
·
6,188 Posts
welcome paul.

you are not alone with software issues on the lastest armada. i've also seen this behavior on the 21 qx.

the car is so new so there is not muh that can be done other than to document it so others searching over the internet can see and respond. looks like it may be a software issue since this system has some modern software refreshes. im sure nissan japan know what could be the issue and are likely addressing it with a software update at some point.

id cal around to some other dealers across the country, not just your loca city. maybe some other dealers across the country have had better success.
 

·
Registered
2020 Armada Platinum
Joined
·
14 Posts
Take it back tell them to stop giving you the run around, like the other guy said complain and or tell them to buy it back. Stop letting them run you over with" we can't find nothing wrong with it" nissan has the best warranty program then any other manufacturer. I had to be really firm when getting my rotors replaced because they became warped 1 month after buying. They said it wasn't covered but I didn't budge.
 

·
Registered
2021 Armada SL
Joined
·
11 Posts
welcome paul.

you are not alone with software issues on the lastest armada. i've also seen this behavior on the 21 qx.

the car is so new so there is not muh that can be done other than to document it so others searching over the internet can see and respond. looks like it may be a software issue since this system has some modern software refreshes. im sure nissan japan know what could be the issue and are likely addressing it with a software update at some point.

id cal around to some other dealers across the country, not just your loca city. maybe some other dealers across the country have had better success.
Today, while pulling my 2021 SL rwd into the garage, the infotainment screen/system did a refresh and I couldn't bring the camera back up. (I use the cam in parking in the garage)

Is this how the system upgrades and loads updates?

I have mine set to update automatically.
 

·
Administrator
Joined
·
6,188 Posts
no that's not how it is supposed to be. again the system has bugs for sure. if you want to dictate when your car gets the updates installed, i would prefer to make that selection so you are not caught in a situation (like you spojke of) where you need something from the system but its doing an update.

also, can't agree more with what @2020PLATINUM wrote! these cars are brand new. you should not have your car sitting at some back lot out in the hot sun damaging your cars paint whilst you are paying the loan (assuming you have it financed). even if you dont have a lien on it, its YOUR car and if you cant get any use out of it, take it black and have them get you another car or walk away from it. i love nissan/infiniti, but these dealers can make these brands lok bad. more of these dealers are trying to recoup their losses from the last year so they are trying to kick the can down the road and appease owners when the dealer couldn't care less about your car working or not.

complain. go pick up your car and take it to another dealer. speak to nissan consumer affairs and log this issue. maybe its tsb level...
 

·
Premium Member
Joined
·
16 Posts
We have a 2017 Armada bought used with about 20K in May of 2018. On the Carfax report I noted that the radio had been replaced by the dealer we purchased it from. A few months ago, my wife, the primary driver, began experiencing a spate of odd electrical system problems. Dome light coming on after starting, headlights not coming on, various error lights showing up, etc. She would have to stop and restart to regain normal operation. She took it in to the dealer and after a drive and various testing they couldn't duplicate the problem. The issues continued and she took it in again ten days later. They consulted with higher ups and ended up replacing the radio ($1,500 for a refurbished unit, a new one is $5,000), which reminded me that the dealer we purchased from, not the local dealer, had replaced the radio. Fortunately, we paid for the top bumper to bumper extended warranty at the time of purchase. The problems persisted.

My wife took it to the dealer again on March 13, and this time a different tech asked to ride along for a test drive. Almost immediately things started happening and the tech reached back from the front passenger seat and opened and closed the rear passenger door. Everything returned to normal and worked fine on the drive back to the dealer. The tech removed the rear passenger door sensor switch, installed an extra washer between the switch and door frame and reinstalled the switch. When my wife came home with the Armada, with the rubber boot installed, I couldn't see any difference between that switch and the switches on the other doors, but we have had no problem since with over 2K miles on the vehicle.

I'm retired but most of my working career was spent servicing microprocessor controlled office equipment. Odd interference between various pieces of gear, and sometimes from outside sources like commercial radio stations, was not uncommon so the solution to the Armada's problems wasn't too surprising. Don't know if this will help with your problems, but it's an easy fix to try. Good Luck!
 

·
Registered
2021 Nissan Armada SL RWD
Joined
·
47 Posts
We have a 2017 Armada bought used with about 20K in May of 2018. On the Carfax report I noted that the radio had been replaced by the dealer we purchased it from. A few months ago, my wife, the primary driver, began experiencing a spate of odd electrical system problems. Dome light coming on after starting, headlights not coming on, various error lights showing up, etc. She would have to stop and restart to regain normal operation. She took it in to the dealer and after a drive and various testing they couldn't duplicate the problem. The issues continued and she took it in again ten days later. They consulted with higher ups and ended up replacing the radio ($1,500 for a refurbished unit, a new one is $5,000), which reminded me that the dealer we purchased from, not the local dealer, had replaced the radio. Fortunately, we paid for the top bumper to bumper extended warranty at the time of purchase. The problems persisted.

My wife took it to the dealer again on March 13, and this time a different tech asked to ride along for a test drive. Almost immediately things started happening and the tech reached back from the front passenger seat and opened and closed the rear passenger door. Everything returned to normal and worked fine on the drive back to the dealer. The tech removed the rear passenger door sensor switch, installed an extra washer between the switch and door frame and reinstalled the switch. When my wife came home with the Armada, with the rubber boot installed, I couldn't see any difference between that switch and the switches on the other doors, but we have had no problem since with over 2K miles on the vehicle.

I'm retired but most of my working career was spent servicing microprocessor controlled office equipment. Odd interference between various pieces of gear, and sometimes from outside sources like commercial radio stations, was not uncommon so the solution to the Armada's problems wasn't too surprising. Don't know if this will help with your problems, but it's an easy fix to try. Good Luck!
These are the little tidbits that make owners forums invaluable. I can guarantee this will help someone out there with the same issue. Thanks for taking the time to post it here. 👍🏻👍🏻
 
  • Like
Reactions: marctronixx

·
Premium Member
Joined
·
16 Posts
These are the little tidbits that make owners forums invaluable. I can guarantee this will help someone out there with the same issue. Thanks for taking the time to post it here. 👍🏻👍🏻
Thanks! It's hard for folks without experience in microprocessor controlled gear to understand the interactions that can occur with outside sources. It's complicated by the unpredictability factor; it requires an open mind and field experience, can't be learned in a classroom or from a book. Sometimes individual users would build up such strong static charges that they damaged equipment simply by touching it. One man kept blowing pricey electret mic capsules each time he picked up the hand mic on a desktop dictation unit. I put a piece of stainless steel tape on the back of the mic and wired it to the ground wire in the mic cord so each time he touched the mic he discharged any static to ground. That was in the mid eighties and I still have the remainder of the roll of tape.
 

·
Registered
Joined
·
2 Posts
Drove to the grocery store this morning - everything was fine. Was in the store for about an hour. Come out, start the truck, and the radio will not come on. I have no backup cameras, no dash readouts except for digital speedometer. This issue adds to the list that I have had with this vehicle. I am extremely disappointed in Nissan at this point. For a $60k+ vehicle, I expect better than this.

Has anyone else had this issue?
 

·
Administrator
Joined
·
6,188 Posts
as you can see here, there are others with these types of issues on this model car, both qx and armada since they are essentially the same car made on the same line.

my advice - take it back to the dealer and have them address it. if they cant, either ask for a new car/have them buy it back, complain to corporate, or return the car and move on to another vehicle. there is no way im going to continue to drive a car that has these issues and the dealer is sitting on their hands and not helping, ior just trying to kick the can down the road with useless info.

the car is too new to deal with this, and i am a major nisan fanboy!
 

·
Registered
2021 Nissan Armada SL RWD
Joined
·
47 Posts
Drove to the grocery store this morning - everything was fine. Was in the store for about an hour. Come out, start the truck, and the radio will not come on. I have no backup cameras, no dash readouts except for digital speedometer. This issue adds to the list that I have had with this vehicle. I am extremely disappointed in Nissan at this point. For a $60k+ vehicle, I expect better than this.

Has anyone else had this issue?
Again, the price of a new vehicle is irrelevant. It could be a 21 McLaren or a 21 Kia, they should both perform as new, regardless of the price. Take it back to the dealer and drive a loaner/rental on them until you're happy with it. This is why we buy new vehicles. And, we are guinea pigs with the new infotainment layout; knock on wood, no major issues with mine yet...
 

·
Registered
Joined
·
2 Posts
Hello all,

I have had my 2021 Armada for just under 3 weeks now and have had nothing but problems with vehicles electronics systems.

First, every time I drive the vehicle I get an error code through the app that tells me to have the vehicle serviced.

The error messages will say either the Transmission Fluid Pressure Sensor needs to be serviced or that the Oil Pressure Sensor needs servicing.

I have taken the vehicle in for service and the vehicles computer doesn't even store the error codes that I am receiving.

The dealers have tried to tell me that there may be someone else who registered an incorrect VIN in their app and I am reviving their error messages. This makes no sense to me. All I know is that with all of these error codes (6 in 3 weeks), I find that I am really concerned about driving this vehicle because I am not sure if the vehicle is really having service required issues or is there some sort of glitch in the system.

I was driving yesterday, got another error code and took it to the dealer I purchased it from, they put it on the computer and it shows no error codes even though I have dash light warning and one in the app as well.

Second, the vehicles Bluetooth connection continues to disappear while I am driving and the vehicles Bluetooth signal is completely gone, it cannot connect to my phone and my phone does not recognize any Bluetooth signal from the Armada.

The only way I can get these to pair with each other is to forget the device on the Armada and my phone. Then I have to stop the vehicle, wait about 30 seconds and then I have to turn off and the restart the vehicle.

If I am able to pair the devices again, if will stay paired for about 2 or 3 uses of the vehicle and then disappear again. My phone is an iPhone 12 Pro.

I had this checked out by one dealer who said they reset the system and everything should be working fine, this is not the case and this issue continues to happen.

Third, I cannot get the Armadas wifi hot spot to activate and allow for use. I have registered the vehicles hot spot with AT&T and put it on my cell phone plan.

Every time I try to use the Hotspot, i pick the vehicles wifi spot and it immediately takes me to a AT&T my vehicle page for Nissan and adults me to register the vehicle. When I do so, it tells me that the vehicle is already registered and I cannot connect to the internet and the wifi Hotspot will drop the connection and disconnect.

To this day, I have not been able to connect to the internet one time.

So now comes the recap that I have been given by the Nissan dealership.

The Armada is supposedly not able to work with my IOS device because the operating system I am using on my devices (14.6) is not compatible with the vehicles electronic system. I was told if I was working off of operating system (14.5) the vehicle would be working just fine but right now there needs to be an update that will allow the vehicles electronic system.

Problem is, the dealership cannot tell me if the update needs to come from Apple or if it had to come from Nissan. All I know is that the vehicle is not working correctly and the continuing warning symbols are a huge concern for me.

So that is an overview of what I have been dealing with since taking ownership of the vehicle.

Does anyone have any issues similar to these? If so, could you possibly offer some words of hope.

Thanks in advance.
Hello, I have a 2021 Nissan Armada platinum. Purchased May 2021.
1. we called the Nissan connect app people, because the mileage was wrong in the app and it stated there was oil pressure problem. car had 400 miles on it ??
the app was not updating. The app help told us it was a ’known issue‘ BUT they fixed it. Look at app again, I hope yours is fixed.
2. both our iPhones connect fine, but this is my isssue. The volume reverts or resets to HIGH, when I get a text or call….it is SO LOUD it is deafening. I’m serious, the volume will be normal for Bluetooth radio, amazon music, or normal when I have serious Xm on, but as soon as I get a text notification, volume is all the way up, I turn it to medium , but reverts to high with another new text, same trip.
it happens with every iPhone notification, call, email, text sounds. My iPhone is set to medium

I hate this, I think it is a safety issue. I have gone through every menu on the car but it does not retain setting. I called Apple support and they blame Nissan.

Does anyone have a fix for this ?? Help
 

·
Administrator
Joined
·
6,188 Posts
none of us on here can fix the issue. you should reach out directly to nissan corporate and also your local dealer. demand they fix it or give you another vehicle. it makes no sense to have your new vehicle act as it is.
 

·
Registered
Joined
·
2 Posts
This is your reply to all our questions , There are a handful of platinum armadas available in the United States. Why would I go to my dealer and demand they give me another vehicle. Over a setting !.
I just posted this to get an answer Stop answering all our questions the same way
 

·
Administrator
Joined
·
6,188 Posts
the car is brand new. there is no reason anyone should have these issues on a new car.

if you just bought a new iphone and it was not working as per the specs, would you just deal with it at home or would you take it back and get a return? i think most would return for replacement.

the car has new tech in it over previous models. bugs are apparent. i mod across a couple of other sites and ive seen some folks on those sites with the same issues. so yes my response is to take it back. no one over the internet can fix your issue which clearly sounds like bugs in the software.

there are many more than a "handful" of 2021 qx/ and armadas out in the world. these enthusiasts sites draw attention to people who usually have issues with something. you did not find this site to boast how much you love the car -- you came here searching for a solution. unfortunately there is no solution that can be fixed by something simple on the consumer side, and needs to be dealt with through the dealer and nissan corporate.

i understand your frustration but there is not much to do other than to have the dealer fix your issue.
 

·
Registered
Joined
·
3 Posts
Looking to see if anyone has had this issue as well. Had the car only a week and twice the left portion of the screen go black. The radio portion stays on and you can see if but nothing on the left side. If I hit the Menu button, it pops up and you can see everything. But once you select an option it goes back to black. When you put it in park it will turn back on. Guessing it needs to be replaced but not sure.

Thank you!
 
1 - 20 of 22 Posts
Top