Nissan Armada & Infiniti QX56 Forums banner
21 - 40 of 105 Posts

·
Registered
Joined
·
2 Posts
Hello all,

I have had my 2021 Armada for just under 3 weeks now and have had nothing but problems with vehicles electronics systems.

First, every time I drive the vehicle I get an error code through the app that tells me to have the vehicle serviced.

The error messages will say either the Transmission Fluid Pressure Sensor needs to be serviced or that the Oil Pressure Sensor needs servicing.

I have taken the vehicle in for service and the vehicles computer doesn't even store the error codes that I am receiving.

The dealers have tried to tell me that there may be someone else who registered an incorrect VIN in their app and I am reviving their error messages. This makes no sense to me. All I know is that with all of these error codes (6 in 3 weeks), I find that I am really concerned about driving this vehicle because I am not sure if the vehicle is really having service required issues or is there some sort of glitch in the system.

I was driving yesterday, got another error code and took it to the dealer I purchased it from, they put it on the computer and it shows no error codes even though I have dash light warning and one in the app as well.

Second, the vehicles Bluetooth connection continues to disappear while I am driving and the vehicles Bluetooth signal is completely gone, it cannot connect to my phone and my phone does not recognize any Bluetooth signal from the Armada.

The only way I can get these to pair with each other is to forget the device on the Armada and my phone. Then I have to stop the vehicle, wait about 30 seconds and then I have to turn off and the restart the vehicle.

If I am able to pair the devices again, if will stay paired for about 2 or 3 uses of the vehicle and then disappear again. My phone is an iPhone 12 Pro.

I had this checked out by one dealer who said they reset the system and everything should be working fine, this is not the case and this issue continues to happen.

Third, I cannot get the Armadas wifi hot spot to activate and allow for use. I have registered the vehicles hot spot with AT&T and put it on my cell phone plan.

Every time I try to use the Hotspot, i pick the vehicles wifi spot and it immediately takes me to a AT&T my vehicle page for Nissan and adults me to register the vehicle. When I do so, it tells me that the vehicle is already registered and I cannot connect to the internet and the wifi Hotspot will drop the connection and disconnect.

To this day, I have not been able to connect to the internet one time.

So now comes the recap that I have been given by the Nissan dealership.

The Armada is supposedly not able to work with my IOS device because the operating system I am using on my devices (14.6) is not compatible with the vehicles electronic system. I was told if I was working off of operating system (14.5) the vehicle would be working just fine but right now there needs to be an update that will allow the vehicles electronic system.

Problem is, the dealership cannot tell me if the update needs to come from Apple or if it had to come from Nissan. All I know is that the vehicle is not working correctly and the continuing warning symbols are a huge concern for me.

So that is an overview of what I have been dealing with since taking ownership of the vehicle.

Does anyone have any issues similar to these? If so, could you possibly offer some words of hope.

Thanks in advance.
Hello, I have a 2021 Nissan Armada platinum. Purchased May 2021.
1. we called the Nissan connect app people, because the mileage was wrong in the app and it stated there was oil pressure problem. car had 400 miles on it ??
the app was not updating. The app help told us it was a ’known issue‘ BUT they fixed it. Look at app again, I hope yours is fixed.
2. both our iPhones connect fine, but this is my isssue. The volume reverts or resets to HIGH, when I get a text or call….it is SO LOUD it is deafening. I’m serious, the volume will be normal for Bluetooth radio, amazon music, or normal when I have serious Xm on, but as soon as I get a text notification, volume is all the way up, I turn it to medium , but reverts to high with another new text, same trip.
it happens with every iPhone notification, call, email, text sounds. My iPhone is set to medium

I hate this, I think it is a safety issue. I have gone through every menu on the car but it does not retain setting. I called Apple support and they blame Nissan.

Does anyone have a fix for this ?? Help
 

·
Administrator
Joined
·
6,638 Posts
none of us on here can fix the issue. you should reach out directly to nissan corporate and also your local dealer. demand they fix it or give you another vehicle. it makes no sense to have your new vehicle act as it is.
 

·
Registered
Joined
·
2 Posts
This is your reply to all our questions , There are a handful of platinum armadas available in the United States. Why would I go to my dealer and demand they give me another vehicle. Over a setting !.
I just posted this to get an answer Stop answering all our questions the same way
 

·
Administrator
Joined
·
6,638 Posts
the car is brand new. there is no reason anyone should have these issues on a new car.

if you just bought a new iphone and it was not working as per the specs, would you just deal with it at home or would you take it back and get a return? i think most would return for replacement.

the car has new tech in it over previous models. bugs are apparent. i mod across a couple of other sites and ive seen some folks on those sites with the same issues. so yes my response is to take it back. no one over the internet can fix your issue which clearly sounds like bugs in the software.

there are many more than a "handful" of 2021 qx/ and armadas out in the world. these enthusiasts sites draw attention to people who usually have issues with something. you did not find this site to boast how much you love the car -- you came here searching for a solution. unfortunately there is no solution that can be fixed by something simple on the consumer side, and needs to be dealt with through the dealer and nissan corporate.

i understand your frustration but there is not much to do other than to have the dealer fix your issue.
 

·
Registered
Joined
·
5 Posts
Looking to see if anyone has had this issue as well. Had the car only a week and twice the left portion of the screen go black. The radio portion stays on and you can see if but nothing on the left side. If I hit the Menu button, it pops up and you can see everything. But once you select an option it goes back to black. When you put it in park it will turn back on. Guessing it needs to be replaced but not sure.

Thank you!
 

·
Premium Member
Joined
·
539 Posts
Looking to see if anyone has had this issue as well. Had the car only a week and twice the left portion of the screen go black. The radio portion stays on and you can see if but nothing on the left side. If I hit the Menu button, it pops up and you can see everything. But once you select an option it goes back to black. When you put it in park it will turn back on. Guessing it needs to be replaced but not sure.

Thank you!
That is NOT normal... If still under warranty get it replaced.
 
  • Like
Reactions: marctronixx

·
Registered
2021 Nissan Armada SL
Joined
·
218 Posts
That is NOT normal... If still under warranty get it replaced.
True, not normal. We rented a new Infinity a few weeks ago up in TN. This happened one night on that vehicle as well. Luckily, because I had read a post here, all I did was hold the power button down and the entire system was reset / rebooted. Now, I have not had to do this in my Armada but, it worked in the Infinity all-the-same. I assume that it's just a glitch, like all computers are prone to do. Before I took it back to the dealership, I'd try this to reset/reboot the system. As far as I can tell, this does not change any of the user preferences, just reboots the infotainment system.
 

·
Registered
Joined
·
5 Posts
True, not normal. We rented a new Infinity a few weeks ago up in TN. This happened one night on that vehicle as well. Luckily, because I had read a post here, all I did was hold the power button down and the entire system was reset / rebooted. Now, I have not had to do this in my Armada but, it worked in the Infinity all-the-same. I assume that it's just a glitch, like all computers are prone to do. Before I took it back to the dealership, I'd try this to reset/reboot the system. As far as I can tell, this does not change any of the user preferences, just reboots the infotainment system.
Thanks for the info. When do you hold down the power button to reboot it and for how long? I'll give that a try before I take it up to the dealership.
 

·
Registered
2021 Nissan Armada SL
Joined
·
218 Posts
Thanks for the info. When do you hold down the power button to reboot it and for how long? I'll give that a try before I take it up to the dealership.
You can do it any time, and probably hold it down for 10 seconds or so.
 
  • Like
Reactions: toname

·
Registered
Joined
·
1 Posts
I purchased a beautiful 21 Armada 2 months ago and my truck has been siting at the dealer because the center display on top of the new dash keeps cutting out. Nissan cant figure out what is causing this annoying problem. Has anyone experienced this problem. This is 7th Nissan vehicle we have owned and we never had any issues. We traded in our 2011 Armada platinum that we loved and cherished for the 2021. Please help, getting no where with Nissan....
we are having the same issues with both of our '21 Armadas.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #32 ·
Jumping in on this conversation. Yes, hold it down for 10-15 seconds and it will go black and reboot. I have to do this all the time. I've made a couple posts on this issue regarding the Infotainment system for the 2021 Armada. Nissan should be embarrassed on this release. You'll likely waste your time at the Dealership. They'll tell you it's because of your bluetooth connected phones and to wait for the release. I love this truck, otherwise.
 

·
Registered
2021 Nissan Armada SL
Joined
·
218 Posts
Jumping in on this conversation. Yes, hold it down for 10-15 seconds and it will go black and reboot. I have to do this all the time. I've made a couple posts on this issue regarding the Infotainment system for the 2021 Armada. Nissan should be embarrassed on this release. You'll likely waste your time at the Dealership. They'll tell you it's because of your bluetooth connected phones and to wait for the release. I love this truck, otherwise.
No issues on my ‘21 yet (knock on wood)…
 
  • Like
Reactions: marctronixx

·
Registered
Joined
·
2 Posts
I just bought my Armada in July and today the radio stopped working. No FM, no AM, no XM, no Bluetooth. The audio screen doesn't even come up when I try to press the audio button either on the screen or on the console. Very frustrating
 

·
Registered
2021 Nissan Armada SL
Joined
·
218 Posts
I just bought my Armada in July and today the radio stopped working. No FM, no AM, no XM, no Bluetooth. The audio screen doesn't even come up when I try to press the audio button either on the screen or on the console. Very frustrating
It can be glitchy for-sure. Sometimes my wireless carplay does not connect or, it disconnects when I'm actually using the nav or conf. call, etc...equally frustrating. You can do a hard reset and it restarts the unit but keeps all the settings. You just hold down the power / volume knob for (maybe) 8-10 seconds and the system will reboot. Not sure if that will help you or not. I bet if you take it to the dealer they will struggle to "recreate" the challenges you're seeing...that's usually how it happens for me.
 
  • Like
Reactions: toname

·
Registered
Joined
·
2 Posts
It can be glitchy for-sure. Sometimes my wireless carplay does not connect or, it disconnects when I'm actually using the nav or conf. call, etc...equally frustrating. You can do a hard reset and it restarts the unit but keeps all the settings. You just hold down the power / volume knob for (maybe) 8-10 seconds and the system will reboot. Not sure if that will help you or not. I bet if you take it to the dealer they will struggle to "recreate" the challenges you're seeing...that's usually how it happens for me.
Thanks!!! The reset thing worked. Good to know for the future. Still ridiculous that you even have to do that for the price of the vehicle.
 

·
Registered
2021 Nissan Armada SL
Joined
·
218 Posts
Thanks!!! The reset thing worked. Good to know for the future. Still ridiculous that you even have to do that for the price of the vehicle.
I know, you’re right. And I’ve said it before, the price is irrelevant, the product should work. Maybe an OTA update is coming soon. It’s pretty new tech, not cutting edge but new enough.
 

·
Registered
Joined
·
1 Posts
Major issues with my 2021 Armada also. Infotainment system screen goes blank and resets from time to time. Sometimes as much as 10x/hr making the system unusable. Dealer has not been too helpful. There was a SW release they upgraded to, but the gremlins are still there. Seems to happen with/without iPhones connected (hardwire or wifi). I have provide video examples of the symptoms, but dealer is wanting a log of the incidents with date/time/indoor-outdoor temps, etc. Not sure if this is SW or HW related (or both). Some of the resets are back to factory default (I loose all address book entries, home address, date/time, etc). Clearly this was not ready for prime time.
 

·
Administrator
Joined
·
6,638 Posts
thanks for your input and sad to hear yet another owner with these issues. as you can see from this thread this is becoming somewhat of a problem. Nissan im sure are aware but it would be helpful on your part to message nissan consumer affairs directly with the data you have accumulated. the more people who do this DIRECTLY to nissan, the sooner they can find the bugs and issue updates.
 

·
Registered
Joined
·
1 Posts
I wish I had read this post before I purchased my 2021 Armada last month. Not only is it extremely glitchy, my back up camera actually freezes when I’m backing up & that is dangerous. I never experienced many problems with my 2008 Armada. I almost hated to part with her but it was time for an upgrade.
 
21 - 40 of 105 Posts
Top