Nissan Armada & Infiniti QX56 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
124 Posts
Discussion Starter #1
Long story sort I finally replaced my rear left bearing so all the warning lights went off until about a mile down the road the 4WD light came on so I turned the switch to another mode and it went out and started working again.

Does the 4WD system store codes? The system will turn off the 4WD warning light by just switching modes and sometimes it wont come back on for another 20+ miles.. Also when in Auto mode I only saw it once when it switched into 2WD mode otherwise it always stays in 4WD when in auto and on the highway.
 

·
Premium Member
Joined
·
3,403 Posts
When you say it always stays in 4WD when in auto and on the highway, how do you know? When I put mine in Auto, an indicator comes on that signifies it's in Auto, but I have no idea if the system is putting power to all 4 wheels, or just the rear wheels. When I switch to 4WD, then the steering feel changes noticeably; the effort to turn the wheel is higher, which is what I'd expect, since in 4WD the front and rear axles are locked to spin at the same rate no matter what.

I'm guessing from what you're saying that the switch is fine, and you still have a sensor problem. Sounds like, from all of your posts, that you have your hands full with this Armada. Kudos to you for figuring this all out.

Keith
 

·
Registered
Joined
·
124 Posts
Discussion Starter #3
When you say it always stays in 4WD when in auto and on the highway, how do you know? When I put mine in Auto, an indicator comes on that signifies it's in Auto, but I have no idea if the system is putting power to all 4 wheels, or just the rear wheels. When I switch to 4WD, then the steering feel changes noticeably; the effort to turn the wheel is higher, which is what I'd expect, since in 4WD the front and rear axles are locked to spin at the same rate no matter what.

I'm guessing from what you're saying that the switch is fine, and you still have a sensor problem. Sounds like, from all of your posts, that you have your hands full with this Armada. Kudos to you for figuring this all out.

Keith
When it's in Auto all 4 wheels are lit I did see coming from work it switched to 2WD not too much longer I think the 4WD light came on.. I tried to switch to 2WD then back to 4WD-auto while in drive that didn't work but when I put the car in park and moved the switch again the 4WD light went out.. and on the highway switching from Auto 4WD to 2WD I can see the steering has a lighter feel so it's in 4WD at highway speed and not dropping to 2WD.

I'm going to try and see if the code is stored.

Ok so I think I got the codes right So this is what I have..

6
7
11
12
17
22
23

It seems like a lot of codes for something that much I would think the 4wd warning would come on right away.. but it clears up using just the switch? Code 11 I'm confused because in the FSM it talks about the 2-4wd shift solenoid valve circuit 2wd switch of 4wd shift switch I'm not sure what that means.

Ok I found this out yesterday when the light comes on if I just move the switch just a small bit like less than 1 mm the 4WD light goes off and the display shows all 4 wheels lit.
 

·
Registered
Joined
·
124 Posts
Discussion Starter #5
That’s what I’m thinking but all those codes for a bad switch? I’ll have to get another to try.
 
1 - 5 of 5 Posts
Top