Nissan Armada & Infiniti QX56 Forums banner
1 - 3 of 3 Posts

·
Premium Member
Joined
·
22 Posts
Discussion Starter · #1 ·
Nissan Armada 2006

I changed the clock spring several years ago and while it was "i am assuming" calibrating itself the abs went on and off a couple of times. All of the sudden the ABS light went ON and never went off and I the truck worked without any problems.
Back to 2022 they put a new rack and pinon to the truck and apparently the mechanic did a hard reset on the computer. Now the ABS light is off but whenever I go over 15 mph and turn the steering wheel off in any direction by degrees the ABS system activates and it gets dangerous to drive the truck. I got it scanned and there is no code related to ABS.
After the new rack and pinion were installed I took it to the tire shop for a professional alignment.
I am wondering if any of you have had this problem?

Thank you in advance for your help!
 

·
Premium Member
Joined
·
1,558 Posts
Not all scan tools will read/diagnose ABS systems. Also, a hard reset to the ECM isn’t going to do anything in regards to the ABS issue you’re having.
Since you had the alignment done, see if that shop has a scan tool that has the capability to do a steering wheel angle reset.
 
  • Like
Reactions: marctronixx

·
Premium Member
Joined
·
50 Posts
FWIW...a year or 3 ago the ABS on my 06 would randomly activate. Pull over and turn the truck off and it would be fine for weeks, even months and then it would happen again. No codes but ABS and other lights would come on. On the advice of someone on this forum (whom i wish I could give credit to them but I don't remember who it was) who claimed to be a Nissan Tech, I topped up the brake fluid. I mean to the top. Haven't had a problem since.
 
1 - 3 of 3 Posts
Top