Nissan Armada & Infiniti QX56 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
A few months ago I bought Armada 2019. Since day 1 I have this problem that in the infotainment display it shows that fuel economy is 99.9MPG. Do all Armada's display the same or is this a software/hardware issue?

Also, I noticed that "range" that is displayed is very imprecise, when tank is fully filled it shows ~390miles, but a few miles later it can drop to ~330miles, and then go up again.

See attached images.
20200916_150540_HDR.jpg
20200916_150528_HDR.jpg
20200916_150452_HDR.jpg
 

·
Super Moderator
Joined
·
5,703 Posts
you clearly have something defective. it could be a sensor, or the BCM, or any combination of things. the MPG will fluctuate over time, and changes based on a number of things and depending on your driving style, so thats nothing new, but the display showing 99.x MPG is not kosher.

no trouble lamps correct? maybe worth a check at the obd port if you see any errors/faults.
when it involves software, it may be your best bet to just have nissan diagnose, so you are not chasing your tail.

so, questions.
its used, did you buy it private party or a dealer? if the latter, was there some warranty on it? did you ask the seller about this issue?

do you have the maintenance records on the car? any electrical modifications done to it as far as you know?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I bought from dealer, and the car was previously owned by a rental company. I think it is still under factory warranty as it is barely under 36K miles (it is 34.4K miles). Can I use factory warranty for this problem if so how?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Dealer did full computer reset which apperantly can be done only at dealership, and no way to do it at home. After that the glitch was gone. This is just a software glitch.
 
1 - 8 of 8 Posts
Top