Nissan Armada & Infiniti QX56 Forums banner

21 - 40 of 81 Posts

·
Super Moderator
Joined
·
5,165 Posts
They may not be able rot germ the engine codes from their reader. Doesn’t mean there are not any codes.

It’s really difficult to try and understand what could be going on over the internet. You could have issues with:

—spark plugs?
—cam angle sensor
—petrol pump
—starter
—etc...

Does it start up on the second try?
Can you reproduce this every time?
Does it happen when the car is cold? What if you’ve been driving for a while and then turn off the car.. does it start up right away then?

When did this start to happen? Is anything else wrong not he car electrically?
What trim options do you have on the car?
 

·
Registered
Joined
·
7 Posts
Just tried it this morning and it stared up on the first try with no problem. Still no codes showing up. However, all of our preset radio stations were gone, so it’s almost as if the car reset itself.

This just happened for the first time yesterday. Nothing else electrically is wrong that I can tell. We have the platinum trim level.
 

·
Registered
Joined
·
4 Posts
I had the exact same issue for the first time yesterday and have had it two more times since. I have a 2018 Armada. The BCI Malfunction warning came on while driving, then when i turned off car it would not restart for several times. It took about 5X before the car starts again and the warning light is gone.
 

·
Registered
Joined
·
7 Posts
I had the exact same issue for the first time yesterday and have had it two more times since. I have a 2017 Armada. The BCI Malfunction warning came on while driving, then when i turned off car it would not restart for several times. It took about 5X before the car starts again and the warning light is gone.
That’s exactly what is happening to ours. How many miles does your Armada have?
 

·
Registered
Joined
·
4 Posts
That’s exactly what is happening to ours. How many miles does your Armada have?
We have around 23k miles. Never had any issues and then all of a sudden yesterday this started. I called the dealership and they said they think they've heard of this issue and are going to take a look at it Friday. Fingers crossed they can figure it out and that it's all covered under warranty. Very frustrated to be having this issue on a pretty new car.

Also similar to you we have the platinum package, and it's a 2018.
 

·
Super Moderator
Joined
·
5,165 Posts
This does sound like its something the dealer should look into, especially if it’s happening on a newish model car.
 

·
Registered
Joined
·
7 Posts
We have around 23k miles. Never had any issues and then all of a sudden yesterday this started. I called the dealership and they said they think they've heard of this issue and are going to take a look at it Friday. Fingers crossed they can figure it out and that it's all covered under warranty. Very frustrated to be having this issue on a pretty new car.

Also similar to you we have the platinum package, and it's a 2018.
You should be under warranty. 3 years 36k miles. I however am 5k miles outside of warranty which is infuriating. Sounds like it’s something that should be recalled if we are all having the exact same issue.
 

·
Registered
Joined
·
4 Posts
You should be under warranty. 3 years 36k miles. I however am 5k miles outside of warranty which is infuriating. Sounds like it’s something that should be recalled if we are all having the exact same issue.
We're taking it in Friday, I will update here when I find out exactly what they say is wrong. Definitely sounds like a possible recall issue.
 

·
Registered
Joined
·
7 Posts
We're taking it in Friday, I will update here when I find out exactly what they say is wrong. Definitely sounds like a possible recall issue.
Yes, please do! I had an appointment to take mine in today, but cancelled it because I thought the issue had stopped. My wife said it’s happening again today. So mad!!
 

·
Registered
Joined
·
4 Posts
Yes, please do! I had an appointment to take mine in today, but cancelled it because I thought the issue had stopped. My wife said it’s happening again today. So mad!!
I just got Armada back from dealer. They have seen this issue multiple times and sometimes have to replace the brake sensor and sometimes just have to reset to warning. They just reset the warning light for me and so far haven't seen the problem again. I have a feeling I'll be taking it back to replace the brake, we'll see.
 

·
Super Moderator
Joined
·
5,165 Posts
Yep the brake sensor is the culprit. Most likely you’ll be back to replace it. Ive seen this issue discussed a couple times here on this forum alone and the solution was a faulty brake sensor.
 

·
Registered
Joined
·
1 Posts
Today while I was driving suddenly the BCI malfunction light came ON. I had to turn the engine off and fire it up again to make it go away. Anyone have this come up? Not sure why it popped up. Backup camera and sonar is functional.
i even have the BCI. Well I didn’t know what was it but i tested my car it turned out that it does something with the car sensors. It is better to go chick it out before something wrong happens👍
 

·
Registered
Joined
·
2 Posts
I just got Armada back from dealer. They have seen this issue multiple times and sometimes have to replace the brake sensor and sometimes just have to reset to warning. They just reset the warning light for me and so far haven't seen the problem again. I have a feeling I'll be taking it back to replace the brake, we'll see.
This issue for me has been ongoing since I had the vehicle. Left me stranded with the car not starting. Dealer had my car 4 times changed the battery the first time... second the brake switch... 3rd time said the brake switch they replaced must have been bad. Now they 4th just flew in a master mechanic from Nissian to look This chronic problem who said since he cannot replicate the problem he cannot suggests any repairs... 20 min after my case owner at Nissian North america calls me to tell me this the dealer calls me and says we found the issue it’s the ABS control assembly... however Nissian will not fix this under warranty for me and it’s a $4,500 job.... part number suggested by Nissian is 46007-5ZA9C... I have read in this thread that this did not fix someone else issue. I have called a lawer sounds like enough folks here having Same issue and I am sure there are more out there. maybe class action suit is they way to go. I just got my car back last week after Nissian had if for almost a month and I just replicated the problem in less then a week. Car won’t start will have Nissian come tow this POS and hopefully do the right thing and fix what they believe the issue is. My take on it is Nissian knows there is an issue but is turning their heads because the fix must be expensive and a recall could cost them a lot of money to fix the real problem.
 

·
Registered
Joined
·
9 Posts
New guy here, my wife got a 2017 Armada platinum and we encountered that BCI malfunction warning light, first of all that is the Back Up Collision Intervention, so it shouldn't be in the front bumper, but that is the least of the issues.

Our Armada would not have any of the symptoms you guys describe, it would still run fine, it was just the warning light, then suddenly one day it was hard to start, it would remote start, but once you got in and pressed the brake pedal and push the start button it would shut down. It did this a few times to my wife and it would eventually start again, so yes it was the brake light switch, our Armada was 35.5k just outside of the warranty and I just bought the switch ($65) and replaced it in like less than 30 seconds, we had the BCI malfunction warning light show up a few times since but is not letting us stranded or unable to start the truck. Good luck peeps!
 

·
Registered
Joined
·
1 Posts
Is there more than one switch? One shop I took ours to said there was two brake switches. Also do you have the part number for the switch?

New guy here, my wife got a 2017 Armada platinum and we encountered that BCI malfunction warning light, first of all that is the Back Up Collision Intervention, so it shouldn't be in the front bumper, but that is the least of the issues.

Our Armada would not have any of the symptoms you guys describe, it would still run fine, it was just the warning light, then suddenly one day it was hard to start, it would remote start, but once you got in and pressed the brake pedal and push the start button it would shut down. It did this a few times to my wife and it would eventually start again, so yes it was the brake light switch, our Armada was 35.5k just outside of the warranty and I just bought the switch ($65) and replaced it in like less than 30 seconds, we had the BCI malfunction warning light show up a few times since but is not letting us stranded or unable to start the truck. Good luck peeps!
Is there more than one switch? One shop I took ours to said there was two brake switches. Also do you have the part number for the switch?
 

·
Registered
Joined
·
9 Posts
Is there more than one switch? One shop I took ours to said there was two brake switches. Also do you have the part number for the switch?
Not at the moment, I'll look into it tomorrow when I get back home, the brake light switch is the one that the brake pedal pushes and if you crawl under the dash and follow the brake pedal you will see it, one thing I did notice is that the new part had a different color, maybe an updated part to differentiate from the old one.

Oh and yes there are two, the one I replaced was the one on the top. After you remove the plug is just a twist lock, like I said <30 seconds. Once I removed the first thing I noticed was the different color and different part number printed so obviously this was an updated part I got. I will update the part number when I get home.
 

·
Registered
Joined
·
9 Posts
Sorry couldn't find the receipt with the actual part number, just go to the Nissan dealership and buy one, that's what I did, the other sensor is for the cruise control I believe. Good luck!
 

·
Premium Member
Joined
·
46 Posts
We encountered this BCI issue today
"BCI MALFUNCTION"

I'm calling the dealership tomorrow. It's weird so many people are now having this problem.
 
21 - 40 of 81 Posts
Top