Nissan Armada & Infiniti QX56 Forums banner
141 - 160 of 161 Posts

·
Registered
Joined
·
4 Posts
Try to remote start it with the fob... when my brake switch failed, it would always start remotely... that should rule out the starter...
Great idea!! I will try it next time! Thanks!

All went well, it's very easy. Just give it a 1/4 turn to get it in and out. I haven't seen the 'BCI Malfunction' warning show up since. Here's where I bought it from, it came to $45 shipped:

2003-2020 Nissan Stoplamp Switch 25320-AX10A | Nissan Parts Plus
Great, thanks so much!!! Also when the BCI Malfunction came on, it wouldn't let me use my cruise control. Should I purchase one of those too?
 

·
Registered
Joined
·
4 Posts
Try to remote start it with the fob... when my brake switch failed, it would always start remotely... that should rule out the starter...
Well, it happened again yesterday, and low and behold, the remote starter started it right up! When I got home (drove for about 15 min) I pulled into the garage and tried restarting after I turned it off, and it wouldn't turn back on. I'm still waiting to hear from the 800-Nissan1 representative to see if they will fix it, but I am planning to buy the brake lamp switch from O'Reilly today after work. I gave her the Sku number for the one listed from someone else. It came back with Import Direct and sku number of 18-1843 for $25. Should I buy that one, or just order the one for 50 online?
 

·
Registered
2019 Armada SL
Joined
·
72 Posts
Well, it happened again yesterday, and low and behold, the remote starter started it right up! When I got home (drove for about 15 min) I pulled into the garage and tried restarting after I turned it off, and it wouldn't turn back on. I'm still waiting to hear from the 800-Nissan1 representative to see if they will fix it, but I am planning to buy the brake lamp switch from O'Reilly today after work. I gave her the Sku number for the one listed from someone else. It came back with Import Direct and sku number of 18-1843 for $25. Should I buy that one, or just order the one for 50 online?
It's hard to tell if that is the revised design (whatever that may be) or the old design. Might be worth the extra few bucks to just be done with the problem.
 

·
Registered
Joined
·
4 Posts
It's hard to tell if that is the revised design (whatever that may be) or the old design. Might be worth the extra few bucks to just be done with the problem.
Thank you. I ordered it online. I wasn't too concerned about the price, just more the fact I could get it taken care of sooner and not have to wait for the delivery! Thanks so much for everyone's help! Hopefully this fixes me up and I'm good to go!!
 

·
Registered
Joined
·
1 Posts
Okay this forum has been very informational! I am a bit confused with the part names... Let me start off by saying my issue has had no functional issue except that there the BCI orange light is on (i'll count my blessings). A couple of days later my check engine light came on but it seems to be unrelated as the code reads my catalytic converters are bad. so which part should I start with?
Stop lamp switch
brake switch
Brake light switch
Stoplight switch

HELP!
 

·
Registered
Joined
·
1 Posts
I'm also having problems with my 2019 Armada. BCI malfunction with all lights going crazy and car jerking. Thid car not always starting when button pressed, using remote start mostly. All these problems after warranty has now expired. Feel stupid buying this truck with all the other options out there. Too much money not to have a reliable vehicle. Got to figure out how to unload this thing. Very disappointed and won't buy another Nissan product!!
 

·
Registered
Joined
·
1 Posts
I'm also having problems with my 2019 Armada. BCI malfunction with all lights going crazy and car jerking. Thid car not always starting when button pressed, using remote start mostly. All these problems after warranty has now expired. Feel stupid buying this truck with all the other options out there. Too much money not to have a reliable vehicle. Got to figure out how to unload this thing. Very disappointed and won't buy another Nissan product!!
Update: 2/28/2022 - FIXED! Read update at bottom of this post.

I have had this same issue. BCI malfunction, My car wouldn't start sometimes, My cruise control not working, etc.. all the signs in this long thread and my dealer kept telling me it was related to the fuel system and kept resetting the computer. I believe this thread fixed my problem. The fix was pretty simple too.

Just need to buy that brake sensor which for my 2017 Armada, I bought this one on amazon for $19: Amazon.com: Wai Danie Brake Light Switch Lamp Compatible with 25320AX00C 25320-AX10A 2011962 25320AX008 : Automotive

and then I found this video on YouTube which shows how easy it is to replace. Literally the hardest part is situating your body so you can look under the steering wheel area:

On my 2017 Armada it was the black switch which is above the red one. It is a tight twist to take off but its really that simple. when you put the new one back in, just make sure it basically lines up with the other switch button thingy.

Good luck and Thank you Club Armada for the fix! I was pulling my hair out and definitely not enjoying my Armada anymore. I have been dealing with this for over a year and it was getting worse and worse every day. I did also notice the old switch button didn't feel smooth if I pressed it in. like it was definitely worn out, damaged or something.

I just fixed it today, but everything has worked perfectly so far. will update if that changes! Good luck and thanks again!

Update: 1/12/2022 - Last night when going through a drive through lane, the warning lights came back on "BCI Malfunction". I turned off/on the car and it cleared up. no issue starting again. Wonder if maybe there is another issue as well. Maybe the cruise control switch next to the brake switch?

Update 1/23/2022 - I am almost constantly still getting the "BCI Malfunction" warning and cant use Cruise Control. The starting issue has been fixed with the brake switch. I have no idea how to fix this warning. Very frustrating.

Update: 2/28/2022 - 😃 I Think it is finally FIXED! 😃 🤞 I Replaced the Cruise Control Switch as well about 3 weeks ago and have not had the BCI Malfunction happen since. 🤞 I ordered the part from ebay: it was labeled as "Brake Switch Cruise Cancel / Clutch Safety Switch Fit for Nissan Murano Rogue" Brake Switch Cruise Cancel / Clutch Safety Switch Fit for Nissan Murano Rogue | eBay , GOOD LUCK!!
 

·
Registered
Joined
·
1 Posts
Today while I was driving suddenly the BCI malfunction light came ON. I had to turn the engine off and fire it up again to make it go away. Anyone have this come up? Not sure why it popped up. Backup camera and sonar is functional.
Hello. Try to disable the BCI through setting, driver's assist. It might work. That's what I did to 2019 Armada.
Today while I was driving suddenly the BCI malfunction light came ON. I had to turn the engine off and fire it up again to make it go away. Anyone have this come up? Not sure why it popped up. Backup camera and sonar is functional.
Try to disable the BCI through setting - driver' assist. It might work. That's what I did to my 2019 Armada
 

·
Registered
Joined
·
1 Posts
So I've had the same issues as everyone else. It started with random no starts and then went to dead battery at times. Then the dreaded bci malfunction and various warning dash lights. I found this forum and disassembled and cleaned the sensors without luck. (I found later that I installed them incorrectly so this may have worked initially had I known) I then ordered aftermarket brake and cruise sensors. Swapped them out and drove it around with no bci malfunction for a couple days before blam it hit again. I checked the radars for mud and found nothing obstructing it. I checked the brake and cruise sensors and found both were bottomed out when I installed them. I reinstalled without putting the brake down first and twisted them in at that depth with the brake pedal in its natural position (not all the way down). I found there's quite a difference there. I immediately could tell the brakes weren't dragging or getting hot. If you're armada doesn't slowly roll forward with it in gear and the brakes not on then they are probably dragging. I drove it about an hour or so and the error hasn't returned. I think there are 2 issues going on here the first is a bad brake sensor and the second is an improperly installed replacement. This may be why they keep failing. Only install the sensor with the brake pedal in its natural position not pressed down. If you want to check if your Sonar and radar are working properly just put a rubber trashcan behind your car on one side and then the other and finally in the middle. Back towards it with the bci on and it will show you if it detects the object in each position and warn you followed by pressing the brakes momentarily. If they aren't working you will get no warning.
 

·
Registered
Joined
·
1 Posts
Old thread, ongoing issue, I have the same issue with my 18 Armada, except we found out about it because my wife couldn't get the vehicle to start, it went into ACC mode. after a bunch of self diagnostics i decided to jump start it, didn't think it would work, but the truck did start, and that is when the dash started going crazy. drove it around the block and back home, shut it off and tarted it back up and everything cleared up. Now i occasionally get BCI malfunction, that clears after restarting. I just don't feel like having Nissan service jerking me around, that's why i haven't brought it in yet.
Sooo here we are again...whatever happened to the BCI error? Just the 1 time?
 

·
Registered
Joined
·
1 Posts
Came across this particular thread as we're looking to purchase a 2017 Armada Platinum, 87,XXX miles. During our second test drive, we took it into an empty parking lot for my wife to figure out how well she could park it, about two miles from (Volvo) dealership. About four lights came on: collision, 4WD, CEL, and ABS. I shut it off for about ten seconds and turned it back on. It took a few extra seconds for the engine to turn over. Then, 8 lights came on adding the master warning light and a couple others. I pressed the gas pedal all the way to the floor, and didn't get any response beyond idle speed, whether in forward or reverse. Contacted dealer via text and phone call, telling him we were stuck. I idle-limped it across the street to another parking lot and shut it off and waited two minutes. Then, it started, and only the CEL was on, and was able to drive it back to the dealership.

The dealership took it in back to run the codes, and per the Used Car Manager, all the historical codes were related to Low Voltage. They put a new battery in, and all the lights were off. Used Car Manager came back and said he felt pretty confident that the new battery would fix it. I asked him to check the alternator as well. He came back a half hour later and said that he turned it on, turned on all the accessories and AC, and started it up, and they were concerned with a power leak. Tomorrow they're taking it to their sister Nissan dealership next door to run full scans.

Through reading through this thread, the symptoms we experienced seem a bit different than most of the ones listed here, with some similarities. Anyone else experienced the symptoms we did along with the other named symptoms?
 

·
Registered
Joined
·
1 Posts
Just bought a 2019 Armada SL with 48K miles on it. Drove it for approximately 2.5 weeks and started encountering an issue with the car firing up when pressing the ignition button. Then the dashboard lights started and finally the dreaded BCI malfunction came on. Took it to my local Nissan dealership and they ran their diagnostics. Told me the battery voltage was very low and a sensor harness had to be replaced. They said this should fix the problem. I took their word for it, but got curious about the BCI malfunction issue and came across this thread and others. Well, a day and a half later and the BCI malfunction is back! Started with the car not turning on right away and once it did, the dashboard started lighting up, same warnings as everyone is seeing. I took it back to the Nissan dealership and told them to look into this forum for tips on how to resolve the issue.

Questions:
1) What's the best way to fix this? What seems to be the most successful fix? I don't care if it's something i need to do again every so often, but i'd like to get the issue resolved.
2) Is the BCI malfunction issue a risk to safety? From what i've read it can be, so i'm concerned i could be putting my family at risk. It seems to come on only while driving, not when i turn the car on initially. Could it cause an accident?
3) For those that have gone through this, do you regret your Armada purchase? I'm still within 30 days of my purchase and could potentially figure out a way out of the purchase if i need do.
4) I purchased an extended bumper to bumper warranty with my Armada. Should i keep it? It doesn't seem to help me with this issue, but could help with other issues if they arise.

Thanks!

Hello. Try to disable the BCI through setting, driver's assist. It might work. That's what I did to 2019 Armada.

Try to disable the BCI through setting - driver' assist. It might work. That's what I did to my 2019 Armada
How do you disable it? I've tried finding a way to do this and have had no luck.

How do you disable it? I've tried finding a way to do this and have had no luck.
Nevermind, i found it. Funny, the manual calls it the I-BI system.
 

·
Registered
Joined
·
2 Posts
Well.....my 2017 Armada Platinum got the stupid BCI Malfunction warning. Here is how I fixed it. Earlier, I was having trouble just getting the vehicle started. I had to pump the brake multiple times and then push the Start button and it would fire. Now, I couldn't even do that......I searched online, found this thread and read it Front to Back. I played with both pin switch sensors for the brake pedal. I unmounted both of them and them dangle by the brake pedal = Truck would start everytime without fail. After some trial and error, the TOP pin switch (brake one I think) only needs to be installed so far in until the 3rd brake lamp no longer lights up on the tailgate. The BOTTOM pin switch I re-installed all the way in and took it for a test drive. After about a mile, the Damn BCI Malfunction warning came back, but this time, only the Yellow triangle warning indicator and 1 other light came on (not like previous times where the dash was lit up like a Christmas tree and I couldn't get the truck to downshift even with gas pedal pushed through the floorboard!). I ended up through trial and error backing off the BOTTOM pin switch ever so slightly, lock it down and go for a test drive. No matter where it was set, the BCI Malfunction warning came back, I ended up ordering both switches from Rock Auto last week and installed both today. I installed the TOP pin switch as before so that the 3rd brake light on the tailgate no longer illuminates. The BOTTOM pin switch, I installed it about half way (guessing) and locked it down. Took truck for a test drive and low and behold - NO MORE BCI Malfunction Warning! I have tested driving the truck at least a dozen times already - everything works fine, no lights on dash, truck accelerates and brakes normally, no power loss, etc.....

Hope this helps anyone still trying to figure out their issue......

Toys
 

·
Registered
Joined
·
1 Posts
If you haven't scanned the codes, then you need to. Long cranks like that are usually the result of a failing cam or crank sensor. If you have scanned and the only codes are "garbage codes" like C1130, then it's likely your ECM Relay is dropping out. That shuts down the ECM and makes all the other systems squawk, but the ECM itself doesn't know anything is wrong and won't have any codes in it.
BCI Malfunction Nissan Armada – Can You Deal with It?
 

·
Registered
Joined
·
2 Posts
UPDATE - 3 Days later.........

Everything is still good! Have taken truck on short drives, backroads, highway speeds, long drives and no BCI Malfunction warning at ALL!!
I am certain, where the 2 sensors are "locked" in at makes a difference.
Good Luck to the rest of you folks!

Laterz,
Toys
 

·
Registered
Joined
·
1 Posts
Hello fellow armada owners, I too have experienced the BCI malfunction error code on my 2020 Nissan armada. I am thinking about bringing it into a Nissan dealer to have them examine the car. What next steps would you recommend in telling the dealership to navigate the problem? Does anyone have any recent updates? Thanks, Tim
 

·
Administrator
Joined
·
6,683 Posts
if you already have a plan to go to the dealer, then do that. let them diagnose the car, connect the consult to the car and pull any codes, then you can come here and tell us the codes, if any, and the next steps. many times you can replace certain things yourself if you have the time.
 

·
Registered
Joined
·
1 Posts
BCI problem with 2017 armada. All warning lights come , sensors. 4 wheel drive won’t engage went lights come on . Is that something other people have noticed? Live in the northeast so it’s a big problem.
 
141 - 160 of 161 Posts
Top