Nissan Armada & Infiniti QX56 Forums banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
2 Posts
Discussion Starter #1
Just wanted to start this post regarding this problem that alot of Armada/Titan owners are experiencing. This trouble is a known problem from Nissan and they Resurfaced and Rotated my rotors. I was supposed to get new brakes also but I don't think so. Vehicle Stats: 2004 Armada SE Off Road @ 5000 Miles!!
 

·
Premium Member
Joined
·
1 Posts
Brakes?????

Hi Folks! I've been a very proud 05 Armada owner since December 04. Here's my problem. At just 4500 miles, when braking from 40 mph or so, I'm experiencing front end shaking/tremling. Wasn't sure if the problem was due to road damage after recent salting and snow removal. Please tell me what you think.
 

·
Administrator
Joined
·
5,215 Posts
This is the most discussed topic on this forum. There are hundreds of posts about the brake judder. You should take your Armada to your dealer for the fix. If you would like more details do a search here for brakes.
 

·
Premium Member
Joined
·
1,431 Posts
scr38 said:
This is the most discussed topic on this forum. There are hundreds of posts about the brake judder. You should take your Armada to your dealer for the fix. If you would like more details do a search here for brakes.

And every other forum dealing with the Armada/Titan. :teeth:
 

·
Premium Member
Joined
·
1,258 Posts
Breaks Vibrating When Breaking!?
At first I thought he meant Brakes.
Then I thought about it and it should read,
"Brakes Break when breaking".

Get it?
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
5 Participants
andy
Nissan Armada & Infiniti QX56 Forums
Club Armada is the premier Nissan Armada forum! Here you can discuss and review your favorite SUV with fellow owners.
Full Forum Listing
Top