Nissan Armada & Infiniti QX56 Forums banner

1 - 11 of 11 Posts

·
Premium Member
Joined
·
84 Posts
Discussion Starter #1
I have an 05 SE and I noticed the other day a strange clicking sound like a relay going on and off every 4~5 seconds when the inside air blower was on. It went away when I turned it off. I did not have AC on at that time and I noticed it when the vehicle was parked and idling. Has any one else experienced this? thx.
 

·
Premium Member
Joined
·
1,431 Posts
There is something screwey with how the AC works, if you turn on the defrost for more than 90 seconds (I think that the time) the AC will stay on regardless on what you do with the contorls until you turn off the ignition. I'm guessing you may of been hearing the AC cycle even though you had it turned off???
 

·
Administrator
Joined
·
5,215 Posts
I'm not sure about this, but I think there is a Federal safety regulation that the AC must operate (it cycles) when the defroster is on. This prevents sudden fogging of the windows when the defroster is turned on. The AC removes moisture that will condense on the inside of the glass.
 

·
Premium Member
Joined
·
84 Posts
Discussion Starter #5 (Edited)
I checked it again and there appears to be no correlation between the radiator fan and the clicking sound. I also first thought it is the defroster but I tried other settings too and as soon as I turn on the blower even without defroster I start hearing this clicking sound. It goes away as soon as I turn the blower off. One more thing, it is raining these days in northern california so I dont know if there is any correlation to that. I have made a service appointment and we will see what the dealer says about it.
 

·
Premium Member
Joined
·
1,431 Posts
changezi said:
I have made a service appointment and we will see what the dealer says about it.
I can almost gaurantee you'll get the service ticket back with a "could not duplicate" :rolleyes: Unless you are one of the lucky few who gets a tech who actually cares..good luck.
 

·
Premium Member
Joined
·
84 Posts
Discussion Starter #7
I was able to reproduce the clicking sound for the service writer. I also mentioned another clicking sound inside the cabin when I put the vehicle in 4WD auto. The tech told me that Nissan service line has told them that they are aware of this clicking sound in some Armadas but there is no fix for it yet. For the 4wd auto ticking noise, they told me to either leave the vehicle at dealership overnight or bring it tomorrow morning so that their foreman tech can take a look but they wont give me a rental car because they say they dont know what is the fix or how long the fix will take. I do have extended warranty on my vehicle and I was told I should get a rental for service dropoffs requiring more than two hours of work. Any suggestions?
 

·
Premium Member
Joined
·
163 Posts
With all due respect to Nissan service techs, get your damn rental. While I might not get all of my problems fixed, I don't even have to bother asking for a rental at my dealership. Hell, three of the Enterprise workers know me by name! The manager makes sure to put me in a decent car or SUV (even though I'm supposed to be in a compact car) since I have been up there so many times. Take my advice and get your money's worth for your warranty. Nissan might not like it, but they will continue to see me for the next 70,000 miles as long as I have issues ;)
 

·
Premium Member
Joined
·
1,431 Posts
changezi said:
I do have extended warranty on my vehicle and I was told I should get a rental for service dropoffs requiring more than two hours of work. Any suggestions?
I was told the exact same thing. The last time I asked for rental vs. their shuttle (which makes me miss 2 hours of work) they said "the EW rental is only if we have diagnosed the problem and are replacing a warrantied part". So another words the best you can probably hope for is to get a rental the day after you drop of your vehicle :mad:
 

·
Premium Member
Joined
·
84 Posts
Discussion Starter #10
Here is the update - The foreman technician told me that since 2003, Nissan has changed their computer logic. This means that everytime that you turn on any defroster settings, it will automatically turn on the ac for defrost. It will not only turn on the ac but it will lock the ac on for as long as the engine is running even if you change the blower settings back to a non defrost position. The only way to get rid of that clicking is turn off the engine, turn off the blower or turn it to a non defrost setting and turn the engine back on. He did the same thing and the clicking sound went away. He also told me that since Nissan did not communicate this info to them before making the change, they changed several AC units for this clicking noise before they called nissan and nissan informed them of this change. As for the clicking inside the cabin for 4wd auto, it has disappeared and for now I am blaming my "over sensitive imagination" :confused: .
 

·
Premium Member
Joined
·
163 Posts
so is there going to be a tsb for that? seems like a bad enough issue to require one. talk about a waste of gas, especially on a long trip (and when the ac isnt needed after a while). I might take mine in soon..
 
1 - 11 of 11 Posts
About this Discussion
10 Replies
5 Participants
OffRoadinArmada
Nissan Armada & Infiniti QX56 Forums
Club Armada is the premier Nissan Armada forum! Here you can discuss and review your favorite SUV with fellow owners.
Full Forum Listing
Top