Nissan Armada & Infiniti QX56 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Good morning,
Have a 2015 Armada. It has a problem with the climate control, when You turn on the passenger A/C it still blows warm air, and will make a chattering noise behind the dash. Any ideas?

Thank You!
 

·
Premium Member
Joined
·
3,411 Posts
Sounds like one of your HVAC blend doors has stopped working. This is a problem that has occurred before, and can be difficult (and expensive) to fix. There are a lot of threads about this problem. To replace some of the blend doors requires removal of the dash.

Keith
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Sounds like one of your HVAC blend doors has stopped working. This is a problem that has occurred before, and can be difficult (and expensive) to fix. There are a lot of threads about this problem. To replace some of the blend doors requires removal of the dash.

Keith
Thank You very Much! I was kind of afraid of that.
 

·
Premium Member
Joined
·
3,411 Posts
Were you able to find any other threads on this issue? Like I said, this isn't the first time this has happened. If you can't find exactly what you're looking for, take a look over at titantalk.com, that is a much more active forum that this one, and there is a lot of commonality between the 1st gen Armada and the early Titans.

Keith
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Were you able to find any other threads on this issue? Like I said, this isn't the first time this has happened. If you can't find exactly what you're looking for, take a look over at titantalk.com, that is a much more active forum that this one, and there is a lot of commonality between the 1st gen Armada and the early Titans.

Keith
I have found a few! Haven't had much time to look today, I am seeing about the same thing You were talking about. Appreciate the info.
 

·
Registered
Joined
·
14 Posts
Thank You very Much! I was kind of afraid of that.
YIKES!!! I did this repair few years ago on our old Armada. $$$$$$$$$. Entire dash comes out and they take them all out to see which is broken! We had them all replaced. Such a cheaply made part!!! Wife got annoyed with repairs occurring she had me get a new one. Now...no AC issue. But expect a huge repair bill
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
YIKES!!! I did this repair few years ago on our old Armada. $$$$$$$$$. Entire dash comes out and they take them all out to see which is broken! We had them all replaced. Such a cheaply made part!!! Wife got annoyed with repairs occurring she had me get a new one. Now...no AC issue. But expect a huge repair bill
Actually it started working on it's own! I hope it was just something blocking it. Usually not My luck though.
 
1 - 8 of 8 Posts
Top